isis/ospf redistribution scenario

From: Debbie Westall (dwestall@debbie.coxfiber.net)
Date: Sat Dec 27 2003 - 18:08:26 GMT-3


I'm working on a scenario with OSPF and IS-IS redistribution. I managed to
get it working but I don't understand why. Maybe you could take a look and
help me.....

 ------- -------- --------
| R2 | -----------------------| R1 |-----------------------| R4 |
-------- -------- ---------

R2 is OSPF
R1 is OSPF and ISIS
R4 is ISIS

My redistribution point is R1. Here is my configurations:

R1
interface Loopback0
ip address 192.100.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.14 point-to-point
description Link to R4
ip address 172.16.14.1 255.255.255.0
ip router isis
frame-relay class FREEK
frame-relay interface-dlci 104
!
interface Serial0/0.123 multipoint
description Link to R2 & R3
ip address 172.16.123.1 255.255.255.0
ip ospf network point-to-multipoint
frame-relay map ip 172.16.123.1 102
frame-relay map ip 172.16.123.2 102 broadcast
frame-relay map ip 172.16.123.3 103 broadcast
!
router ospf 1
log-adjacency-changes
area 0 authentication message-digest
area 10 stub
redistribute connected subnets
redistribute isis level-2 subnets
network 172.16.10.0 0.0.0.255 area 10
network 172.16.12.0 0.0.0.255 area 0
network 172.16.123.0 0.0.0.255 area 0
network 192.100.1.1 0.0.0.0 area 0
!
router isis
net 00.0000.0000.0000.0001.00
redistribute connected
redistribute ospf 1
is-type level-2-only

R2
interface Loopback0
ip address 192.100.2.2 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description Link to R1
ip address 172.16.123.2 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-point
ip ospf hello-interval 30
ip ospf priority 0
frame-relay map ip 172.16.123.1 201 broadcast
frame-relay map ip 172.16.123.2 201
frame-relay map ip 172.16.123.3 201 broadcast
!
interface Serial0/1
description Link to R6
ip address 172.16.26.2 255.255.255.0
encapsulation ppp
no peer neighbor-route
clockrate 64000
dce-terminal-timing-enable
!
router ospf 1
log-adjacency-changes
area 0 authentication message-digest
area 26 virtual-link 192.100.6.6
network 172.16.12.0 0.0.0.255 area 0
network 172.16.26.0 0.0.0.255 area 26
network 172.16.123.0 0.0.0.255 area 0
network 192.100.2.2 0.0.0.0 area 0

R4
interface Loopback0
ip address 192.100.4.4 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
no ip address
encapsulation frame-relay
!
interface Serial1/0.14 point-to-point
description Link to R1
ip address 172.16.14.4 255.255.255.0
ip router isis
frame-relay class FREEK
frame-relay interface-dlci 401
!
interface Serial1/1
description Link to R5
ip address 172.16.45.4 255.255.255.0
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router isis
net 00.0000.0000.0000.0004.00
is-type level-2-only
!
ip classless
ip http server
!
!
map-class frame-relay FREEK
frame-relay end-to-end keepalive mode bidirectional
no frame-relay adaptive-shaping
!

Until I added the redistribute connected under the ospf and is-is I could
see the routes on R4 but they were not pingable. I could not see R4's
routes on R2 at all. I don't understand why I would need to redistribute
the connected.

I know there has been some discussion about this on several lists, but I
was not able to find the threads I was looking for.

Can you help explain or point me to a link for explanation?

Thanks Much

Happy New Year!!!

Debbie



This archive was generated by hypermail 2.1.4 : Sat Jan 03 2004 - 08:25:45 GMT-3