Re: ISIS Problem

From: Richard Davidson (rich@myhomemail.net)
Date: Sun Dec 14 2003 - 21:48:02 GMT-3


Please correct me if I'm wrong. I think R2 (spoke)
can only peer with R4 (the hub). CLNS is a layer 2
protocol. You are atempting to configure it as if it
were a layer 3 protocol and R4 (the hub) will route
the traffic to the other spokes. I don't think it
works that way. You can only peer R2 with R6, and R3
if you have a layer 2 connection.

This is what you have
*********************
R4------R3
| |
| |-----R2
|
R6

--- "Charles T. Alexander"
<charles.t.alexander@verizon.net> wrote:
> I am having problems bringing up r2 in ISIS, the
> other are up and exchanging routes.
>
> r2---|---r6
> |
> frame
> |
> r5---|---r4
>
>
>
> r2#i
> Codes: C - connected, S - static, I - IGRP, R - RIP,
> M - mobile, B - BGP
> D - EIGRP, EX - EIGRP external, O - OSPF, IA
> - OSPF inter area
> N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA external type 2
> E1 - OSPF external type 1, E2 - OSPF external
> type 2, E - EGP
> i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> level-2, ia - IS-IS inter area
> * - candidate default, U - per-user static
> route, o - ODR
> P - periodic downloaded static route
>
> Gateway of last resort is not set
>
> 137.10.0.0/16 is variably subnetted, 4 subnets,
> 3 masks
> C 137.10.2.0/24 is directly connected,
> Loopback0
> O 137.10.1.1/32 [110/11] via 137.10.125.1,
> 00:17:17, Ethernet0
> C 137.10.100.0/27 is directly connected,
> Serial0
> C 137.10.125.0/24 is directly connected,
> Ethernet0
> O 192.176.0.0/24 [110/11] via 137.10.125.100,
> 00:17:17, Ethernet0
> O 192.176.1.0/24 [110/11] via 137.10.125.100,
> 00:17:17, Ethernet0
> O 192.176.2.0/24 [110/11] via 137.10.125.100,
> 00:17:17, Ethernet0
> O 192.176.3.0/24 [110/11] via 137.10.125.100,
> 00:17:18, Ethernet0
> r2#
>
> ______________________________________________
>
> r2#r
> Building configuration...
>
> Current configuration : 2151 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r2
> !
> boot system tftp r2-ios-image 137.10.74.62
> logging buffered 10000 debugging
> enable password radnor
> !
> username r5 password 0 ctasta
> ip subnet-zero
> no ip domain-lookup
> ip host r1 137.10.125.1
> !
> isdn switch-type basic-ni
> !
> !
> !
> interface Loopback0
> ip address 137.10.2.2 255.255.255.0
> ip router isis
> !
> interface Ethernet0
> backup delay 5 60
> backup interface BRI0
> ip address 137.10.125.2 255.255.255.0
> ip ospf hello-interval 1
> ip ospf priority 0
> !
> interface Serial0
> ip address 137.10.100.2 255.255.255.224
> ip router isis
> encapsulation frame-relay
> frame-relay map clns 104 broadcast
> frame-relay map ip 137.10.100.2 104
> frame-relay map ip 137.10.100.4 104 broadcast
> frame-relay map ip 137.10.100.6 104 broadcast
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> !
> interface Serial1
> no ip address
> shutdown
> !
> interface BRI0
> ip address 137.10.25.2 255.255.255.252
> encapsulation ppp
> dialer map ip 137.10.25.1 name r5 broadcast
> 4082222222
> dialer load-threshold 99 either
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 40811111111
> isdn spid2 40811111112
> no peer neighbor-route
> no cdp enable
> ppp authentication chap callin
> ppp multilink
> hold-queue 25 in
> !
> router ospf 1
> router-id 137.10.2.2
> log-adjacency-changes
> timers lsa-group-pacing 600
> network 137.10.25.0 0.0.0.3 area 1
> network 137.10.125.0 0.0.0.255 area 0
> !
> router isis
> net 49.0102.2222.2222.2222.00
> is-type level-2-only
> !
> ip classless
> ip http server
> ip ospf name-lookup
> ip pim bidir-enable
> !
> access-list 101 permit icmp any any
> access-list 101 permit ip any host 137.10.125.10
> access-list 101 permit tcp any any eq bgp
> access-list 101 permit ospf any any
> dialer-list 1 protocol ip list 101
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> alias exec w write
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r2
>
> ------------------------------------------------
>
> r6#r
> Building configuration...
>
> Current configuration : 2132 bytes
> !
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> no service single-slot-reload-enable
> !
> hostname r6
> !
> logging buffered 10000 debugging
> enable password radnor
> !
> ip subnet-zero
> no ip domain-lookup
> !
> ip cef
> ip audit notify log
> ip audit po max-events 100
> !
> call rsvp-sync
> !
> !
> !
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 137.10.6.6 255.255.255.0
> ip router isis
> !
> interface Ethernet0/0
> ip address 137.10.74.6 255.255.255.192
> !
> interface Ethernet0/1
> no ip address
> shutdown
> !
> interface Ethernet0/2
> no ip address
> shutdown
> !
> interface Ethernet0/3
> no ip address
> shutdown
> !
> interface Serial1/0
> ip address 137.10.100.6 255.255.255.224
> ip router isis
> encapsulation frame-relay
> serial restart-delay 0
> frame-relay map clns 604 broadcast
> frame-relay map ip 137.10.100.2 604 broadcast
> frame-relay map ip 137.10.100.4 604 broadcast
> frame-relay map ip 137.10.100.6 604
> no frame-relay inverse-arp
> frame-relay lmi-type ansi
> !
> interface Serial1/1
> bandwidth 64
> ip address 137.10.69.6 255.255.255.240
> serial restart-delay 0
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface ATM2/0
> description 2 24 12 2
> bandwidth 149760
> no ip address
> shutdown
> atm ilmi-keepalive
> pvc 0/5 qsaal
> !
> pvc 0/16 ilmi
> !
> !
> interface ATM2/0.1 multipoint
> ip address 137.11.69.6 255.255.255.240
> atm esi-address 666666666666.00
> !
> svc 100000000000000
> protocol ip 137.11.69.6
> encapsulation aal5snap
> idle-timeout 10
> !
> !
> svc nsap
> 10.000000000000000000000000.999999999999.00
> protocol ip 137.11.69.9 broadcast
> encapsulation aal5snap
> idle-timeout 10
> !
> !
> router isis
> net 49.0426.6666.6666.6666.00
> !
> ip classless
> no ip http server
> !
> !
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> alias exec w write
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r6
>
>
-------------------------------------------------------
>
> r4#r
> Building configuration...
>
> Current configuration : 1842 bytes
> !
> version 12.2
> no service single-slot-reload-enable
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r4
> !
> logging buffered 10000 debugging
> logging rate-limit console 10 except errors
> enable password radnor
> !
> ip subnet-zero
> no ip finger
> no ip domain-lookup
> !
> no ip dhcp-client network-discovery
> !
> !
> !
> !
> interface Loopback0
> ip address 137.10.4.4 255.255.255.0
> ip router isis
> !
> interface Ethernet0
> ip address 137.10.74.4 255.255.255.192
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> no ip mroute-cache
> frame-relay lmi-type ansi
> !
> interface Serial0.5 multipoint
> ip address 137.10.45.4 255.255.255.240
> ip router isis 45
> no ip mroute-cache
> frame-relay map clns 405 broadcast
> frame-relay map ip 137.10.45.4 405 IETF
> payload-compression FRF9 stac
> frame-relay map ip 137.10.45.5 405 broadcast IETF
> payload-compression FRF9 stac
> !
> interface Serial0.26 multipoint
> ip address 137.10.100.4 255.255.255.224
> ip router isis
> no ip mroute-cache
> frame-relay map clns 401 broadcast
> frame-relay map clns 406 broadcast
> frame-relay map ip 137.10.100.2 401 broadcast
> frame-relay map ip 137.10.100.4 401
> frame-relay map ip 137.10.100.6 406 broadcast
> no frame-relay inverse-arp
> !
> interface Serial1
> no ip address
> shutdown
> !
> router isis
> net 49.0426.4444.4444.4444.00
> !
> router isis 45
> net 49.0045.4444.4444.4444.00
> is-type level-1
> !
> ip kerberos source-interface any
> ip classless
> ip http server
> !
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> alias exec w write
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> transport input none
> escape-character 27
> line 1 8
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r4#
>
>
-----------------------------------------------------------
>
> r5#r
> Building configuration...
>
> Current configuration : 2191 bytes
> !
> version 12.1
> no service single-slot-reload-enable
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname r5
> !
> logging buffered 10000 debugging
> enable password radnor
> !
> username r2 password 0 ctasta
> !
> !
> !
> !
> ip subnet-zero
> no ip domain-lookup
> !
> isdn switch-type basic-ni
> !
> !
> !
> !
> !
> interface Loopback0
> ip address 137.10.5.5 255.255.255.0
> ip router isis
> !
> interface Loopback1
> ip address 205.1.1.1 255.255.255.224
> !
> interface Loopback2
> ip address 205.1.1.33 255.255.255.224
> !
> interface Loopback3
> ip address 205.1.1.65 255.255.255.224
> !
> interface BRI0/0
> ip address 137.10.25.1 255.255.255.0
> encapsulation ppp
> shutdown
> dialer idle-timeout 0
> dialer map ip 137.10.25.2 name r2 broadcast
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 40822222221
> isdn spid2 40822222222
> no peer neighbor-route
> no cdp enable
> ppp authentication chap pap
> !
> interface Ethernet0/0
> ip address 137.10.50.5 255.255.255.0
> !
> interface TokenRing0/0
> no ip address
> shutdown
> ring-speed 16
> !
> interface Serial1/0
> ip address 137.10.45.5 255.255.255.240
> ip router isis
> encapsulation frame-relay
> no ip mroute-cache
> serial restart-delay 0
> frame-relay map clns 504 broadcast
> frame-relay map ip 137.10.45.4 504 broadcast IETF
> payload-compression FRF9 stac
> frame-relay map ip 137.10.45.5 504 IETF
> payload-compression FRF9 stac
> frame-relay lmi-type ansi
> !
> interface Serial1/1
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/2
> no ip address
> shutdown
> serial restart-delay 0
> !
> interface Serial1/3
> no ip address
> shutdown
> serial restart-delay 0
> !
> router ospf 1
> router-id 137.10.5.5
> log-adjacency-changes
> network 137.10.25.0 0.0.0.3 area 1
> !
> router isis
> redistribute connected level-1-2
> net 49.0045.5555.5555.5555.00
> !
> ip classless
> ip http server
> !
> dialer-list 1 protocol ip permit
> !
> alias exec i show ip route
> alias exec r show run
> alias exec c config t
> alias exec u undebug all
> alias exec b show ip bgp
> alias exec bs show ip bgp sum
> alias exec s show ip int brief
> alias exec w write
> !
> line con 0
> exec-timeout 0 0
> logging synchronous
> escape-character 27
> line aux 0
> line vty 0 4
> exec-timeout 0 0
> password bp
> login
> !
> end
>
> r5#
>
>



This archive was generated by hypermail 2.1.4 : Sat Jan 03 2004 - 08:25:41 GMT-3