From: Alan Halachmi (alan@halachmi.net)
Date: Sat Dec 06 2003 - 16:47:30 GMT-3
Hello!
At the end of Doyle Vol.1, Chpt. 5, there's a configuration exercise
involving RIPv1. I've included a mini-topology for the benefit of my
question:
///// TOPOLOGY \\\\\
-[(s0)RTA(e0)]--[(e0/0)RTC(s0/0)]--[(s0/0)RTD(e0/0)]--[(e0/0)RTE(s0/0)]--
RTA
s0: 192.168.2.126/27
e0: 192.168.2.193/27
RTC
e0/0: 192.168.2.194/27
s0/0: 192.168.3.1/24
RTD
s0/0: 192.168.3.2/24
e0/0: 192.168.4.3/24
RTE
e0/0: 192.168.4.1/24
s0/0: 192.168.5.193/27
\\\\\ TOPOLOGY /////
... Now... Part 2 of the configuration exercise asks that RTC and RTD
exchange information using unicast and not broadcast. So, I input the
following configuration:
RTC:
router rip
passive-interface Serial0/0
network 192.168.2.0
network 192.168.3.0
neighbor 192.168.3.2
RTD:
router rip
passive-interface Serial0/0
network 192.168.3.0
network 192.168.4.0
neighbor 192.168.3.1
A 'debug ip rip' reveals that RTC & RTD are acting as required. There are
no updates going to 255.255.255.255 over the serial connection between
these two routers. RTA and RTE are seeing one another's routes and the
192.168.3.0 route, as required. However, when I check the answer key in
the book, the configuration is different:
RTC:
router rip
network 192.168.2.0
neighbor 192.168.3.2
RTD:
router rip
network 192.168.4.0
neighbor 192.168.3.1
I tried this solution, and my IOS 12.2(19a) routers dump:
- From RTC:
00:31:57: RIP: sending v1 update to 255.255.255.255 via Ethernet0/0
(192.168.2.194)
00:31:57: RIP: build update entries - suppressing null update
00:31:57: RIP: rip_sendupdate_vk() no source specified. Set source.
00:31:57: RIP: source 0.0.0.0, mask 0.0.0.0
00:31:57: -Traceback= 80629E60 8062A4A4 8062A5E0 8049C070 8062F480 8062FA64
803692B4
With regard to the Doyle solution, my questions are:
1) Would the neighbors exchange information even though the neighbor
relationship is built over a subnet not defined by a "network" directive in
"router rip"?
2) If RTC and RTD were able to exchange routes, would they advertise
192.168.3.0 to RTA and RTE?
TIA,
Alan
This archive was generated by hypermail 2.1.4 : Sat Jan 03 2004 - 08:25:36 GMT-3