From: William Chen (kwchen@netvigator.com)
Date: Fri Nov 28 2003 - 00:30:08 GMT-3
Dear all,
I don't know if it is a valid configuration, but I can do routing and bridge together between bridged and routed interfaces by using CRB!
**********
R6#
hostname R6
!
bridge crb
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.6 255.255.255.0
bridge-group 1
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.10.6 255.255.255.0
bridge-group 1
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.6 255.255.255.0
!
!
bridge 1 protocol ieee
!
end
R7#
hostname R7
!
interface FastEthernet0/0
ip address 192.168.10.7 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.10.6
!
end
R8#
hostname R8
!
interface FastEthernet0/0
ip address 192.168.10.8 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.10.6
!
end
R9#
hostname R9
!
interface FastEthernet0/0
ip address 192.168.30.9 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.6
!
end
**********
Then, the testing part:
**********
R6#sh int crb
FastEthernet0/0
Not bridging this sub-interface.
FastEthernet0/0.10
Bridged protocols on FastEthernet0/0.10:
appletalk clns decnet ip
Software MAC address filter on FastEthernet0/0.10
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
0x2A: 0 0900.2b01.0001 0 RCV DEC spanning tree
0x9D: 0 000b.fdce.cc60 93 RCV Interface MAC address
0xC0: 0 0100.0ccc.cccc 0 RCV CDP
0xC1: 0 0100.0ccc.cccd 5 RCV SSTP MAC address
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
0xC2: 1 0180.c200.0000 0 RCV IBM spanning tree
0xC2: 2 0100.0ccd.cdce 0 RCV VLAN Bridge STP
FastEthernet0/0.20
Bridged protocols on FastEthernet0/0.20:
appletalk clns decnet ip
Software MAC address filter on FastEthernet0/0.20
Hash Len Address Matches Act Type
0x00: 0 ffff.ffff.ffff 3 RCV Physical broadcast
0x2A: 0 0900.2b01.0001 0 RCV DEC spanning tree
0x9D: 0 000b.fdce.cc60 198 RCV Interface MAC address
0xC0: 0 0100.0ccc.cccc 0 RCV CDP
0xC1: 0 0100.0ccc.cccd 2 RCV SSTP MAC address
0xC2: 0 0180.c200.0000 0 RCV IEEE spanning tree
0xC2: 1 0180.c200.0000 0 RCV IBM spanning tree
0xC2: 2 0100.0ccd.cdce 0 RCV VLAN Bridge STP
FastEthernet0/0.30
Routed protocols on FastEthernet0/0.30:
ip
Not bridging this sub-interface.
Virtual-Access1
**********
Therefore, ip is bridged among the fa0/0.10 and fa0/0.20. With CRB, normally, we can't do route between bridge group 1 and fa0/0.30. However, by assigning IP address to both fa0/0.10 and fa0/0.20, I can make it works:
**********
R7#p 192.168.10.8 (Bridge)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
R7#p 192.168.30.9 (Route)
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.9, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
**********
Interesting?
Best Regards,
William Chen
This archive was generated by hypermail 2.1.4 : Fri Dec 12 2003 - 12:29:19 GMT-3