From: Tim Fletcher (groupstudy@fletchmail.net)
Date: Mon Oct 27 2003 - 12:39:44 GMT-3
Good solution. Another way to accomplish would be to use a rotary. You are
limited to ports 3001-3099, but as long as that's not an issue:
line vty 0 4
rotary 8
Then telnet to port 3008.
-Tim
At 09:15 AM 10/27/2003 -0600, Michael Snyder wrote:
>While this is pretty simple to do, it took me a while to figure it out.
>
>My service provider blocks tcp 23, which means I couldn't access my
>office router from home.
>
>It became a problem when I needed to reset office dmz servers via
>telnet.
>
>Below is the sample config,
>
>I'm relocating the loopback telnet tcp 23 to the public interface tcp
>1000.
>
>Works just fine, in fact any router service that can survive nat will
>work using the same method.
>
>
>------------------------------------------------------------------------
>--------------------
>
>
>
>interface Serial0
> ip address 150.50.17.1 255.255.255.0
> ip nat outside
>
>interface Loopback1
> ip address 192.168.1.1 255.255.255.0
> ip nat inside
>
>access-list 10 permit 192.168.1.0 0.0.0.255
>
>ip nat inside source list 10 interface Serial0 overload
>ip nat inside source static tcp 192.168.1.1 23 150.50.17.1 1000
>extendable
>
>
>------------------------------------------------------------------------
>--------------------
>
>R2#telnet 150.50.17.1 1000
>Trying 150.50.17.1, 1000 ... Open
>
>
>Router R1 - Cisco 1602 Interfaces S0 S1 E0
>
>E0 Connects to BB1
>S0 Connects to R2-S1
>
>
>R1 line 1
>
>R1#
>
>R1#show ip nat tr
>
>Pro Inside global Inside local Outside local Outside
>global
>tcp 150.50.17.1:1000 192.168.1.1:23 --- ---
>tcp 150.50.17.1:1000 192.168.1.1:23 150.50.17.2:11005
>150.50.17.2:11005
>
>R1#
>
>
>
>
>
>Michael Snyder
>Lead Network Engineer
>CCNP/DP, CSS1, MCSE NT/2000
>Revolution Computer Systems
>(270) 443-7400
>
>_______________________________________________________________________
>Please help support GroupStudy by purchasing your study materials from:
>http://shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:53:09 GMT-3