CyscoExpert Sample Lab Version 2

From: Wayne Hines (wayneh@DataNetDev.com.au)
Date: Sun Oct 19 2003 - 03:47:11 GMT-3


Hello Group,

For those who have done this very good lab.

     R2--------R5-------
       \ |
        \ |
         \ R3-E0 150.1.30.3/24
          \ |
           \ |
     R1-----R4----------

R3 has an network on its Ethernet interface that is injected into OSPF as an
external route.

This route [via R5] is then redistributed on R2 into EIGRP 100 and carried
across the tunnel to R4, where if the administrative distance of the R3-R4
(ospf) path is raised to 171 the R3 E0 route via R5-R2-R4 is passed on to
R1.

The same R3 E0 route is also redistributed on R4 from OSPF into RIP and then
from RIP into EIGRP. The route is successfully redistributed into RIP but
not from RIP into EIGRP.

The only relevant config appears to be R4

So my questions are
1) Why is the RIP to EIGRP redistribution not working [as expected]?
2) and hence how does one achieve a redundant path to this route. ie in
case of R2-R4 tunnel failure?

!R4 FULL CONFIG
conf t
hostname r4

interface Loopback0
 ip address 150.1.4.4 255.255.255.0
!
interface Loopback10
 ip address 195.1.4.4 255.255.255.0
!
interface Tunnel0
 ip address 150.1.24.4 255.255.255.0
tu so 150.1.4.4
tu de 150.1.2.2
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 1
!
key chain 1
key 1
key-string 0 cisco

interface Ethernet0
 ip address 170.1.1.1 255.255.255.0
no shut
!
interface Serial0
 ip address 150.1.111.4 255.255.255.248
encap frame
frame map ip 150.1.111.3 403 br
frame map ip 150.1.111.4 403 br
frame map ip 150.1.111.5 403 br
no frame inverse-arp
no arp frame
ip ospf priority 0
ip ospf authentication
ip ospf authentication-key 0 cisco
no shut
!
interface Serial1
 ip address 150.1.14.4 255.255.255.0
 clock rate 2000000
no shut

access-list 1 permit 150.1.30.0 0.0.0.255
router ospf 1
network 150.1.111.4 0.0.0.7 area 0
neighbor 150.1.111.3
area 0 authentication
network 150.1.4.4 0.0.0.255 area 0
redist rip subnets route-map RIPOSPF
distance 171 0.0.0.0 255.255.255.255 1

access-list 3 permit 0.0.0.0 255.254.255.255
route-map RIPOSPF permit 10
match ip address 3
set metric 1000

route-map RIPOSPF permit 20
set metric-type type-1

access-list 2 permit 200.0.0.0 0.7.0.0
router rip
version 2
no auto-summary
network 170.1.1.0
passive-interface s0
passive-interface tu0
passive-interface s1
passive-interface lo0
passive-interface lo10
passive-interface e0
neighbor 170.1.1.100
timers basic 10 30 30 40
redist ospf 1 metric 3
redist eigrp 100 metric 3
distance 109 0.0.0.0 255.255.255.255 2

router eigrp 100
network 150.1.24.0 0.0.0.255
no auto-summary
passive-interface s0
passive-interface e0
network 150.1.14.4 0.0.0.255
redist rip metric 1000 100 254 1 1500

router bgp 34
no synch
no auto-summary
neighbor 150.1.3.3 remote-as 34
neighbor 150.1.3.3 update-source lo0
neighbor 150.1.1.1 remote-as 1
neighbor 150.1.1.1 update-source lo0
neighbor 150.1.1.1 ebgp-multihop 5
neighbor 150.1.2.2 remote-as 256
neighbor 150.1.2.2 update-source lo0
neighbor 150.1.2.2 ebgp-multihop 5
neighbor 170.1.1.254 remote-as 100
network 195.1.4.0 mask 255.255.255.0

neighbor 150.1.1.1 route-map Metric31337 out
neighbor 150.1.2.2 route-map Metric31337 out
neighbor 170.1.1.254 route-map NO_EXPORT in

access-list 4 permit 0.0.1.0 255.255.254.255
ip as-path access-list 2 permit ^100_
route-map Metric31337 permit 10
match ip address 4
match as-path 2
set metric 31337

route-map Metric31337 permit 20

ip as-path access-list 1 permit _1000_
route-map NO_EXPORT permit 10
match as-path 1
set community NO-EXPORT

route-map NO_EXPORT permit 20

bridge 1 protocol ieee
dlsw local-peer peer-id 150.1.4.4
dlsw remote-peer 0 frame-relay interface Serial0 403
dlsw bridge-group 1

int s0
frame-relay map llc2 403 broadcast

int e0
bridge-group 1

ntp authenticate
ntp authentication-key 1 md5 cisco
ntp trusted-key 1
ntp peer 150.1.1.1

end

THE FOLLOWING IS WITH THE TUNNEL INTERFACE SHUT

sh ip ospf d

            OSPF Router with ID (195.1.4.4) (Process ID 1)

                Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
195.1.2.2 195.1.2.2 3 (DNA) 0x80000006 0x3413 1
195.1.3.3 195.1.3.3 371 0x8000000F 0xE2CC 3
195.1.4.4 195.1.4.4 453 0x80000003 0x6D23 2
195.1.5.5 195.1.5.5 1778 0x80000006 0x2B12 4

                Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
150.1.111.3 195.1.3.3 1141 0x8000000E 0x6E86

                Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
150.1.1.1 195.1.2.2 3 (DNA) 0x80000001 0x4B4E
150.1.2.2 195.1.2.2 8 (DNA) 0x80000001 0xB324
150.1.6.6 195.1.2.2 3 (DNA) 0x80000001 0xC302
150.1.6.6 195.1.5.5 1778 0x80000005 0x9427
150.1.12.0 195.1.2.2 8 (DNA) 0x80000003 0xCDC0
150.1.222.2 195.1.2.2 8 (DNA) 0x80000001 0x2CCF
150.1.222.2 195.1.5.5 1779 0x80000004 0x6385
150.1.222.5 195.1.2.2 3 (DNA) 0x80000003 0x6E7E
150.1.222.5 195.1.5.5 1779 0x80000004 0xE00F
150.1.222.6 195.1.2.2 3 (DNA) 0x80000001 0x6885
150.1.222.6 195.1.5.5 1779 0x80000005 0x39AA
172.16.30.0 195.1.2.2 3 (DNA) 0x80000001 0x9BB3

                Summary ASB Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
195.1.2.2 195.1.5.5 1779 0x8000000F 0x711B

                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
150.1.24.0 195.1.2.2 424 0x80000004 0xC292 0
150.1.30.0 195.1.3.3 372 0x8000000D 0xC152 0
170.1.1.0 195.1.4.4 165 0x80000001 0x8423 0

r4#sh ip rip database
150.1.0.0/16 auto-summary
150.1.1.1/32 redistributed
    [3] via 195.1.2.2,
150.1.2.2/32 redistributed
    [3] via 195.1.2.2,
150.1.3.3/32 redistributed
    [3] via 195.1.3.3,
150.1.4.0/24 redistributed
    [1] via 0.0.0.0,
150.1.5.5/32 redistributed
    [3] via 195.1.5.5,
150.1.6.6/32 redistributed
    [3] via 195.1.5.5,
150.1.12.0/24 redistributed
    [3] via 195.1.2.2,
150.1.14.0/24 redistributed
    [1] via 0.0.0.0,
150.1.24.0/24 redistributed
    [3] via 195.1.2.2,
150.1.30.0/24 redistributed
    [3] via 195.1.3.3,
150.1.35.0/24 redistributed
    [3] via 195.1.5.5,
150.1.111.0/29 redistributed
    [1] via 0.0.0.0,
150.1.222.2/32 redistributed
    [3] via 195.1.2.2,
150.1.222.5/32 redistributed
    [3] via 195.1.5.5,
150.1.222.6/32 redistributed
    [3] via 195.1.5.5,
170.1.0.0/16 auto-summary
170.1.1.0/24 directly connected, Ethernet0
172.16.0.0/16 auto-summary
172.16.30.0/24 redistributed
    [3] via 195.1.2.2,
195.1.3.0/24 auto-summary
195.1.3.3/32 redistributed
    [3] via 195.1.3.3,
220.1.0.0/16 redistributed
    [3] via 150.1.14.1,

r4#sh ip eigrp topology
IP-EIGRP Topology Table for AS(100)/ID(195.1.4.4)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 150.1.14.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 170.1.1.0/24, 1 successors, FD is 2585600
         via Redistributed (2585600/0)
P 220.1.0.0/16, 1 successors, FD is 2297856
         via 150.1.14.1 (2297856/128256), Serial1



This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:53:04 GMT-3