From: Perrymon, Josh L. (PerrymonJ@bek.com)
Date: Thu Oct 16 2003 - 14:59:26 GMT-3
This is an example of a pix configured for the following
(( 515-UR 3 active interfaces with fail over ))
Network-to-Network VPNs using object groups
Dynamic client to network VPNs using RSA authentication
Nat-T to allow In-Line PAT for IPSEC
CLient DMZ interface to segment outside clients
CLient DMZ with DHCP on the interface
Maybe this will help with some design / implementation issues.
Building configuration...
: Saved
:
PIX Version 6.3(0)144
interface ethernet0 100full
interface ethernet1 100full
interface ethernet2 10full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 clientdmz security50
enable password xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
passwd xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
hostname pix
domain-name xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
clock timezone CST -6
clock summer-time CDT recurring
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
object-group network vpn_client_subnets <- Object groups make VPN very
modular
network-object xxxxxxxx 255.255.0.0
Object-group network Hub_VPN_subnet
network-object 1.1.1.0 255.0.0.0
access-list compiled
access-list nonat-inside permit ip xxxxxxxxxxxxxxxxxxxxxxxx <- No-NAT acl
is required for network-to-network VPN
access-list HUB_to_Remote permit ip xxxxxxxxxxxxxxxxxxxxxxxxxx <--- Crypto
map for n-2-n VPN
access-list clientdmz permit ipxxxxxxx 255.255.255.0 host xxxxxxx <---
ClientDMZ acl
pager lines 24
logging on
logging timestamp
logging monitor debugging
logging buffered debugging
logging trap debugging
logging history debugging
logging facility 7
logging host inside xxxxxxxxxxxxxxxxxxx
mtu outside 1500
mtu inside 1500
mtu clientdmz 1500
ip address outside pixoutside 255.255.255.0
ip address inside pixinside 255.255.255.0
ip address clientdmz pixdmz 255.255.255.0
ip verify reverse-path interface outside
ip audit info action alarm
ip audit attack action alarm
ip local pool client_vpn_pool 2.2.2.2-2.2.2.255 <--- Pool used by dynamic
vpn clients
failover
failover timeout 0:00:00
failover poll 15
failover ip address outside xxxx
failover ip address inside xxxxxx
failover ip address clientdmz xxxxx
pdm history enable
arp timeout 14400
global (outside) 1 xxxxxxxx netmask 255.255.255.0 <--- PAT Pool
nat (inside) 0 access-list nonat-inside <--- No-NAT ACL
nat (inside) 1 xxxxx 255.255.255.0 0 0
nat (inside) 1 xxxxxxx 255.255.248.0 0 0
nat (clientdmz) 1 xxxxxxxx255.255.255.0 0 0
static (inside,clientdmz) xxxxxxxn xxxxxxxn netmask 255.255.248.0 0 0 <--
Static needed for CLient DMZ to access LAN
access-group clientdmz in interface clientdmz
route outside 0.0.0.0 0.0.0.0 wwwrouter 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ <---- THis is the Radius (AAA) config
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa-server clientauth protocol radius
aaa-server clientauth (inside) host bxxxxxxxxx shared_key timeout 30 <---
Shared key and IP for RSA box
http server enable
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec <--- This allows ALL vpn traffic to bypass
ACL's
auth-prompt accept RSA Authentication successful - VPN Established-
Connected to
auth-prompt reject DENIED- xxxxxxxxxxxxxxxxxxxxx
crypto ipsec transform-set des-md5 esp-des esp-md5-hmac <--- Transform set
to be used
crypto dynamic-map dynamic-clients 10000 set transform-set des-md5 <-
Dynamic client crypto map
crypto map vpn 10 ipsec-isakmp
crypto map vpn 10 match address xxxxx <---- Net-2-NET VPN
crypto map vpn 10 set peer xxxxx
crypto map vpn 10 set transform-set des-md5
crypto map vpn 99 ipsec-isakmp dynamic dynamic-clients
crypto map vpn client token authentication clientauth <--- Refers to
clientauth AAA config
crypto map vpn interface outside <- Applies crypto to outside
isakmp enable outside <--- Applies ISAKMP to outside
isakmp key ******** address xxxxxxxxx netmask 255.255.255.255 no-xauth <--
PRE-Shared KEY
isakmp identity address <-- USE isakmp identity as address
isakmp nat-traversal 20 <-- enfore Nat-T for use with upstream PAT ((
Encaps IPSEC over UDP 4500))
isakmp policy 10 authentication pre-share <-- This will cover most ALL
transforms
isakmp policy 10 encryption des
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash sha
isakmp policy 20 group 1
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 2
isakmp policy 30 lifetime 86400
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption des
isakmp policy 40 hash md5
isakmp policy 40 group 1
isakmp policy 40 lifetime 86400
vpngroup xxxx address-pool brooksville <-- Setup VPN groups
vpngroup xxxxxx dns-server xxxx
vpngroup xxxxxx wins-server xxxx
vpngroup xxxxxx default-domain xxxxxxcom
vpngroup xxxxx split-tunnel split_tunnel <--- uses split_tunnel ACL to
split traffic
vpngroup xxxxxx idle-time 1800
vpngroup xxxxxxx password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet 0.0.0.0 0.0.0.0 clientdmz
telnet timeout 20
ssh timeout 5
console timeout 0
dhcpd address xxxxxxxx clientdmz Setup DHCP Daemon
dhcpd dns xxxxxx
dhcpd wins xxxxxxx
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain bek2.com
dhcpd enable clientdmz
terminal width 80
banner exec This Is Restricted Equipment
banner login This Equipment is Restricted.
Cryptochecksum:xxxxxxx
: end
[OK]
pix(config)#
Joshua Perrymon
Sr. Network Security Consultant
This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:53:03 GMT-3