From: ccie2be (ccie2be@nyc.rr.com)
Date: Thu Oct 02 2003 - 08:26:44 GMT-3
Good morning Ozgur,
That was a great way to respond to my questions. Not only did I learn the
answers to those questions but I saw the technique that should be used to
implement this type of config. Thanks so much.
Here's my summary of what you did to config an EtherChannel:
1) set phy int to be in etherchannel to their default setting using the
"default int ..." command.
2) using "int range" command, config phy int to be in channel-group and set
mode to "on".
3) Switch to the Port-channel just created.
4) Configure the needed parameters (encap, native vlan, allowed vlans, etc)
under the Port-channel.
5) In the sh run output, IOS has automatically entered the commands
configured under the Port-channel under the phy interfaces as well.
Did I miss anything?
Thanks again. Unfortunately, I don't have access to 3550's very frequently
so this was a big, big help. dt
----- Original Message -----
From: "Ozgur Guler (Garanti Teknoloji)" <OzgurG@garanti.com.tr>
To: "ccie2be" <ccie2be@nyc.rr.com>
Sent: Thursday, October 02, 2003 6:36 AM
Subject: RE: 3550 - duplicate commands on phy & etherchannel
hope this answers you questions...
see the output below
-------------------------------
Switch(config)#default int fa 0/23
Building configuration...
Interface FastEthernet0/23 set to default configuration
Switch(config)#default int fa 0/24
Building configuration...
Interface FastEthernet0/24 set to default configuration
Switch(config)#^Z
Switch#s run int fa
1d22h: %SYS-5-CONFIG_I: Configured from console by console0/23
Building configuration...
Current configuration : 49 bytes
!
interface FastEthernet0/23
no ip address
end
Switch#s run int fa 0/24
Building configuration...
Current configuration : 49 bytes
!
interface FastEthernet0/24
no ip address
end
Switch#c
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#int range fa 0/23 - 24
Switch(config-if-range)#sw
Switch(config-if-range)#ch
Switch(config-if-range)#channel-g
Switch(config-if-range)#channel-group 1 ?
mode Etherchannel Mode of the interface
Switch(config-if-range)#channel-group 1 mo
Switch(config-if-range)#channel-group 1 mode on
Switch(config-if-range)#exit
Switch(config)#int po
Switch(config)#int port-channel 1
Switch(config-if)#sw
Switch(config-if)#switchport tr
Switch(config-if)#switchport trunk en
Switch(config-if)#switchport trunk encapsulation do
Switch(config-if)#switchport trunk encapsulation dot1q
Switch(config-if)#sw
Switch(config-if)#switchport mo
Switch(config-if)#switchport mode tru
Switch(config-if)#switchport mode trunk
Switch(config-if)#sw
Switch(config-if)#switchport tr
Switch(config-if)#switchport trunk all
Switch(config-if)#switchport trunk allowed vl
Switch(config-if)#switchport trunk allowed vlan 100
Switch(config-if)#s
Switch(config-if)#sw
Switch(config-if)#switchport tr
Switch(config-if)#switchport trunk n
Switch(config-if)#switchport trunk native v
Switch(config-if)#switchport trunk native vlan 55
Switch(config-if)#^Z
Switch#
1d22h: %SYS-5-CONFIG_I: Configured from console by consoles run int fa 0/23
Building configuration...
Current configuration : 203 bytes
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 55
switchport trunk allowed vlan 100
switchport mode trunk
no ip address
channel-group 1 mode on
end
Switch#s run int fa 0/24
Building configuration...
Current configuration : 203 bytes
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 55
switchport trunk allowed vlan 100
switchport mode trunk
no ip address
channel-group 1 mode on
end
Switch#s run int po
Switch#show run int port-channel 1
Building configuration...
Current configuration : 175 bytes
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk native vlan 55
switchport trunk allowed vlan 100
switchport mode trunk
no ip address
end
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
ccie2be
Sent: Thursday, October 02, 2003 1:27 PM
To: Group Study
Subject: 3550 - duplicate commands on phy & etherchannel
Hi,
In the portion of the config below 4 different commands are entered 3
times -
once under each of the physical interfaces and again under the portchannel.
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 1,10,20,30,40,55,70,100
switchport mode trunk
no ip address
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 1,10,20,30,40,55,70,100
switchport mode trunk
no ip address
udld enable
channel-group 1 mode on
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk native vlan 999
switchport trunk allowed vlan 1,10,20,30,40,55,70,100
switchport mode trunk
no ip address
udld enable
channel-group 1 mode on
1) Is there a way to accomplish the same thing without entering all 4
commands
so many times? If so, how?
2) If any of these commands weren't entered under the Port-channel, would
the
portchannel "inherit" any of the settings from the physical interfaces?
Which ones?
3) Could any of these commands be left off the physical interface and just
entered once under the port-channel? Which ones?
4) If some commands are needed under both the phy and the port-channel, is
there any rule of thumb regarding which commands are needed under both and
which aren't?
Any help with these questions will be greatly appreciated.
Thanks in advance, dt
***Get your CCIE and a FREE vacation: Shop.GroupStudy.com***
This archive was generated by hypermail 2.1.4 : Mon Nov 24 2003 - 07:52:55 GMT-3