RE: OSPF Point-to-Multipoint, Nonbroadcast

From: Danny.Andaluz@triaton-na.com
Date: Tue Sep 09 2003 - 14:21:00 GMT-3


Here's what I have and it seems to work ok:

r2#sh run int s0
Building configuration...

Current configuration : 293 bytes
!
interface Serial0
 ip address 1.1.1.2 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 1.1.1.5 105
 frame-relay map ip 1.1.1.6 106
 no frame-relay inverse-arp
End

r2#sh run | b router ospf 1
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 neighbor 1.1.1.6
 neighbor 1.1.1.5

r2#sh ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface
6.6.6.6 0 FULL/ - 00:01:39 1.1.1.6 Serial0
1.1.1.5 0 FULL/ - 00:01:39 1.1.1.5 Serial0

r2#sh ip ospf inter
Serial0 is up, line protocol is up
  Internet Address 1.1.1.2/24, Area 0
  Process ID 1, Router ID 1.1.1.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:04
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 6.6.6.6
    Adjacent with neighbor 1.1.1.5
  Suppress hello for 0 neighbor(s)

r5#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JK8OS-L), Version 12.2(1d), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.

Other end:

interface Serial0
 ip address 1.1.1.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint non-broadcast
 ip ospf priority 0
 frame-relay map ip 1.1.1.2 501 broadcast
 no frame-relay inverse-arp

router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0

r5#sh ip ospf neigh

Neighbor ID Pri State Dead Time Address Interface
1.1.1.2 1 FULL/ - 00:01:46 1.1.1.2 Serial0

r5#sh ip ospf inter
Serial0 is up, line protocol is up
  Internet Address 1.1.1.5/24, Area 0
  Process ID 1, Router ID 1.1.1.5, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.2
  Suppress hello for 0 neighbor(s)

r5#sh ver
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-JK8OS-L), Version 12.2(1d), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.

-----Original Message-----
From: navaid@rogers.com [mailto:navaid@rogers.com]
Sent: Tuesday, September 09, 2003 12:56 PM
To: Group Study
Subject: OSPF Point-to-Multipoint, Nonbroadcast

As you can see in example from Doc. CD, neighbor command is only used on hub and no neighbor command on other router. I am having problem with adj. when command is only on Hub router. what is correct way to configure point to multipoint nonbroadcast, the way that works or the way that is documented in CD ?

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt2/1cfospf.htm#1001760

OSPF Point-to-Multipoint, Nonbroadcast Example
The following example illustrates a point-to-multipoint network with nonbroadcast:

interface Serial0
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
encapsulation frame-relay
no keepalive
frame-relay local-dlci 200
frame-relay map ip 10.0.1.3 202
frame-relay map ip 10.0.1.4 203
frame-relay map ip 10.0.1.5 204
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0
neighbor 10.0.1.3 cost 5
neighbor 10.0.1.4 cost 10
neighbor 10.0.1.5 cost 15
The following example is the configuration for the router on the other side:

interface Serial9/2
ip address 10.0.1.3 255.255.255.0
encapsulation frame-relay
ip ospf network point-to-multipoint non-broadcast
no ip mroute-cache
no keepalive
no fair-queue
frame-relay local-dlci 301
frame-relay map ip 10.0.1.1 300
no shut
!
router ospf 1
network 10.0.1.0 0.0.0.255 area 0

1



This archive was generated by hypermail 2.1.4 : Wed Oct 01 2003 - 07:24:25 GMT-3