RE: why is my distribute list not working ?

From: Jonathan V Hays (jhays@jtan.com)
Date: Sat Aug 30 2003 - 16:53:45 GMT-3


THIS IS WHAT I AM GETTING DOWNSTREAM ---

R_3#
R_3#sh ip route rip
     153.4.0.0/24 is subnetted, 9 subnets
R 153.4.26.0 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.6.0 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.2.0 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.66.0 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R 170.4.0.0/16 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 192.168.1.0/24 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R_3#sh r

Hi Richard,

I can't say for sure about 153.4.6.0 and 153.4.66.0 - perhaps they are
coming in from another interface, such as Serial0/0.26?

However, the routes 153.4.26.0, 153.4.2.0, and 170.40.0./16 are
generated by R_2 and your distribute list will not block these - it will
only block RIP routes coming in Ethernet 0/0.

HTH,

Jonathan

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Richard L. Pickard
Sent: Saturday, August 30, 2003 4:38 PM
To: Ccielab@Groupstudy. Com
Subject: why is my distribute list not working ?

my goal is to accept only the 192.168.1.0/24 route from BB_2, which is
connected to ethernet 0/0 on R_2

hostname R_2
!
!
interface Loopback0
 ip address 153.4.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 170.4.2.1 255.255.255.0
 ip accounting output-packets
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no arp frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial0/0.23 point-to-point
 ip address 153.4.23.2 255.255.255.0
 frame-relay interface-dlci 203
!
interface Serial0/0.26 point-to-point
 ip address 153.4.26.2 255.255.255.0
 frame-relay interface-dlci 206
!
!
router rip
timers basic 20 120 120 160
network 153.4.0.0
network 170.4.0.0
distribute-list 1 in Ethernet0/0
no auto-summary
!
ip classless
ip http server
ip ospf name-lookup
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!

========================================================================
===
THIS IS WHAT I AM GETTING DOWNSTREAM ---

R_3#
R_3#sh ip route rip
     153.4.0.0/24 is subnetted, 9 subnets
R 153.4.26.0 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.6.0 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.2.0 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 153.4.66.0 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R 170.4.0.0/16 [120/1] via 153.4.23.2, 00:00:11, Serial0/0.23
R 192.168.1.0/24 [120/2] via 153.4.23.2, 00:00:11, Serial0/0.23
R_3#sh run
hostname R_3
!
interface Loopback0
 ip address 153.4.3.3 255.255.255.0
 ip router isis
 isis circuit-type level-2-only
!
interface FastEthernet0/0
 ip address 153.4.33.3 255.255.255.0
 ip ospf authentication-key cisco
 speed 100
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no arp frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial0/0.13 point-to-point
 ip address 153.4.13.3 255.255.255.0
 ip router isis
 clns enable
 isis circuit-type level-2-only
 frame-relay interface-dlci 301
!
interface Serial0/0.23 point-to-point
 ip address 153.4.23.3 255.255.255.0
 frame-relay interface-dlci 302
!
router ospf 10
 router-id 153.4.33.3
 log-adjacency-changes detail
 area 6 authentication
 network 153.4.33.0 0.0.0.255 area 6
!
router isis
 net 13.0001.0000.0000.0031.00
 is-type level-2-only
!
router rip
 timers basic 20 120 120 160
 network 153.4.0.0
!
ip http server
ip http secure-server
ip classless
!
ip ospf name-lookup



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:54:11 GMT-3