From: Jonathan V Hays (jhays@jtan.com)
Date: Mon Aug 25 2003 - 16:00:35 GMT-3
Emad,
Your config looks identical to mine, except for different ports used.
When you say 'not working' could you be more specific? Do you mean you
can't ping from switch to switch?
Or are you trying to ping to/from devices connected to the switches?
I was able to ping across VLANs on the switches because of static
default routes on each switch pointing to the other switch. However, if
you ping from hosts, each connected to different VLANs then you must
configure a default gateways on the hosts themselves.
For example, suppose you have a host(router) with IP address 20.1.1.22
connected to fa0/9 (vlan 2) on the 'DOWN' switch. You have another host
with IP address 30.1.1.33 connected to fa0/9 (vlan 3) on the 'UP'
switch.
Now, on the console of 20.1.1.22 I ping 30.1.1.33. The DOWN switch
passes the packet from fa0/9 to its default-gateway, the UP switch, via
the trunk. The UP switch in turn routes the packet to 30.1.1.33. If the
host 30.1.1.33 does not have a default-gateway configured it will drop
the packet, since it only knows about the 30.1.1.0/24 network, but it
sees the source of the packet as 20.1.1.0/24. Its connected
switch/router may know about 20.1.1.0/24 but the host itself has no
knowledge of any other network than 30.1.1.0/24.
I apologize in advance if I am telling you something you already know.
I hope this helps.
Jonathan
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
emad
Sent: Monday, August 25, 2003 12:15 PM
To: 'Jonathan V Hays'
Cc: ccielab@groupstudy.com
Subject: RE: Cat3550: strange problem
Jonathan,
I did what u post but still not working as following:
!
interface FastEthernet0/1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 2
switchport mode access
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 20.1.1.2 255.255.255.0
!
ip default-gateway 20.1.1.1
ip classless
Down-Back#sh ip in br
Interface IP-Address OK? Method Status
Protocol
Vlan1 unassigned YES NVRAM administratively
down down
Vlan2 20.1.1.2 YES NVRAM up
up
FastEthernet0/1 unassigned YES unset up
up
FastEthernet0/9 unassigned YES unset up
up
Down-Back#sh vtp sta
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 13
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Disabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0xE4 0xA1 0xC5 0xEC 0xF0 0x3E 0x8E
0x8A
Configuration last modified by 1.1.1.2 at 3-1-93 06:10:57
Local updater ID is 20.1.1.2 on interface Vl2 (lowest numbered VLAN
interface found)
And the UP switch
!
!
interface FastEthernet0/1
switchport trunk encapsulation isl
switchport mode trunk
!
interface FastEthernet0/9
switchport access vlan 3
switchport mode access
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 20.1.1.1 255.255.255.0
!
interface Vlan3
ip address 30.1.1.1 255.255.255.0
!
ip default-gateway 20.1.1.2
ip classless
UP-SW#sh ip in br
Interface IP-Address OK? Method Status
Protocol
Vlan1 unassigned YES NVRAM administratively
down down
Vlan2 20.1.1.1 YES NVRAM up
up
Vlan3 30.1.1.1 YES NVRAM up
up
FastEthernet0/9 unassigned YES unset up
up
UP-SW#sh vtp stat
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 21
VTP Operating Mode : Server
VTP Domain Name : cisco
VTP Pruning Mode : Enabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0xDA 0xF3 0x9D 0x8E 0x57 0xDA 0x86
0x8A
Configuration last modified by 0.0.0.0 at 3-1-93 06:39:04
Local updater ID is 20.1.1.1 on interface Vl2 (lowest numbered VLAN
interface found)
UP-SW#
Please advice
Regards
-----Original Message-----
From: Jonathan V Hays [mailto:jhays@jtan.com]
Sent: Monday, August 25, 2003 5:30 PM
To: 'emad'
Cc: ccielab@groupstudy.com
Subject: RE: Cat3550: strange problem
Emad,
1. In your config on fa0/9 change the mode to "switchport mode access"
or you may have problems in some versions of switch software or if you
configure DLSw+ on a router connected to this port. Here is your config
from a previous post:
interface FastEthernet0/9
switchport access vlan 2
switchport mode dynamic desirable <== NOT RECOMMENDED TO LEAVE IN
DEFAULT MODE
http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12114ea1/3550s
cg/swvlan.htm#1036007
Here's a brief excerpt:
Step 1 configure terminal
Step 2 interface interface-id
Step 3 switchport mode access
Step 4 switchport access vlan vlan-id
Step 5 end
2. Here is a simple config that routes between VLANs. If you are not
using a routing protocol (e.g., OSPF) then typing the command "ip
routing" is NOT necessary.
Ports fa0/19 on the two switches are connected with a crossover cable
which serves as an ISL trunk.
==========
S1_3550#sh run | begin 0/19
interface FastEthernet0/19
switchport trunk encapsulation isl
switchport mode trunk
no ip address
!
interface Vlan2
ip address 20.1.1.1 255.255.255.0
!
interface Vlan3
ip address 30.1.1.1 255.255.255.0
!
ip default-gateway 20.1.1.2
==========
S2_3550#sh run | begin 0/19
interface FastEthernet0/19
switchport trunk encapsulation isl
switchport mode trunk
no ip address
!
<snip>
interface Vlan2
ip address 20.1.1.2 255.255.255.0
!
interface Vlan4
ip address 40.1.1.2 255.255.255.0
!
ip default-gateway 20.1.1.1
==========
The only other commands I typed that are not shown in the excerpted
configs above are these:
==========
vtp domain cisco (on each switch)
vlan 2 (to create the vlan)
vlan 3 (to create the vlan)
vlan 4 (to create the vlan)
==========
Here are the ping tets:
==========
S1_3550#sh ip int brief | include Vlan
Vlan1 unassigned YES unset administratively
down down
Vlan2 20.1.1.1 YES manual up
up
Vlan3 30.1.1.1 YES manual up
up
S1_3550#p 40.1.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
S1_3550#
==========
S2_3550#sh ip int brief | include Vlan
Vlan1 unassigned YES unset administratively
down down
Vlan2 20.1.1.2 YES manual up
up
Vlan4 40.1.1.2 YES manual up
up
S2_3550#p 30.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
S2_3550#
==========
I hope this is of use to you. I learned a thing or two myself while
playing around with this. I will put this in a separate post.
Jonathan
This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:54:06 GMT-3