From: Jonathan V Hays (jhays@jtan.com)
Date: Mon Aug 25 2003 - 15:44:14 GMT-3
All,
While playing around with Emad's config (see "Cat3550: strange problem")
I came across an unexpected error message:
"00:19:24: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered
on FastEthernet0/20 (2), with S1_3550 FastEthernet0/20 (1)."
Physically, ports fa0/19 and fa0/20 are connected between two Catalyst
3550 switches with crossover cables. I configured fa0/19 as an ISL
trunk. I then configured fa0/20 on switch 2 (S2_3550) with VLAN 2 and
got the error.
I thought 'native vlan' applied only to Dot1Q trunks. Evidently not. I
guess I need to reread the switch software configuration guide.
A minute later I remembered that configuring a port with vlan 2 was not
necessary for what I was trying to accomplish so I removed it from
fa0/20. All I needed to do was to create the VLAN. The command
"interface vlan 2" does not create a VLAN, although "switchport access
vlan 2" does create a VLAN. And of course you can simply create the vlan
without applying it to an interface, using either "config-vlan Mode" or
"VLAN Configuration Mode", as Cisco calls them. I think Cisco could have
created more distinctive terms for these two modes.
Here's the link for those unfamiliar with these two modes:
http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/12114ea1/3550s
cg/swvlan.htm#1196935
Does anyone have an insight into the cause of this error message?
No VLANs had been created at this point and the configs were as follows:
SWITCH 1:
=========
interface FastEthernet0/19
switchport trunk encapsulation isl
switchport mode trunk
no ip address
!
interface Vlan2
ip address 20.1.1.1 255.255.255.0
!
interface Vlan3
ip address 30.1.1.1 255.255.255.0
!
ip default-gateway 20.1.1.2
ip classless
SWITCH 2:
=========
interface FastEthernet0/19
switchport trunk encapsulation isl
switchport mode trunk
no ip address
!
interface FastEthernet0/20
switchport access vlan 2
switchport mode access
no ip address
!
interface Vlan2
ip address 20.1.1.2 255.255.255.0
=========
AFTER CONFIGURING FA0/20:
=========
S2_3550(config)#in fa0/20
S2_3550(config-if)#switchport mode access
S2_3550(config-if)#switchport access vlan 2
% Access VLAN does not exist. Creating vlan 2
S2_3550(config-if)#
00:19:24: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered
on FastEthernet0/20 (2), with S1_3550 FastEthernet0/20 (1).
S2_3550(config-if)#
00:19:48: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan2, changed
state to up
S2_3550(config-if)#
00:20:24: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered
on FastEthernet0/20 (2), with S1_3550 FastEthernet0/20 (1).
S2_3550(config-if)#
The same error message appeared on the other switch.
Thanks for your comments,
Jonathan
This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:54:06 GMT-3