do I use a conditional advertisement ? please help

From: Richard L. Pickard (nettable_walker@comcast.net)
Date: Sat Aug 16 2003 - 18:04:29 GMT-3


Fiesta()
topology - R_1 ---- 3550 ---- BB1
The lab I am working asks the following:

 advertise to BB 1 ALL of the 190.x.y.y/24 & 130.x.y.y/24 Loopbacks. The
3550 should be the only device to see the 130.x.y.y Loopbacks in its BGP
table.

Here is what I have so far:

R_1#
R_1#sh run
Building configuration...

Current configuration : 2602 bytes
!
! Last configuration change at 12:29:17 UTC Tue Aug 26 2003
! NVRAM config last updated at 12:30:59 UTC Tue Aug 26 2003
!
version 12.2
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname R_1
!
enable password cisco
!
username R_3 password 0 cisco

interface Loopback0
 ip address 130.4.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 130.4.135.1 255.255.255.0
 full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no arp frame-relay
 no frame-relay inverse-arp
!
interface Serial0/0.1 multipoint
 ip address 130.4.100.1 255.255.255.240
 ip pim sparse-dense-mode
 ip ospf priority 0
 no arp frame-relay
 frame-relay map ip 130.4.100.2 103 broadcast
 frame-relay map ip 130.4.100.3 103 broadcast
 frame-relay map ip 130.4.100.6 103 broadcast
 no frame-relay inverse-arp
!
!
interface BRI0/0
 ip address 130.4.13.1 255.255.255.0
 encapsulation ppp
 dialer map ip 130.4.13.3 name R_3
 dialer-group 1
 isdn switch-type basic-5ess
 isdn fast-rollover-delay 5
 ppp authentication chap
 ppp multilink
!
!
router ospf 10
 router-id 130.4.1.1
 log-adjacency-changes detail
 network 130.4.1.0 0.0.0.255 area 0
 network 130.4.13.0 0.0.0.255 area 1
 network 130.4.100.0 0.0.0.255 area 0
 network 130.4.135.0 0.0.0.255 area 0
!
router bgp 65060
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 401
 bgp confederation peers 65050
 network 190.4.1.0 mask 255.255.255.0
 neighbor 130.4.100.3 remote-as 65050
 neighbor 130.4.135.35 remote-as 65060
 no auto-summary
!
!
!

R_1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     170.4.0.0/24 is subnetted, 1 subnets
O E2 170.4.1.0 [110/10] via 130.4.135.35, 02:07:17, Ethernet0/0
O E2 210.120.14.0/24 [110/10] via 130.4.135.35, 02:07:17, Ethernet0/0
B 207.15.16.0/24 [200/0] via 170.4.1.254, 02:30:22
O E2 210.120.12.0/24 [110/10] via 130.4.135.35, 02:07:17, Ethernet0/0
B 207.15.17.0/24 [200/0] via 170.4.1.254, 02:30:22
     190.4.0.0/24 is subnetted, 6 subnets
B 190.4.35.0 [200/0] via 130.4.135.35, 02:38:19
B 190.4.2.0 [200/0] via 130.4.100.2, 01:17:01
B 190.4.3.0 [200/0] via 130.4.100.3, 02:38:51
B 190.4.6.0 [200/0] via 130.4.100.6, 02:38:08
B 190.4.4.0 [200/0] via 130.4.34.4, 02:29:57
B 190.4.5.0 [200/0] via 130.4.34.4, 02:29:57
O E2 210.120.10.0/24 [110/10] via 130.4.135.35, 02:07:19, Ethernet0/0
     201.145.33.0/28 is subnetted, 15 subnets
B 201.145.33.112 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.96 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.80 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.64 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.48 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.32 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.16 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.240 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.224 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.208 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.192 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.176 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.160 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.144 [200/0] via 170.4.1.254, 02:30:24
B 201.145.33.128 [200/0] via 170.4.1.254, 02:30:24
B 207.15.11.0/24 [200/0] via 170.4.1.254, 02:30:25
B 207.15.10.0/24 [200/0] via 170.4.1.254, 02:30:25
     130.4.0.0/16 is variably subnetted, 11 subnets, 3 masks
C 130.4.135.0/24 is directly connected, Ethernet0/0
O IA 130.4.5.0/24 [110/130] via 130.4.100.3, 02:07:20, Serial0/0.1
O E2 130.4.2.0/24 [110/35] via 130.4.100.2, 02:07:20, Serial0/0.1
O 130.4.3.0/24 [110/65] via 130.4.100.3, 02:07:21, Serial0/0.1
O 130.4.35.35/32 [110/11] via 130.4.135.35, 02:07:21, Ethernet0/0
C 130.4.1.0/24 is directly connected, Loopback0
C 130.4.13.0/24 is directly connected, BRI0/0
O IA 130.4.36.0/24 [110/65] via 130.4.100.3, 02:07:21, Serial0/0.1
O IA 130.4.34.0/24 [110/65] via 130.4.100.3, 02:07:21, Serial0/0.1
O IA 130.4.45.0/24 [110/129] via 130.4.100.3, 02:07:21, Serial0/0.1
C 130.4.100.0/28 is directly connected, Serial0/0.1
B 207.15.15.0/24 [200/0] via 170.4.1.254, 02:30:26
B 207.15.14.0/24 [200/0] via 170.4.1.254, 02:30:26
B 207.15.13.0/24 [200/0] via 170.4.1.254, 02:30:26
O E2 210.120.16.0/24 [110/10] via 130.4.135.35, 02:07:21, Ethernet0/0
B 207.15.12.0/24 [200/0] via 170.4.1.254, 02:30:26
R_1#

============================================================================
==============

3550_A#
3550_A#sh run
Building configuration...

Current configuration : 4371 bytes
!
! Last configuration change at 14:51:25 UTC Tue Aug 26 2003
! NVRAM config last updated at 14:51:28 UTC Tue Aug 26 2003
!
version 12.1
no service pad
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname 3550_A
!
!
ip subnet-zero
ip routing
!
!
spanning-tree extend system-id
!
!
!
interface Loopback0
 ip address 130.4.35.35 255.255.255.0
!
interface Loopback190
 ip address 190.4.35.35 255.255.255.0
!
interface FastEthernet0/1
 description R_1
 no switchport
 ip address 130.4.135.35 255.255.255.0
 duplex full
 speed 10
!
interface FastEthernet0/2
 switchport access vlan 504
 switchport mode access
 no ip address
 duplex full
 speed 10
!
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 4,6,1002-1005
 switchport trunk pruning vlan 6
 switchport mode trunk
 no ip address
 duplex full
 speed 100
!
interface FastEthernet0/4
 switchport access vlan 4
 switchport mode access
 no ip address
 duplex full
 speed 10
!
interface FastEthernet0/5
 description R_5
 no ip address
 duplex full
 speed 10
!
interface FastEthernet0/6
 switchport access vlan 6
 switchport mode access
 no ip address
 duplex full
 speed 10
!
!
interface FastEthernet0/10
 description BB_1
 no switchport
 ip address 170.4.1.1 255.255.255.0
 duplex full
 speed 10
!
!
interface FastEthernet0/12
 description BB_2 frame switch
 switchport access vlan 504
 switchport mode access
 no ip address
 duplex full
 speed 100
!
!
interface Vlan1
 no ip address
!
interface Vlan4
 ip address 130.4.34.1 255.255.255.0
!
router ospf 10
 router-id 130.4.35.35
 log-adjacency-changes detail
 redistribute rip metric 10 subnets
 passive-interface default
 no passive-interface FastEthernet0/1
 network 130.4.35.0 0.0.0.255 area 0
 network 130.4.135.0 0.0.0.255 area 0
!
router rip
 timers basic 20 120 120 160
 redistribute ospf 1 metric 5
 network 170.4.0.0
 distribute-list 10 in
 no auto-summary
!
router bgp 65060
 no synchronization
 bgp log-neighbor-changes
 bgp confederation identifier 401
 bgp confederation peers 65050
 network 130.4.0.0
 network 190.4.35.0 mask 255.255.255.0
 neighbor 130.4.135.1 remote-as 65060
 neighbor 170.4.1.254 remote-as 400
 distribute-list 10 in
 no auto-summary
!
ip default-gateway 130.4.34.3
ip classless
ip http server
!
!
!
access-list 10 permit 0.0.0.0 255.255.254.255
!
line con 0
 exec-timeout 0 0
 logging synchronous
line vty 0 4
 login
line vty 5 15
 login
!
end

3550_A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     170.4.0.0/24 is subnetted, 1 subnets
C 170.4.1.0 is directly connected, FastEthernet0/10
R 210.120.14.0/24 [120/1] via 170.4.1.254, 00:00:06, FastEthernet0/10
B 207.15.16.0/24 [20/0] via 170.4.1.254, 02:31:19
R 210.120.12.0/24 [120/1] via 170.4.1.254, 00:00:06, FastEthernet0/10
B 207.15.17.0/24 [20/0] via 170.4.1.254, 02:31:19
     190.4.0.0/24 is subnetted, 6 subnets
C 190.4.35.0 is directly connected, Loopback190
B 190.4.2.0 [200/0] via 130.4.100.2, 01:17:57
B 190.4.3.0 [200/0] via 130.4.100.3, 02:39:17
B 190.4.6.0 [200/0] via 130.4.100.6, 02:39:05
B 190.4.4.0 [200/0] via 130.4.34.4, 02:30:53
B 190.4.5.0 [200/0] via 130.4.34.4, 02:30:53
R 210.120.10.0/24 [120/1] via 170.4.1.254, 00:00:07, FastEthernet0/10
     201.145.33.0/28 is subnetted, 15 subnets
B 201.145.33.112 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.96 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.80 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.64 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.48 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.32 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.16 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.240 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.224 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.208 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.192 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.176 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.160 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.144 [20/0] via 170.4.1.254, 02:31:21
B 201.145.33.128 [20/0] via 170.4.1.254, 02:31:21
B 207.15.11.0/24 [20/0] via 170.4.1.254, 02:31:21
B 207.15.10.0/24 [20/0] via 170.4.1.254, 02:31:22
     130.4.0.0/16 is variably subnetted, 11 subnets, 3 masks
C 130.4.135.0/24 is directly connected, FastEthernet0/1
O IA 130.4.5.0/24 [110/140] via 130.4.135.1, 02:08:17, FastEthernet0/1
O E2 130.4.2.0/24 [110/35] via 130.4.135.1, 02:08:17, FastEthernet0/1
O 130.4.3.0/24 [110/75] via 130.4.135.1, 02:08:18, FastEthernet0/1
O 130.4.1.1/32 [110/11] via 130.4.135.1, 02:08:18, FastEthernet0/1
O IA 130.4.13.0/24 [110/1572] via 130.4.135.1, 02:08:18, FastEthernet0/1
O IA 130.4.36.0/24 [110/75] via 130.4.135.1, 02:08:18, FastEthernet0/1
C 130.4.34.0/24 is directly connected, Vlan4
C 130.4.35.0/24 is directly connected, Loopback0
O IA 130.4.45.0/24 [110/139] via 130.4.135.1, 02:08:18, FastEthernet0/1
O 130.4.100.0/28 [110/74] via 130.4.135.1, 02:08:18, FastEthernet0/1
B 207.15.15.0/24 [20/0] via 170.4.1.254, 02:31:23
B 207.15.14.0/24 [20/0] via 170.4.1.254, 02:31:23
B 207.15.13.0/24 [20/0] via 170.4.1.254, 02:31:23
R 210.120.16.0/24 [120/1] via 170.4.1.254, 00:00:10, FastEthernet0/10
B 207.15.12.0/24 [20/0] via 170.4.1.254, 02:31:23
3550_A#

[GroupStudy removed an attachment of type image/jpeg which had a name of Fiesta Bkgrd.jpg]



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:59 GMT-3