Dialer profile, MLPPP and dialer watch

From: Tony Pang (tonypang@dmx.com.hk)
Date: Mon Aug 11 2003 - 06:16:01 GMT-3


Hi,

I am testing dialer profile, MLPPP and dialer watch at the same time. I have
found that the call drops at the idle time, instead of checking the status
of the watched route. I am pretty sure that I have turned off the idle
timeout in called side.

 I have tested with legacy DDR and it works fine. Here is the debug from the
calling side:
R3-2503#sh int dial 1
Dialer1 is up, line protocol is up
  Hardware is Unknown
  Internet address is 10.56.0.3/24
  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, loopback not set
  DTR is pulsed for 1 seconds on reset
  Time to interface disconnect: idle 00:00:01 <-----
  Interface is bound to BR0:1
  Interface is bound to BR0:2
  LCP Open, multilink Open
  Open: IPCP, CDPCP
  Last input 00:00:09, output never, output hang never
  Last clearing of "show interface" counters 03:44:46
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations 0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 96 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1100 packets input, 95332 bytes

R3-2503#
*Mar 1 03:46:56.807: Di1 DDR: idle timeout <----
Disconnect rather than check watched route
*Mar 1 03:46:56.807: Di1 DDR: disconnecting call
*Mar 1 03:46:56.827: BR0 DDR: has total 1 call(s), dial_out 1, dial_in 0
*Mar 1 03:46:56.831: %DIALER-6-UNBIND: Interface BR0:1 unbound from profile
Di1
*Mar 1 03:46:56.839: BR0:1 DDR: disconnecting call
*Mar 1 03:46:56.839: BR0:1 DDR: Dialer Watch: resetting call in progress
*Mar 1 03:46:56.843: BR0 DDR: has total 0 call(s), dial_out 0, dial_in 0
*Mar 1 03:46:56.851: %DIALER-6-UNBIND: Interface BR0:2 unbound from profile
Di1
*Mar 1 03:46:56.855: BR0:2 DDR: disconnecting call
*Mar 1 03:46:56.863: %ISDN-6-CONNECT: Interface BRI0:2 is now connected to
4081
111111 R2-2503
*Mar 1 03:46:56.871: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected
from 40
81111111 R2-2503, call lasted 92 seconds
*Mar 1 03:46:56.879: %ISDN-6-DISCONNECT: Interface BRI0:2 disconnected
from 40
81111111 R2-2503, call lasted 89 seconds
*Mar 1 03:46:57.007: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
down
*Mar 1 03:46:57.011: BR0:1 DDR: disconnecting call
*Mar 1 03:46:57.811: %LINEPROTO-5-UPDOWN: Line protocol on Interface
BRI0:1, ch
anged state to down
*Mar 1 03:46:57.815: %LINEPROTO-5-UPDOWN: Line protocol on Interface
BRI0:2, ch
anged state to down
*Mar 1 03:46:58.907: %LINK-3-UPDOWN: Interface BRI0:2, changed state to
down
*Mar 1 03:46:58.911: BR0:2 DDR: disconnecting call

Attached please find the config:
Calling side:

!
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3-2503
!
logging buffered 40960 debugging
logging rate-limit console 10 except errors
!
username R2-2503 password 0 cisco
username r2 password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!

!

isdn switch-type basic-ni
cns event-service server
!

!
interface Loopback0
 ip address 172.16.254.3 255.255.255.255
!
interface Loopback1
 ip address 3.3.3.3 255.255.255.255
!
interface Loopback3
 ip address 33.33.33.33 255.255.255.255
!
interface Ethernet0
 mac-address 4444.3333.3333
 ip address 192.168.150.73 255.255.255.0
 ip router isis net150
 service-policy output pmap-service

!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tx-ring-limit 4
 tx-queue-limit 4
 service-policy input pmap-sub
 service-policy output pmap-sub
 no fair-queue
 no arp frame-relay
 frame-relay traffic-shaping
 no frame-relay inverse-arp
 ip rsvp bandwidth 32 8
!
interface Serial0.1 point-to-point
 ip address 192.168.102.3 255.255.255.0
 ip pim nbma-mode
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 no ip mroute-cache
 shutdown
 frame-relay interface-dlci 304
!
interface Serial0.3 point-to-point
 ip address 192.168.103.3 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key cisco
 ip ospf network non-broadcast
 ip ospf cost 100
 ip ospf hello-interval 10
 no ip mroute-cache
 shutdown
 frame-relay interface-dlci 302
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 40822222221
 isdn spid2 40822222222
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
 ppp authentication chap
 ppp multilink
!
interface Dialer1
 ip address 10.56.0.3 255.255.255.0
 encapsulation ppp
 ip ospf cost 9999
 dialer pool 1
 dialer remote-name R2-2503
 dialer idle-timeout 90
 dialer string 4081111111
 dialer load-threshold 1 outbound
 dialer watch-group 2
 dialer-group 1
 ppp authentication chap
 ppp multilink
!

router ospf 1
 router-id 172.16.254.3
 log-adjacency-changes
 area 56 virtual-link 172.16.254.2 authentication authentication-key cisco
 area 60 virtual-link 172.16.254.2
 network 3.3.3.3 0.0.0.0 area 0
 network 10.56.0.0 0.0.0.255 area 56
 network 172.16.254.0 0.0.0.255 area 0
 network 192.168.102.0 0.0.0.255 area 0
 network 192.168.103.0 0.0.0.255 area 60
 neighbor 192.168.103.2
!
 --More--  router isis net150
 net 49.3333.3333.3333.00
 set-overload-bit
!
router isis
 is-type level-1
!
router rip
 network 192.168.150.0
!
ip kerberos source-interface any
ip classless
ip route 99.99.99.3 255.255.255.255 Ethernet0
no ip http server
!
!
access-list 103 deny ospf any any
access-list 103 permit ip any any

dialer watch-list 2 ip 172.16.254.2 255.255.255.255

dialer-list 1 protocol ip list 103

!

!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

R3-2503#

Called side:
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2-2503
!
netbios access-list host nbfilter deny C
logging buffered 40960 debugging
logging rate-limit console 10 except errors
!
username R3-2503 password 0 cisco
username r3-password password 0 juniper
username jerk password 0 cisco
username r3 password 0 cisco
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip multicast-routing

!
!

!
isdn switch-type basic-ni
cns event-service server
!

!
!
!
interface Loopback0
 ip address 172.16.254.2 255.255.255.255
 no ip mroute-cache
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.0
!

interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
 ip access-group 161 in

 no ip route-cache
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 no ip mroute-cache

interface Serial0
 bandwidth 1500
 no ip address
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 no arp frame-relay
 frame-relay traffic-shaping
 ip rsvp bandwidth 32 8

!
interface Serial0.3 point-to-point
 ip address 192.168.103.2 255.255.255.0
 no ip route-cache
 ip ospf authentication-key cisco
 ip ospf network broadcast
 ip ospf priority 0
 no ip mroute-cache
 frame-relay interface-dlci 203
  class DLCI-203

!
interface BRI0
 no ip address
 encapsulation ppp
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 40811111111
 isdn spid2 40811111112
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
 no peer default ip address
 ppp authentication chap
 ppp multilink
!
interface Dialer0
 no ip address
 no cdp enable
!
interface Dialer1
 ip address 10.56.0.2 255.255.255.0
 encapsulation ppp
 ip ospf cost 9999
 ip ospf demand-circuit
 dialer pool 1
 dialer remote-name R3-2503
 dialer idle-timeout 0
 dialer wait-for-carrier-time 15
 ppp authentication chap
 ppp multilink
!
interface Dialer2
 ip address 10.64.0.2 255.255.255.0
 encapsulation ppp
 dialer pool 2
 dialer remote-name r3
 dialer idle-timeout 0
 ppp authentication chap
 ppp chap hostname r2
!
router ospf 1
 router-id 172.16.254.2
 log-adjacency-changes
 area 0 authentication
 area 56 virtual-link 172.16.254.3 authentication-key cisco
 area 60 authentication
 area 60 virtual-link 172.16.254.3 authentication null
 redistribute static metric 1 subnets
 network 10.1.1.0 0.0.0.255 area 1
 network 10.56.0.0 0.0.0.255 area 56
 network 172.16.254.0 0.0.0.255 area 60
 network 192.168.103.0 0.0.0.255 area 60
 default-information originate always metric 10
!

ip kerberos source-interface any
ip classless

!
!

dialer-list 1 protocol ip permit
lat service R2 enabled

!
line con 0
 transport input none
line aux 0
line vty 0 4
 password master
 login
!
end



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:57 GMT-3