Re: CBWFQ configurations

From: Cristian Henry H (chenry@reuna.cl)
Date: Thu Aug 07 2003 - 13:30:26 GMT-3


My opinios is;
If you config voice traffic with LLQ (LLQ+WFQ scheme) at least I get the
following:

policy-map cbwfq
 class voice
  priority percent 40
 class net10
  bandwidth percent 66
 class ftp
  bandwidth percent 33
!
int se0/0
 service-policy output cbwfq
 max-reserved-bandwidth 50
!

Explanations:

Total BW = 100 Kbps
Max-reserved-bandwidth = 50

Class voice (priority percent 40)= 100 x 0.4 = 40 Kbps
Class net10 (bandwidth percent 66) = ((100 - 40) x 0.5) x 0.66 = 20 Kbps
Class ftp (bandwidth percent 33) = ((100 - 40) x 0.5) x 0.33 = 10 Kbps
Default = (100 - 40) - ((100 - 40) x 0.5) = 30 Kbps

Total BW = 40 + 20 + 10 + 30 = 100 Kbps, this agree with requirements:

 - User in network 10.10.10.0/24 will get 20% BW
 - FTP traffic will get 10% BW
 - Voice traffic will get 40% BW
 - All of the remain traffic will use the remain of the BW
 
Any comments are appreciated

Nguyen Hoang Long ha escrito:
>
> Hi Binh,
>
> First, the solution to use LLQ & CBWFQ only works when congestions occurs,
> otherwise, we have to seek an alternative way.
>
> Assumes that your requirement is used for congestion time, if i remember
> right, IOS rules for your scenario is:
> "priority percent" is percent of (interface BW)
> "bandwidth percent" is percent of (interface BW- LLQ)
>
> So your two solutions don't make any difference, with "percent" keyword, BW
> is not affected by 75% percent rule.
>
> Additionally, those should be used:
> + voice traffic must be put in priority queue with the "priority", not
> "bandwidth"
> + since you used statement like : "match protocol ftp", NBAR & CEF must
> be enabled.
>
> Now, thing becomes more complicated with this rule:
> "bandwidth percent" is percent of (interface BW- LLQ);
> take your 1st configuration as example, your FTP traffic will only get
> 10% of (BW-voice traffic) = 10% of ( 60%BW) = 6% BW.
> it should be "bandwidth percent 17" so FTP traffic will get 17% of
> (BW-voice traffic) = 17% of ( 60%BW) = 10.2 % BW.
>
> identically, you will have result like this:
> class voice
> priority percent 40
> class net10
> bandwidth percent 33
> class ftp
> bandwidth percent 17
>
> Check again this link:
> http://127.0.0.1:8080/cc/td/doc/product/software/ios122/122cgcr/fqos_r/qrfcmd1.htm#xtocid2
> http://127.0.0.1:8080/cc/td/doc/product/software/ios122/122cgcr/fqos_r/qrfcmd6.htm#xtocid3
>
> So, if you can specify bandwidth for interface, specifying exact bandwidth
> in kbps + "max-reserve-bw 100" make it more simple.
>
> Again, solution only work for congestions period.
>
> Any comments ?
>
> Good luck,
> Long
>
> ----- Original Message -----
> From: "Lam Binh" <lambinh@hcm.vnn.vn>
> To: "'CCIE Lab GroupStudy'" <ccielab@groupstudy.com>
> Sent: Tuesday, August 05, 2003 6:03 PM
> Subject: CBWFQ configurations
>
> > Hello Groups,
> >
> > I would like to confirm whether my solution is correct or not.
> >
> > The requirement to configure CBWFQ as follows:
> >
> > - User in network 10.10.10.0/24 will get 20% BW
> > - FTP traffic will get 10% BW
> > - Voice traffic will get 40% BW
> > - All of the remain traffic will use the remain of the BW
> >
> > I have two solution of configurations as:
> >
> > 1.
> > class-map match-all Voice
> > match access-group 102
> > class-map match-all ftp
> > match protocol ftp
> > class-map match-all net10
> > match access-group 101
> >
> > policy-map cbwfq
> > class voice
> > bandwidth percent 40
> > class net10
> > bandwidth percent 20
> > class ftp
> > bandwidth percent 10
> > class class-default
> > bandwidth percent 35
> >
> >
> > access-list 101 permit ip 10.10.10.0 0.0.0.255 any
> > access-list 102 permit udp any any range 16384 32767
> > access-list 102 permit udp any range 16384 32767 any
> >
> > int se0/0
> > service-policy output cbwfq
> > max-reserved-bandwidth 100
> >
> > 2.
> > class-map match-all Voice
> > match access-group 102
> > class-map match-all ftp
> > match protocol ftp
> > class-map match-all net10
> > match access-group 101
> >
> > policy-map cbwfq
> > class voice
> > bandwidth percent 40
> > class net10
> > bandwidth percent 20
> > class ftp
> > bandwidth percent 10
> >
> > access-list 101 permit ip 10.10.10.0 0.0.0.255 any
> > access-list 102 permit udp any any range 16384 32767
> > access-list 102 permit udp any range 16384 32767 any
> >
> > int se0/0
> > service-policy output cbwfq
> > max-reserved-bandwidth 70
> >
> > Please advise both above methods are correct or not to meet the
> > requirements?
> > Which one is referable?
> >
> > thank you in advance!
> >
> > Lam Binh
> >
> >
> > _______________________________________________________________________
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

-- 
Cristian E. Henry
REUNA

E-mail: chenry@reuna.cl Fono: 56-2-3370336



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:54 GMT-3