RE: ISIS with dialer watch?

From: Hunt Lee (huntl@webcentral.com.au)
Date: Sun Aug 03 2003 - 23:29:44 GMT-3


Hi Brian,

Here is the full config:-

R5-

version 12.2

service timestamps debug datetime msec show-timezone

service timestamps log datetime msec show-timezone

no service password-encryption

!

hostname r5

!

enable secret 5 $1$Mjhz$l30tkrcUiMSmRdJJWJ.bZ.

!

username User_C password 0 isdn

ip subnet-zero

no ip domain-lookup

!

ip multicast-routing

isdn switch-type basic-net3

!
!
!
interface Loopback0
 ip address 192.168.5.5 255.255.255.255

interface Loopback101

 ip address 192.168.101.1 255.255.255.0

!

interface Ethernet0

 ip address 172.16.136.5 255.255.255.0 secondary

 ip address 172.168.136.5 255.255.255.192

 ip router isis

 ip pim sparse-dense-mode

 standby 1 ip 172.16.136.1

 standby 1 priority 210

 standby 1 preempt

 standby 1 track Serial0 50

!

interface Serial0

 ip address 172.16.2.5 255.255.255.0
 ip router isis
 encapsulation frame-relay
 no fair-queue
 clockrate 2000000
 frame-relay map ip 172.16.2.2 501 broadcast
!

interface Serial1

 no ip address

 shutdown

 no fair-queue

 clockrate 64000

!

interface BRI0

 ip address 172.16.3.5 255.255.255.0

 ip router isis

 encapsulation ppp

 dialer watch-disable 60

 dialer map ip 172.16.3.2 name User_C broadcast 2222

 dialer map ip 172.16.137.0 name User_C broadcast 2222

 dialer map clns 49.0001.0192.0168.0202.00 name User_C broadcast 2222
 dialer load-threshold 127 either
 dialer watch-group 1
 dialer-group 1
 isdn switch-type basic-net3
 ppp authentication chap

router isis
 net 49.0001.0192.0168.0505.00
 passive-interface Loopback0
 area-password ipexpert
!

router bgp 8888

 no synchronization

 bgp log-neighbor-changes

 network 192.168.100.0

 network 192.168.101.0

 aggregate-address 192.168.100.0 255.255.254.0 summary-only

 neighbor 192.168.2.2 remote-as 8888

 neighbor 192.168.2.2 update-source Loopback0

 neighbor 192.168.2.2 timers 90 270

 no auto-summary

!
ip classless
no ip http server
!
dialer watch-list 1 ip 172.16.137.0 255.255.255.0
!

dialer-list 1 protocol ip permit

!

alias exec shiprt sh ip route

alias exec shint sh ip int brief

!

line con 0

line aux 0

line vty 0 4
 no login
!
end

R2:-

service timestamps debug datetime msec show-timezone
service timestamps log datetime msec show-timezone
no service password-encryption
!
hostname r2
!
!
username r5 password 0 isdn
ip subnet-zero
ip cef
no ip domain-lookup
frame-relay de-list 1 protocol ip gt 512
isdn switch-type basic-net3

interface Loopback0
 ip address 192.168.2.2 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 clockrate 2000000
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial0.1 point-to-point
 ip address 172.16.1.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 frame-relay de-group 1 104
 frame-relay interface-dlci 104

interface Serial0.2 multipoint
 ip address 172.16.2.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 frame-relay de-group 1 105
 frame-relay de-group 1 106
 frame-relay map clns 105 broadcast
 frame-relay map clns 106 broadcast
 frame-relay map ip 172.16.2.5 105 broadcast
 frame-relay map ip 172.16.2.6 106 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 description Simulate Ethernet0 going back to R1
 ip address 172.16.137.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 tag-switching ip
!
interface BRI0
 ip address 172.16.3.2 255.255.255.0
 no ip directed-broadcast
 ip router isis
 encapsulation ppp
 dialer map ip 172.16.3.5 name r5 broadcast 1111
 dialer map clns 49.0001.0192.0168.0505.00 name r5 broadcast 1111
 isdn switch-type basic-net3
 ppp authentication chap
 ppp chap hostname User_C
 ppp chap password 7 151B18080A
 ppp multilink

router isis
 passive-interface Loopback0
 net 49.0001.0192.0168.0202.00
 area-password ipexpert
!
router bgp 8888
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.1.1 remote-as 8888
 neighbor 192.168.1.1 update-source Loopback0
 neighbor 192.168.1.1 route-reflector-client
 neighbor 192.168.4.4 remote-as 8888
 neighbor 192.168.4.4 route-reflector-client
 neighbor 192.168.5.5 remote-as 8888
 neighbor 192.168.5.5 update-source Loopback0
 neighbor 192.168.5.5 timers 90 270
 neighbor 192.168.5.5 route-reflector-client
 no auto-summary
!
ip classless
no ip pim bidir-enable
 
                                        
!
!
!
line con 0
line aux 0
line vty 0 4
 password ipexpert
 login
!
end
                                                                    
r2#

-----Original Message-----
From: Brian Dennis [mailto:bdennis@internetworkexpert.com]
Sent: Monday, 4 August 2003 3:26 AM
To: Hunt Lee
Subject: RE: ISIS with dialer watch?

Can you send the config for R5 also?

Brian

-----Original Message-----
From: Hunt Lee [mailto:huntl@webcentral.com.au]
Sent: Sunday, August 03, 2003 4:05 AM
To: 'Brian Dennis'
Cc: 'ccielab@groupstudy.com'
Subject: RE: ISIS with dialer watch?

Hi Brian,

I have 2 routers...

On R2 (called party)

router isis
 passive-interface Loopback0
 net 49.0001.0192.0168.0202.00
 area-password ipexpert

so the NET should be 49.0001.0192.0168.0202.00, right?

ANd on the other side R5 (calling party)

I have:-

interface BRI0
 ip address 172.16.3.5 255.255.255.0
 ip router isis
 encapsulation ppp
 dialer watch-disable 60
 dialer map ip 172.16.3.2 name User_C broadcast 2222
 dialer map ip 172.16.137.0 name User_C broadcast 2222
 dialer map clns 49.0001.0192.0168.0202.00 name User_C broadcast 2222
 dialer load-threshold 127 either
 dialer watch-group 1
 isdn switch-type basic-net3
 ppp authentication chap
 ppp multilink
end

The ISDN link is working for normal IP traffic, I can ping 172.16.3.2
fine
from R5... but the ISIS adjacency just doesn't want to come up (it is
stuck
on Init state)

N.B:- Both routers have correct Area password configured, since my ISIS
adjacency via the FR is fine.

Thanks in advance,

Regards,
Hunt

-----Original Message-----
From: Brian Dennis [mailto:bdennis@internetworkexpert.com]
Sent: Sunday, 3 August 2003 5:38 PM
To: Hunt Lee; bmcgahan@internetworkexpert.com
Cc: ccielab@groupstudy.com
Subject: RE: ISIS with dialer watch?

Hunt,
Map to the other side's NET and include the broadcast keyword in the
dialer map statement. Also if you need ISIS to trigger the call, use
"clns_is" in the dialer-list. Of course for dialer watch it isn't
needed.

If your ISIS is setup correctly you should be able to ping the other
side with CLNS.

Router#ping clns <other side's NET>

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Hunt Lee
Sent: Saturday, August 02, 2003 11:56 PM
To: 'Brian McGahan'
Cc: 'ccielab@groupstudy.com'
Subject: RE: ISIS with dialer watch?

HI Brian,

Is there anywhere you can pointed me to an e.g. of setting up ISIS over
ISDN? I know that I have to put in dialer map clns command, but what
value
should I put for the NSAP address?

THanks in advance,

Regards,
Hunt

-----Original Message-----
From: Brian McGahan [mailto:brian@cyscoexpert.com]
Sent: Thursday, 17 April 2003 11:56 AM
To: 'Niksa Tomulic'; ccielab@groupstudy.com
Subject: RE: ISIS with dialer watch?

Niksa,

        With dialer-watch, there is no need for a dialer-list to specify
interesting traffic. The dialer-watch list is the interesting traffic
instead.

        The config for dialer-watch with IS-IS will be the same as with
any other IP routing protocol, but don't forget to map CLNS on the
interface. Remember that with any multipoint non-broadcast interface,
you need a static protocol mapping for any protocol you are running on
that interface. Since IS-IS is part of the CLNS stack, not the IP
stack, you must do a dialer map for CLNS.

HTH

Brian McGahan, CCIE #8593
Director of Design and Implementation
brian@cyscoexpert.com

CyscoExpert Corporation
Internetwork Consulting & Training
Toll Free: 866-CyscoXP
Outside US: 847.674.3392
Fax: 847.674.2625

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Niksa Tomulic
> Sent: Wednesday, April 16, 2003 6:32 PM
> To: ccielab@groupstudy.com
> Subject: ISIS with dialer watch?
>
> Hi list
> Is it possible to use dialer watch scenario with ISIS?
> I remember seeing some posts, but God himself can't find them when I
> need them
>
> dialer-list 1 protocol clns_is permit
> Will define right traffic as interesting, but how to stop it being up
> all the time?
>
> thnx



This archive was generated by hypermail 2.1.4 : Tue Sep 02 2003 - 18:53:52 GMT-3