RE: Class-map order in a service policy?

From: Andrew Crampton (andrew.crampton@ntlworld.com)
Date: Sat Jul 19 2003 - 17:26:28 GMT-3


Tim,

Yes it does matter which order the classes are specified in the policy

From
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos
_c/fqcprt8/qcfmdcli.htm

Note A packet can match only one traffic class within a traffic policy. If
a packet matches more than one traffic class in the traffic policy, the
first traffic class defined in the policy will be used.

So if you had

access-list 101 permit ip any any
access-list 102 permit tcp any any eq telnet

class-map anything
match access-group 101
class-map telnet
match access-group 102

In this order:

policy-map data
class anything
bandwidth 10
class telnet
bandwidth 30

telnet traffic would fall into class "anything" as it's the first class that
matches it. That's why if you do a show policy data, the class-default is
at the bottom to catch any unclassified traffic.

Regards

Andrew.

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Timothy Snow
Sent: 19 July 2003 06:01
To: ccielab@groupstudy.com
Subject: Class-map order in a service policy?

I have a question regarding the order of class-maps? Does it make a
difference in a service policy. My task was to give IP traffic a
bandwith of 40% of the link while telnet gets 10%. I know that it won't
really kick in until there is contention for the link but the "show
policy-map int s 0" shows that traffic is hitting the IP class but not
the telnet class even though I have telnet sessions active.

Could anyone elaborate on if there is a structured order?

interface Serial0
 ip address 150.20.0.5 255.255.255.224
 encapsulation frame-relay
 service-policy output foo
 no arp frame-relay
 frame-relay map ip 150.20.0.2 504
 frame-relay map ip 150.20.0.4 504 broadcast
 frame-relay map ip 150.20.0.6 504
 no frame-relay inverse-arp
 frame-relay lmi-type cisco

policy-map foo
  class ip
   bandwidth percent 40
  class telnet
   bandwidth percent 10
  class class-default
   fair-queue

access-list 100 permit ip any any
access-list 101 permit tcp any any eq telnet log

r5>sh policy-map int s 0

 Serial0

  Service-policy output: foo

    Class-map: ip (match-all)
      504 packets, 210843 bytes
      5 minute offered rate 16000 bps, drop rate 0 bps
      Match: access-group 100
      Weighted Fair Queueing
        Output Queue: Conversation 265
        Bandwidth 40 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 427/204125
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: telnet (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 101
      Weighted Fair Queueing
        Output Queue: Conversation 266
        Bandwidth 10 (%) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
      35 packets, 455 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Weighted Fair Queueing
        Flow Based Fair Queueing
        Maximum Number of Hashed Queues 256
        (total queued/total drops/no-buffer drops) 0/0/0



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:46 GMT-3