RE: Redistribution

From: Jonathan V Hays (jhays@jtan.com)
Date: Sat Jul 12 2003 - 12:57:25 GMT-3


> Hello, Group. I am doing the same scenario and I am seeing
> the same thing
> as ccie2be. My router is running both OSFP and EIGRP and
> redistributing
> between each protocol. When I do a redistribute connected
> under OSPF for a
> loopback not under process, the route does not get sent back
> to the EIGRP
> domain. I believe this is how it should act. Here's my logic:
>
> The routes that are being redistributed into EIGRP are routes
> learned by
> OSPF and any connected networks on the router which are under the OSPF
> process. If a connected network is not under any routing
> process, then how
> can it be redistributed into EIGRP from OSPF? The router does
> not know it as
> an OSPF route. If you were to add this connected network
> under the OSPF
> process then the EIGRP domain would get the route. That's
> why you also have
> to do a "redistribute connected" under EIGRP. So that the
> EIGRP domain can
> have that connected network as well.
>
> I've been looking like crazy on CCO, but cannot find a link
> to back this up.
> Why this is, who knows? But, that's my theory.
>
> Thanks,
> Danny

My theory is that it is situation dependent and IOS-version dependent.

IOS will check the routing table to see what routes should be
redistributed. It will check the routing protocol's database for a
source of routes - but not always - depending on the situation and the
version of IOS. On the CCIE Lab exam you have to play it by ear. If it
won't redistribute automatically throw in "redistribute connected"
verify the results and move on to the next task.

Below is a case where "auto-redistribute-connected" (as I call it)
works.

r1--serial--r2--ethernet--r6

R1 and R2 are connected via direct serial link, 10.1.2.x/24.
R2 and R6 are connected via Ethernet, 10.1.1.x/24.
R2 and R1 run OSPF.
R2 and R6 run EIGRP.
Redistribution both ways takes place on R2.

R1:
interface Loopback1
 ip address 11.11.11.11 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1
 ip address 10.1.2.1 255.255.255.0
 clockrate 64000
!
router ospf 1
 log-adjacency-changes
 network 10.1.2.1 0.0.0.0 area 0
 network 11.11.11.0 0.0.0.255 area 0

R2:
interface Loopback1
 ip address 22.22.22.22 255.255.255.0
!
interface Loopback2
 ip address 26.26.26.26 255.255.255.0
!
interface Loopback3
 ip address 213.213.213.213 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 10.1.1.2 255.255.255.0
!
interface Serial1
 ip address 10.1.2.2 255.255.255.0
!
router eigrp 1
 redistribute ospf 1 metric 1000 100 255 1 1500
 network 10.0.0.0
 network 26.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 redistribute eigrp 1 metric 20 subnets
 network 10.1.2.2 0.0.0.0 area 0
 network 213.213.213.213 0.0.0.0 area 0

R6:
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.0
!
interface Loopback1
 ip address 66.66.66.66 255.255.255.0
!
interface Ethernet0
 ip address 10.1.1.6 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 66.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes

Routing Tables:

r1#sh ip route | exclude -

Gateway of last resort is not set

O 213.213.213.0/24 [110/65] via 10.1.2.2, 00:14:00, Serial1
     66.0.0.0/24 is subnetted, 1 subnets
O E2 66.66.66.0 [110/20] via 10.1.2.2, 00:14:01, Serial1
     10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, Serial1
O E2 10.1.1.0 [110/20] via 10.1.2.2, 00:14:01, Serial1
     26.0.0.0/24 is subnetted, 1 subnets
O E2 26.26.26.0 [110/20] via 10.1.2.2, 00:14:01, Serial1
     11.0.0.0/24 is subnetted, 1 subnets
C 11.11.11.0 is directly connected, Loopback1
r1#

r2#sh ip route | exclude -

Gateway of last resort is not set

C 213.213.213.0/24 is directly connected, Loopback3
     66.0.0.0/24 is subnetted, 1 subnets
D 66.66.66.0 [90/409600] via 10.1.1.6, 00:17:23, Ethernet0
     22.0.0.0/24 is subnetted, 1 subnets
C 22.22.22.0 is directly connected, Loopback1
     10.0.0.0/24 is subnetted, 2 subnets
C 10.1.2.0 is directly connected, Serial1
C 10.1.1.0 is directly connected, Ethernet0
     26.0.0.0/24 is subnetted, 1 subnets
C 26.26.26.0 is directly connected, Loopback2
     11.0.0.0/24 is subnetted, 1 subnets
O 11.11.11.0 [110/65] via 10.1.2.1, 00:14:37, Serial1
r2#

r6#sh ip route | exclude -

Gateway of last resort is not set

D EX 213.213.213.0/24 [170/2611200] via 10.1.1.2, 00:18:02, Ethernet0
     66.0.0.0/24 is subnetted, 1 subnets
C 66.66.66.0 is directly connected, Loopback1
     6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
D 10.1.2.0 [90/2195456] via 10.1.1.2, 00:17:36, Ethernet0
C 10.1.1.0 is directly connected, Ethernet0
     26.0.0.0/24 is subnetted, 1 subnets
D 26.26.26.0 [90/409600] via 10.1.1.2, 00:18:03, Ethernet0
     11.0.0.0/24 is subnetted, 1 subnets
D EX 11.11.11.0 [170/2611200] via 10.1.1.2, 00:15:19, Ethernet0
r6#

Note that most of the connected routes are automatically redistributed.
I'll get back to that "most of" in a minute.

Networks 26.26.26.0/24 is "Connected" on R2 (lo2) and is advertised
under EIGRP to R6. Two EIGRP routes, network 26.26.26.0/24 and the
10.1.1.0/24 Ethernet connection to EIGRP router R6, also show up on R1
as OSPF External Type 2 routes via the redistribution process from EIGRP
to OSPF. I did not have to inject either of these routes separately into
OSPF with "redistributed connected."

Similarly, network 213.213.213.0/24 on R2 (lo3) is advertised under OSPF
to R1 and also shows up on R6 via redistribution as an EIGRP External
route, without "redistribute connected" on R2. However, note that the
10.1.2.0 OSPF network between R2 and R1 shows up as a native EIGRP
route. Why? This is because I injected 10.0.0.0 into EIGRP and did not
specify the exact subnet.

BTW, "passive interface s1" under EIGRP will not stop 10.1.2.0/24 from
being injected into EGIRP and advertised to the R6 EIGRP-only router.

If I make a change on R2 to specify exact interfaces under EIGRP, then
the "auto-redistribute-connected" function works.

R2:
router eigrp 1
 redistribute ospf 1 metric 1000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 network 26.26.26.0 0.0.0.255
 no auto-summary

r6#sh ip route | exclude -

Gateway of last resort is not set

D EX 213.213.213.0/24 [170/2611200] via 10.1.1.2, 00:02:46, Ethernet0
     66.0.0.0/24 is subnetted, 1 subnets
C 66.66.66.0 is directly connected, Loopback1
     6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
D EX 10.1.2.0 [170/2611200] via 10.1.1.2, 00:02:46, Ethernet0
C 10.1.1.0 is directly connected, Ethernet0
     26.0.0.0/24 is subnetted, 1 subnets
D 26.26.26.0 [90/409600] via 10.1.1.2, 00:01:23, Ethernet0
     11.0.0.0/24 is subnetted, 1 subnets
D EX 11.11.11.0 [170/2611200] via 10.1.1.2, 00:02:46, Ethernet0
r6#

So you can see that the "auto-redistribute-connected" function is
sensitive to the configuration. I'm sure we could come up with many more
complexities to change the above results.

As of today, July 12, 2003, I am running 12.1(19) in my 2500 series
router lab. In other versions of the IOS I have been forced to use
"redistributed connected" to get the same results as above.

From my limited experience, it appears to me that Cisco doesn't publish
specifications of exactly how their redistribution processes work
because they are not fully consistent in the implementation from version
to version.

HTH,

Jonathan



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:37 GMT-3