From: Brit Walker \(brwalker\) (brwalker@cisco.com)
Date: Thu Jul 03 2003 - 16:28:45 GMT-3
Take a look at the attached scenario and configuration. I do not believe
this
config is correct. I wanted to get some feedback on it to help get it
correct.
FR will be accepting streaming TCP traffic from R2 and R3
on Ethernet 0 and passing traffic out interface Serial 8
(pretend it's a high-speed interface). Configure FR to avoid
congestion for outbound traffic on Serial 8. Do not use tail
drop as the congestion avoidance mechanism. Devise and apply
a traffic management scheme using the follwing criteria.
- Use a policy named MY-POLICY
- Use classes named CLASS2 for R2 traffic and CLASS3 for R3
traffic. Match all traffic for each and have any access lists
correspond to the number in each router's name.
- Avoid congestion ny dropping R2 traffic that exceeds 20 %
of the total bandwidth and R3 traffic that exceeds 30 % of the
total bandwidth.
- Use access list 2 to match input traffic from R2 and access
list 3 to match input traffic from R3.
- Include some type of descriptive comment with each access list.
- Apply the policy to FR's Serial 8 interface, the egress interface.
Brit
FR will be accepting streaming TCP traffic from R2 and R3
on Ethernet 0 and passing traffic out interface Serial 8
(pretend it's a high-speed interface). Configure FR to avoid
congestion for outbound traffic on Serial 8. Do not use tail
drop as the congestion avoidance mechanism. Devise and apply
a traffic management scheme using the follwing criteria.
- Use a policy named MY-POLICY
- Use classes named CLASS2 for R2 traffic and CLASS3 for R3
traffic. Match all traffic for each and have any access lists
correspond to the number in each router's name.
- Avoid congestion ny dropping R2 traffic that exceeds 20 %
of the total bandwidth and R3 traffic that exceeds 30 % of the
total bandwidth.
- Use access list 2 to match input traffic from R2 and access
list 3 to match input traffic from R3.
- Include some type of descriptive comment with each access list.
- Apply the policy to FR's Serial 8 interface, the egress interface.
fr#wri t
Building configuration...
02:31:09: %SYS-5-CONFIG_I: Configured from console by console
Current configuration : 3489 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname fr
!
enable password cisco
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
ip host r1 192.100.1.1
ip host r2 192.100.2.2
ip host r3 192.100.3.3
ip host r4 192.100.4.4
ip host r5 192.100.5.5
ip host r6 192.100.6.6
ip host fr 192.100.7.7
!
frame-relay switching
!
class-map match-all CLASS2
match access-group 2
class-map match-all CLASS3
match access-group 3
!
!
policy-map MY-POLICY
class CLASS2
bandwidth percent 20
police 300000 9375 9375 conform-action transmit exceed-action drop
class CLASS3
bandwidth percent 30
police 460000 14375 14375 conform-action transmit exceed-action drop
!
!
key chain trees
key 1
key-string cisco
!
!
!
!
interface Loopback0
ip address 192.100.7.7 255.255.255.0
!
interface Loopback150
ip address 150.150.100.7 255.255.255.0
!
interface Ethernet0
ip address 172.16.237.7 255.255.255.0
!
interface Serial0
description TO R1
no ip address
encapsulation frame-relay
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 102 interface Serial1 201
frame-relay route 103 interface Serial2 301
frame-relay route 104 interface Serial3 401
!
interface Serial1
description TO R2
no ip address
encapsulation frame-relay
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 201 interface Serial0 102
frame-relay route 203 interface Serial2 302
frame-relay route 204 interface Serial3 402
!
interface Serial2
description TO R3
no ip address
encapsulation frame-relay
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 301 interface Serial0 103
frame-relay route 302 interface Serial1 203
frame-relay route 304 interface Serial3 403
!
interface Serial3
description TO R4
no ip address
encapsulation frame-relay
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 401 interface Serial0 104
frame-relay route 402 interface Serial1 204
frame-relay route 403 interface Serial2 304
!
interface Serial4
no ip address
shutdown
!
interface Serial5
no ip address
shutdown
!
interface Serial6
no ip address
shutdown
!
interface Serial7
no ip address
shutdown
!
interface Serial8
ip address 120.20.70.7 255.255.255.0
service-policy output MY-POLICY
clockrate 64000
!
interface Serial9
no ip address
shutdown
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
!
router eigrp 1
variance 2
redistribute eigrp 27 metric 64 100 255 1 1500
network 172.16.237.0 0.0.0.255
network 192.100.7.0
neighbor 172.16.237.2 Ethernet0
neighbor 172.16.237.3 Ethernet0
maximum-paths 2
no auto-summary
!
router eigrp 27
redistribute eigrp 1 metric 64 100 255 1 1500
network 120.0.0.0
neighbor 120.20.70.254 Serial8
distribute-list 1 in Serial8
no auto-summary
!
router bgp 7
no synchronization
bgp router-id 192.100.7.7
bgp log-neighbor-changes
network 150.150.100.0 mask 255.255.255.0
neighbor 172.16.237.2 remote-as 2
neighbor 172.16.237.2 password cisco
neighbor 172.16.237.3 remote-as 3
neighbor 172.16.237.3 password cisco
!
no ip classless
ip http server
!
access-list 1 permit 170.70.0.0 0.0.255.255
access-list 2 permit 172.16.237.2
access-list 2 remark Traffic from R2
access-list 3 permit 172.16.237.3
access-list 3 remark Traffic from R3
!
line con 0
exec-timeout 0 0
line aux 0
password cisco
login
line vty 0 4
exec-timeout 0 0
password cisco
login
!
end
fr#sh policy MY-POLICY
Policy Map MY-POLICY
Class CLASS2
Bandwidth 20 (%) Max Threshold 64 (packets)
police 300000 9375 conform-action transmit exceed-action drop
Class CLASS3
Bandwidth 30 (%) Max Threshold 64 (packets)
police 460000 14375 conform-action transmit exceed-action drop
fr#
This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:22 GMT-3