RE: ISDN PPP Callback with Dialer Watch

From: Brian Dennis (brian@labforge.com)
Date: Wed Jul 02 2003 - 15:37:46 GMT-3


That is the behavior of dialer watch. If there is at least one of the
watched routes in the routing table not learned by the backup interface
the dialer watch feature will not trigger a call. If there isn't a
dialer map for the last route in the routing table when all routes are
lost then it will pick any existing dialer map for another watched
route. If I was asked to watch two routes and call two different
destinations I would just use two dialer interfaces.

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
 
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Ram Shummoogum
Sent: Wednesday, July 02, 2003 7:03 AM
To: brian@labforge.com
Cc: ccielab@groupstudy.com
Subject: RE: ISDN PPP Callback with Dialer Watch

Brian:

I just tested that there is no need to add a dialer map statement for
each
route. I am watching 2 routes and I put a dialer map for just one of the
two routes.
However, all the watched routes will need to be removed from the routing
table for the isdn to kick in.

Regards,
RAM

"Brian Dennis" <brian@labforge.com>@groupstudy.com on 07/02/2003
03:11:49
AM

Please respond to "Brian Dennis" <brian@labforge.com>

Sent by: nobody@groupstudy.com

To: <wing_lam@jossynergy.com>, <gjcomcast@comcast.net>
cc: <ccielab@groupstudy.com>
Subject: RE: ISDN PPP Callback with Dialer Watch

You will need a dialer map for each watched route. The reason is you
need to tell the router where to call with the route is "lost". You
could have a situation where you call site A for one route and site B
for another route.

If the watched route disappears from the routing table the router will
look for a dialer map matching the "network" of the watched route. If
you only want to watch the /26 and not the /29 you would do this:

Router(config)#dialer watch-list 1 ip 192.168.10.64 255.255.255.224

Just don't include the /29 in the dialer watch-list.

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
wing_lam@jossynergy.com
Sent: Tuesday, July 01, 2003 11:37 PM
To: Brian Dennis; gjcomcast@comcast.net
Cc: ccielab@groupstudy.com
Subject: RE: ISDN PPP Callback with Dialer Watch

Hi, Brian, Johnson;

Got it with thanks; after study the link provided by Johnson, I still
have
the following question:

1) If I am watching several routes, am I need to add dialer map for each
watched routes?
2) If I am watching 192.168.10.64/29, am I add the dialer map by "dialer
map ip 192.168.10.64 name r2 broadcast 222222" statement? How did the
router knows the subnet mask of the watched route if I have a shorter
prefix but not watching? (say I have a route 192.168.10.64/26 but not
want
to be watched, while I want to watch 192.168.10.64/29)?

Thx,
BBD (Big Black Dog)

                      "Brian Dennis"

                      <brian@labforge.c To:
<wing_lam@jossynergy.com>

                      om> cc:
<ccielab@groupstudy.com>

                                               Subject: RE: ISDN PPP
Callback with Dialer Watch
                      07/02/2003 02:18

                      PM

You need the dialer map to the watched route because a physical BRI
using dialer maps is a multipoint interface. If you used dialer strings
as opposed to dialer maps then you obviously don't need a dialer map to
the watched route.

What if your interface looked like this?

int bri0/0
 ip address 10.10.12.1 255.255.255.0
 encapsulation ppp
 dialer-group 1
 dialer watch-group 1
 dialer map ip 10.10.12.2 broadcast 222222
 dialer map ip 10.10.12.3 broadcast 333333
 dialer map ip 10.10.12.4 broadcast 444444

How does the dialer watch feature know which remote router to call?

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
wing_lam@jossynergy.com
Sent: Tuesday, July 01, 2003 9:45 PM
To: Cristian Henry H
Cc: ccielab@groupstudy.com; nobody@groupstudy.com; Ram Shummoogum
Subject: Re: ISDN PPP Callback with Dialer Watch

Dear Herny,

Just curios why in this case we need to add dialer map statement which
is
the network (10.10.10.0/24) other than the BRI interface
(10.10.12.0/24)?
Shouldn't routing will cater the reachability to 10.10.10.0?

Thx a lot,
BBD (Big Black Dog)

                      Cristian Henry H

                      <chenry@reuna.cl> To: Ram Shummoogum
<rshummoo@ca.ibm.com>
                      Sent by: cc:
ccielab@groupstudy.com

                      nobody@groupstudy Subject: Re: ISDN PPP
Callback with Dialer Watch
                      .com

                      07/02/2003 04:12

                      AM

                      Please respond to

                      Cristian Henry H

Yes, you are right!, please add on r1 the following command
!
  dialer map ip 10.10.10.0 name r2 broadcast 222222
!

and add also on r2 the following one:

!
dialer-list 1 protocol permit list 100
!
access-list 100 deny ospf any any
access-list 100 permit ip any any
!

Thanks

Ram Shummoogum ha escrito:
>
> I think you are missing a dialer map ip statement for the route you
are
> watching.
>
> Cristian Henry H <chenry@reuna.cl>@groupstudy.com on 07/01/2003
10:16:49
AM
>
> Please respond to Cristian Henry H <chenry@reuna.cl>
>
> Sent by: nobody@groupstudy.com
>
> To: Budi Gunawan <bgunawan@hotpop.com>
> cc: CCIE Lab GroupStudy <ccielab@groupstudy.com>
> Subject: Re: ISDN PPP Callback with Dialer Watch
>
> Try with this, could works, let me know the results :
>
> Router client
> ----------------
>
> hostname r1
> !
> enable secret cisco
> !
> username r2 password cisco
> !
> int bri0/0
> ip address 10.10.12.1 255.255.255.0
> encapsulation ppp
> ip ospf cost 9000
> isdn switch-type xxxx
> dialer idle-timout 20
> dialer-group 1
> dialer wait-for-carrier 4
> dialer watch-group 1
> ppp callback request
> dialer map ip 10.10.12.2 name r2 broadcast 222222
> ppp authentication chap
> !
> dialer-list 1 protocol ip permit list 100
> !
> dialer watch-list 1 permit 10.10.10.0 255.255.255.0
> !
> access-list 100 deny ospf any any
> access-list 100 permit ip any any
> !
>
> Router server
> -------------
>
> hostname r2
> !
> enable secret cisco
> !
> username r1 password cisco
> !
> int bri0/0
> ip address 10.10.12.2 255.255.255.0
> encapsulation ppp
> ip ospf cost 9000
> isdn switch-type xxxx
> dialer-group 1
> dialer callback-secure
> dialer enable-timeout 2
> dialer idle timeout 0
> dialer map ip 10.10.12.1 name r1 class callback broadcast 111111
> ppp authentication chap
> ppp callback accept
> !
> dialer-list 1 protocol ip permit
> !
> map-class dialer callback
> dialer callback-server username
> !
>
> Budi Gunawan ha escrito:
> >
> > Hi All,
> >
> > Could we make ISDN callback with Dialer watch?
> > If we could, how to configure it?
> >
> > Thanks and regards,
> > BG.
> >
> >



This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:19 GMT-3