From: Snow, Tim (timothy.snow@eds.com)
Date: Tue Jul 01 2003 - 01:17:22 GMT-3
Jason,
The As-path is added to the BGP Prefix when sent to a EBGP neighbor and not
added to IBGP peers which is why the ^$ works for as-path access-lists as
the route actually sits in the bgp table with a Null AS-Path but when
advertised to a ebgp peer it'll add it's own as in the path.
I'm sure Howard B. will give a much more technical answer as to why this is
the way it is.
-----Original Message-----
From: Jason Cash [mailto:cash2001@swbell.net]
Sent: Monday, June 30, 2003 11:40 PM
To: ccielab@groupstudy.com
Subject: AS Path prepend in IBGP
Is it possible to advertise an as-path prepend via IBGP? For some reason,
it doesn't seem to take:
R5(s0)---(s0)R2
(e0)
|
(e0)
R8
R5
interface Loopback0
ip address 200.0.0.5 255.255.255.255
!
interface Loopback1
ip address 172.32.1.1 255.255.255.0
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 172.32.1.0 mask 255.255.255.0
neighbor 200.0.0.2 remote-as 200
neighbor 200.0.0.2 update-source Loopback0
neighbor 200.0.0.2 route-map addas out
neighbor 200.0.0.8 remote-as 8
neighbor 200.0.0.8 ebgp-multihop 5
neighbor 200.0.0.8 update-source Loopback0
neighbor 200.0.0.8 timers 30 90
neighbor 200.0.0.8 route-map addas out
no auto-summary
!
access-list 5 permit 172.32.1.0 0.0.0.255
!
route-map addas permit 10
match ip address 5
set as-path prepend 500 501
!
route-map addas permit 20
Below is the 'sh ip bgp' from both routers. R2 is iBGP and R8 is eBGP. R8
shows the as-path prepend
whereas R2 does not. What is the problem?
r2#sb
BGP table version is 37, local router ID is 200.0.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i100.100.100.0/24 200.0.0.4 0 100 0 i
*>i101.101.101.0/24 200.0.0.4 0 100 0 i
*> 172.16.0.0/22 200.0.0.1 0 8888 i
*>i172.32.1.0/24 200.0.0.5 0 100 0 i
*>i200.200.200.0 200.0.0.6 0 100 0 i
r8#sb
BGP table version is 19, local router ID is 200.0.0.8
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 100.100.100.0/24 200.0.0.5 0 200 i
*> 172.16.0.0/22 200.0.0.5 0 200 8888 i
*> 172.32.1.0/24 200.0.0.5 0 0 200 500 501 i
*> 200.200.200.0 200.0.0.5 0 200 i
This archive was generated by hypermail 2.1.4 : Wed Aug 06 2003 - 06:52:17 GMT-3