From: Brian Dennis (brian@labforge.com)
Date: Sun Jun 29 2003 - 05:37:38 GMT-3
You have an issue with VLSM since you using the default RIP version(s) -
send RIPv1/receive RIPv1 and RIPv2. R1 and R3 can only send out the
serial interface subnets of the 164.4.0.0/16 network that match the
interface's mask. An exception is host routes. If you change the
loopbacks to /32's you'll have full connectivity. You could also change
them to /28's to match the serial interface's mask to fix the problem.
Here is the process RIPv1 uses:
Is the route to be advertised part of the major network of the
interface? If it is not, then summarize the network to its classful
boundary and send it out. If the route is part of the major network,
check to see of the subnet mask matches that of the outgoing interface.
If the subnet mask does match then advertise the route out the
interface. If the subnet mask of the route does not match the
interface's subnet mask, then do not advertise the route out the
interface unless the route is a host route (/32). If the route is a host
route then advertise it out.
Of course this assumes that there are not any filter's (i.e.
distribute-lists) in place.
Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Mr. Richard L. Pickard
Sent: Saturday, June 28, 2003 8:36 PM
To: ccielab@groupstudy.com
Subject: why is RIP route not being learned ?
Fiesta
R_1 & R_3 are directly connected via frame relay on their serial
interfaces.
I do not understand why R_1's loopback is not reachable from R_3
Please help ---
hostname R_1
interface Loopback0
ip address 165.4.1.1 255.255.255.0
!
interface Ethernet0/0
ip address 170.4.1.1 255.255.255.0
ip accounting output-packets
full-duplex
!
interface Serial0/0.1 point-to-point
backup delay 2 10
backup interface BRI0/0
ip address 165.4.13.1 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 103
!
!
router rip
timers basic 20 40 30 30
network 165.4.0.0
network 170.4.0.0
========================================================================
====
==
hostname R_3
!
!
interface Loopback0
ip address 165.4.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 170.4.3.1 255.255.255.0
ip accounting output-packets
speed 100
full-duplex
!
!
interface Serial0/0.1 point-to-point
ip address 165.4.13.3 255.255.255.240
ip ospf network point-to-point
frame-relay interface-dlci 301
!
!
router rip
timers basic 20 40 30 30
network 165.4.0.0
!
ip http server
ip http secure-server
ip classless
R_3#sh ip route rip
R 210.120.14.0/24 [120/2] via 165.4.13.1, 00:00:16, Serial0/0.1
R 210.120.12.0/24 [120/2] via 165.4.13.1, 00:00:16, Serial0/0.1
R 210.120.10.0/24 [120/2] via 165.4.13.1, 00:00:16, Serial0/0.1
R 210.120.16.0/24 [120/2] via 165.4.13.1, 00:00:16, Serial0/0.1
R_3#
[GroupStudy removed an attachment of type image/jpeg which had a name of
Fiesta Bkgrd.jpg]
This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:11:14 GMT-3