CBWFQ problem

From: CNLink Technical (tech_support@us.cnlink.net)
Date: Fri Jun 20 2003 - 17:58:42 GMT-3


Let's say I have a router that has a s0/0 interface and a GRE tunnel
created (tunnel0) between it and another router.

The router has a default route of tunnel0:
---------------------------------------------------------------------
int tunnel0
ip address 10.2.2.1 255.255.255.252
tunnel source s0/0
tunnel destination 1.1.1.2

int s0/0
ip address 2.2.2.1 255.255.255.252

ip route 1.1.1.2 255.255.255.255 s0/0 (must have route to other endpoint of
the tunnel)
ip route 0.0.0.0 0.0.0.0 tun0
---------------------------------------------------------------------------

I'd like to apply CBWFQ on s0/0 but I'd like to classify based on voice
and/or real time protocol.

It appears that I can't use CBWFQ for this because s0/0 sees is GRE traffic.
And I cannot apply the
"service policy output" command on the tunnel interface (or logical
interfaces).

Really, I'd like to be able to do something like this:
------------------------------------------------------------------------
class-map VOICE
        match access-group 155 ; where access-list 155 defines voice traffic
policy-map PMAP
        class VOICE
        priority 800
        class class-default
        fair-queue

int s0/0
        bandwidth 1000
        max-reserved-bandwdith 80
        service-policy output PMAP
----------------------------------------------------------------------------
-----------------
but it doesn't work since s0/0 seems to only see GRE traffic.

Seems like I'm out of luck if I absolutely need to have a GRE tunnel and a
default route of that tunnel. Any help appreciated:

RC CHAM



This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:11:04 GMT-3