From: John Underhill (stepnwlf@magma.ca)
Date: Sun Jun 08 2003 - 12:42:41 GMT-3
The interface being passive only means it will not send updates out that
interface, but you still have a classful network statement that includes the
BRI. Use ver 2 and a distribute list to filter the RIP updates, like this..
R1
interface Loopback0
ip address 170.1.100.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback1
ip address 170.1.101.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback2
ip address 170.1.102.1 255.255.255.0
no ip directed-broadcast
!
interface Loopback3
ip address 170.1.103.1 255.255.255.0
no ip directed-broadcast
router rip
version 2
passive-interface default
no passive-interface Ethernet0
network 150.50.0.0
network 170.1.0.0
distribute-list 1 out
no auto-summary
access-list 1 permit 170.1.100.0 0.0.0.255
R2
Gateway of last resort is not set
170.1.0.0/24 is subnetted, 1 subnets
R 170.1.100.0 [120/1] via 150.50.17.1, 00:00:05, Ethernet0
150.50.0.0/16 is variably subnetted, 3 subnets, 2 masks
C 150.50.9.0/24 is directly connected, Dialer0
C 150.50.9.2/32 is directly connected, Dialer0
C 150.50.17.0/24 is directly connected, Ethernet0
----- Original Message -----
From: "Jason Cash" <cash2001@swbell.net>
To: <ccielab@groupstudy.com>
Sent: Saturday, June 07, 2003 11:02 PM
Subject: RIP passive interface, still being advertised
> I am having a problem with a passive interface being propagated into a RIP
> network. I am trying to keep certain interfaces (BRI0, S0.501, etc) from
> being routed via RIP. The problem is that I have them interfaces passive
> but they still show up in the RIP database and Route tables.
>
>
>
> Initially, I just did this, thinking it would do the tricl:
>
>
>
> Router rip
>
> Passive-interface default
>
> No passive e0 (etc)
>
>
>
> Another problem is that R5 is redistributing the BRI0 (170.1.201.0 which
> should be passive) into OSPF and causing problems. Why are these passive
> interfaces being put into the RIP process?
>
>
>
> Here are the configs:
>
>
>
> R5
>
> !
>
> interface Serial0.501 point-to-point
>
> ip address 170.1.100.6 255.255.255.252
>
> !
>
> interface BRI0
>
> ip address 170.1.201.1 255.255.255.252
>
> !
>
> router rip
>
> version 2
>
> timers basic 45 135 135 360
>
> redistribute ospf 1 metric 2
>
> passive-interface BRI0
>
> passive-interface Serial0.501
>
> network 170.1.0.0
>
> no auto-summary
>
>
>
> r5#sh ip rip data
>
> 150.50.0.0/16 auto-summary
>
> 150.50.4.0/24
>
> [2] via 170.1.200.7, 00:00:12, Ethernet0
>
> 170.1.0.0/16 auto-summary
>
> 170.1.5.5/32 directly connected, Loopback0
>
> 170.1.7.7/32
>
> [1] via 170.1.200.7, 00:00:12, Ethernet0
>
> 170.1.8.8/32
>
> [2] via 170.1.200.7, 00:00:12, Ethernet0
>
> 170.1.69.0/30 <<<<<<<<<<<<<<<<<<<<<<<<<<<< ATM4/0 on R6
>
> [1] via 170.1.200.6, 00:00:58, Ethernet0
>
> 170.1.78.0/30
>
> [1] via 170.1.200.7, 00:00:12, Ethernet0
>
> 170.1.100.4/30 directly connected, Serial0.501
>
> 170.1.200.0/27 directly connected, Ethernet0
>
> 170.1.201.0/30 directly connected, BRI0
>
> =====================================
>
> R6
>
> interface FastEthernet0/1/0
>
> ip address 170.1.200.6 255.255.255.224
>
> duplex auto
>
> speed auto
>
> !
>
> interface Serial1/0.601 point-to-point
>
> ip address 170.1.100.10 255.255.255.252
>
> ip ospf authentication message-digest
>
> ip ospf message-digest-key 1 md5 ipexpert
>
> frame-relay interface-dlci 601
>
> !
>
> interface ATM4/0
>
> ip address 170.1.69.1 255.255.255.252
>
> no atm ilmi-keepalive
>
> !
>
> router rip
>
> version 2
>
> timers basic 45 135 135 360
>
> redistribute ospf 1 metric 2
>
> passive-interface Serial1/0.601
>
> passive-interface ATM4/0
>
> network 170.1.0.0
>
> no auto-summary
>
>
>
> r6#sh ip rip data
>
> 150.50.0.0/16 auto-summary
>
> 150.50.4.0/24
>
> [2] via 170.1.200.7, 00:00:34, FastEthernet0/1/0
>
> 170.1.0.0/16 auto-summary
>
> 170.1.6.6/32 directly connected, Loopback0
>
> 170.1.7.7/32
>
> [1] via 170.1.200.7, 00:00:34, FastEthernet0/1/0
>
> 170.1.8.8/32
>
> [2] via 170.1.200.7, 00:00:34, FastEthernet0/1/0
>
> 170.1.69.0/30 directly connected, ATM4/0
>
> 170.1.78.0/30
>
> [1] via 170.1.200.7, 00:00:34, FastEthernet0/1/0
>
> 170.1.100.8/30 directly connected, Serial1/0.601
>
> 170.1.200.0/27 directly connected, FastEthernet0/1/0
>
> 170.1.201.0/30 redistributed<<<<<<<<<<<<<<<<<<<<<BRI0 on R5,
> redistributed!!
>
> [2] via 170.1.5.5,
>
>
>
>
>
> R7
>
> r7#sh ip rip data
>
> 150.50.0.0/16 auto-summary
>
> 150.50.4.0/24
>
> [1] via 170.1.78.2, 00:00:31, Serial0/0
>
> 170.1.0.0/16 auto-summary
>
> 170.1.5.5/32
>
> [1] via 170.1.200.5, 00:00:36, FastEthernet0/0
>
> 170.1.6.6/32
>
> [1] via 170.1.200.6, 00:00:39, FastEthernet0/0
>
> 170.1.7.7/32 directly connected, Loopback0
>
> 170.1.8.8/32
>
> [1] via 170.1.78.2, 00:00:31, Serial0/0
>
> 170.1.69.0/30<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<ATM4/0 on R6
>
> [1] via 170.1.200.6, 00:00:39, FastEthernet0/0
>
> 170.1.78.0/30 directly connected, Serial0/0
>
> 170.1.100.0/30
>
> [2] via 170.1.200.5, 00:00:36, FastEthernet0/0
>
> [2] via 170.1.200.6, 00:00:39, FastEthernet0/0
>
> 170.1.100.4/30<<<<<<<<<<<<<<<<<<<<<<<<<<<<<S0.501 on R5
>
> [1] via 170.1.200.5, 00:00:36, FastEthernet0/0
>
> 170.1.100.8/30
>
> [1] via 170.1.200.6, 00:00:40, FastEthernet0/0
>
> 170.1.200.0/27 directly connected, FastEthernet0/0
>
> 170.1.201.0/30<<<<<<<<<<<<<<<<<<<<<<<<<<<<<BRI0 on R5
>
> [1] via 170.1.200.5, 00:00:37, FastEthernet0/0
>
> 172.16.0.0/16 auto-summary
>
> 172.16.0.0/22
>
> [2] via 170.1.200.5, 00:00:37, FastEthernet0/0
>
> [2] via 170.1.200.6, 00:00:40, FastEthernet0/0
>
> 192.168.10.0/24 auto-summary
>
> 192.168.10.0/24
>
> [2] via 170.1.200.5, 00:00:37, FastEthernet0/0
>
> [2] via 170.1.200.6, 00:00:40, FastEthernet0/0
This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:10:54 GMT-3