rip2ospf

From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Wed Jun 04 2003 - 20:38:24 GMT-3


I don't understand how to redistribute rip into ospf when the rip domain is /24 and the link out of the ospf domain is /26

r5 --ethernet-- r7 --serial-- r8

Can't ping r8 from r5??

configs and route tables below

r7#r
Building configuration...

Current configuration : 1754 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 150.50.7.7 255.255.255.0
!
interface Ethernet0
 ip address 150.50.27.7 255.255.255.192
 no ip route-cache
 no ip mroute-cache
 bridge-group 1
!
interface Serial0
 bandwidth 64
 ip address 150.50.25.7 255.255.255.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 clockrate 64000
 bridge-group 1
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
router ospf 1
 router-id 150.50.7.7
 log-adjacency-changes
 redistribute connected subnets
 redistribute rip subnets route-map rip2ospf
 network 150.50.27.0 0.0.0.63 area 0
 default-metric 20
!
router rip
 redistribute connected route-map justlo
 redistribute ospf 1
 passive-interface Ethernet0
 passive-interface Loopback0
 network 150.50.0.0
 default-metric 1
!
ip classless
no ip http server
ip pim bidir-enable
!
!
ip access-list standard rips
 permit 150.50.25.0 0.0.0.255
 permit 150.50.14.0 0.0.0.255
 permit 150.50.8.0 0.0.0.255
 permit 150.50.88.0 0.0.0.255
access-list 1 permit 150.50.7.7
route-map justlo permit 10
 match ip address 1
!
route-map rip2ospf permit 10
 match ip address rips
!
!
bridge 1 protocol ieee
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line 1 8
 flush-at-activation
 transport input all
line aux 0
 transport input all
line vty 0 4
 password bp
 login
!
end

r7#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
O 192.168.25.0/24 [110/1572] via 150.50.27.5, 00:03:16, Ethernet0
O E2 192.168.25.2/32 [110/20] via 150.50.27.5, 00:03:15, Ethernet0
     192.168.56.0/26 is subnetted, 1 subnets
O 192.168.56.0 [110/20] via 150.50.27.6, 00:03:16, Ethernet0
                     [110/20] via 150.50.27.5, 00:03:16, Ethernet0
     150.50.0.0/16 is variably subnetted, 21 subnets, 3 masks
O E2 150.50.200.0/24 [110/20] via 150.50.27.6, 00:03:16, Ethernet0
                        [110/20] via 150.50.27.5, 00:03:17, Ethernet0
O 150.50.40.0/24 [110/540] via 150.50.27.6, 00:03:17, Ethernet0
                       [110/540] via 150.50.27.5, 00:03:17, Ethernet0
O E2 150.50.4.0/24 [110/20] via 150.50.27.6, 00:03:17, Ethernet0
                      [110/20] via 150.50.27.5, 00:03:17, Ethernet0
O E2 150.50.5.0/24 [110/20] via 150.50.27.5, 00:03:18, Ethernet0
O E2 150.50.6.0/24 [110/20] via 150.50.27.6, 00:03:18, Ethernet0
C 150.50.7.0/24 is directly connected, Loopback0
O 150.50.2.2/32 [110/271] via 150.50.27.6, 00:03:18, Ethernet0
                      [110/271] via 150.50.27.5, 00:03:18, Ethernet0
O E2 150.50.1.0/24 [110/20] via 150.50.27.6, 00:03:18, Ethernet0
                      [110/20] via 150.50.27.5, 00:03:18, Ethernet0
O E2 150.50.2.0/24 [110/20] via 150.50.27.6, 00:03:18, Ethernet0
                      [110/20] via 150.50.27.5, 00:03:18, Ethernet0
R 150.50.14.0/24 [120/1] via 150.50.25.8, 00:00:09, Serial0
R 150.50.8.0/24 [120/1] via 150.50.25.8, 00:00:09, Serial0
O E2 150.50.17.0/24 [110/20] via 150.50.27.6, 00:03:18, Ethernet0
                       [110/20] via 150.50.27.5, 00:03:18, Ethernet0
C 150.50.25.8/32 is directly connected, Serial0
C 150.50.25.0/24 is directly connected, Serial0
C 150.50.27.0/26 is directly connected, Ethernet0
O 150.50.123.6/32 [110/10] via 150.50.27.6, 00:03:19, Ethernet0
O 150.50.123.5/32 [110/10] via 150.50.27.5, 00:03:19, Ethernet0
O 150.50.123.4/32 [110/530] via 150.50.27.6, 00:03:19, Ethernet0
                        [110/530] via 150.50.27.5, 00:03:19, Ethernet0
O 150.50.123.2/32 [110/270] via 150.50.27.6, 00:03:19, Ethernet0
                        [110/270] via 150.50.27.5, 00:03:19, Ethernet0
O E2 150.50.123.0/24 [110/20] via 150.50.27.6, 00:03:19, Ethernet0
                        [110/20] via 150.50.27.5, 00:03:19, Ethernet0
R 150.50.88.0/24 [120/1] via 150.50.25.8, 00:00:12, Serial0
r7#
bb1>5
[Resuming connection 5 to r5 ... ]
..
r5#r
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
logging buffered 10000 debugging
enable password radnor
!
username r2 password 0 ctasta
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
lane client flush
isdn switch-type basic-ni
cns event-service server
!
!
!
!
!
interface Loopback0
 ip address 150.50.5.5 255.255.255.0
!
interface BRI0/0
 ip address 192.168.25.5 255.255.255.0
 encapsulation ppp
 dialer map ip 192.168.25.2 name r2 broadcast
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 40822222221
 isdn spid2 40822222222
 ppp authentication chap
 ppp multilink
 bridge-group 1
!
interface Ethernet0/0
 ip address 192.168.56.5 255.255.255.192 secondary
 ip address 150.50.27.5 255.255.255.192
 no ip redirects
 standby priority 115 preempt delay 5
 standby ip 192.168.56.1
 standby track Serial1/0 12
 bridge-group 1
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Serial1/0
 bandwidth 384
 ip address 150.50.123.5 255.255.255.0
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 ip ospf priority 0
 no fair-queue
 frame-relay map ip 150.50.123.2 501 broadcast
 frame-relay map ip 150.50.123.4 501 broadcast
 frame-relay map ip 150.50.123.5 501
 frame-relay map ip 150.50.123.6 501 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 shutdown
!
router ospf 1
 router-id 210.10.10.10
 redistribute connected subnets
 network 150.50.27.0 0.0.0.63 area 0
 network 150.50.123.0 0.0.0.255 area 0
 network 192.168.25.0 0.0.0.255 area 0
 network 192.168.56.0 0.0.0.63 area 0
!
ip classless
no ip http server
!
!
map-class dialer bplan
 dialer callback-server username
access-list 3 deny any
dialer-list 1 protocol ip permit
!
bridge 1 protocol ieee
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 password bp
 login
!
end

r5#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     192.168.25.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.25.0/24 is directly connected, BRI0/0
C 192.168.25.2/32 is directly connected, BRI0/0
     192.168.56.0/26 is subnetted, 1 subnets
C 192.168.56.0 is directly connected, Ethernet0/0
     150.50.0.0/16 is variably subnetted, 20 subnets, 3 masks
O E2 150.50.200.0/24 [110/20] via 150.50.123.2, 00:03:51, Serial1/0
O 150.50.40.0/24 [110/530] via 150.50.123.2, 00:03:51, Serial1/0
O E2 150.50.4.0/24 [110/20] via 150.50.123.2, 00:03:52, Serial1/0
C 150.50.5.0/24 is directly connected, Loopback0
O E2 150.50.6.0/24 [110/20] via 150.50.27.6, 00:03:52, Ethernet0/0
O E2 150.50.7.0/24 [110/20] via 150.50.27.7, 00:03:52, Ethernet0/0
O 150.50.2.2/32 [110/261] via 150.50.123.2, 00:03:52, Serial1/0
O E2 150.50.1.0/24 [110/20] via 150.50.123.2, 00:03:53, Serial1/0
O E2 150.50.2.0/24 [110/20] via 150.50.123.2, 00:03:53, Serial1/0
O E2 150.50.14.0/24 [110/20] via 150.50.27.7, 00:03:53, Ethernet0/0
O E2 150.50.8.0/24 [110/20] via 150.50.27.7, 00:03:53, Ethernet0/0
O E2 150.50.25.8/32 [110/20] via 150.50.27.7, 00:03:53, Ethernet0/0
O E2 150.50.17.0/24 [110/20] via 150.50.123.2, 00:03:53, Serial1/0
O E2 150.50.25.0/24 [110/20] via 150.50.27.7, 00:03:53, Ethernet0/0
C 150.50.27.0/26 is directly connected, Ethernet0/0
O 150.50.123.6/32 [110/10] via 150.50.27.6, 00:03:53, Ethernet0/0
O 150.50.123.4/32 [110/520] via 150.50.123.2, 00:03:53, Serial1/0
O 150.50.123.2/32 [110/260] via 150.50.123.2, 00:03:53, Serial1/0
C 150.50.123.0/24 is directly connected, Serial1/0
O E2 150.50.88.0/24 [110/20] via 150.50.27.7, 00:03:53, Ethernet0/0
r5#
bb1>8
[Resuming connection 8 to r8 ... ]

r8#r
Building configuration...

Current configuration : 2087 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service tcp-small-servers
!
hostname r8
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
ip host tbb2 150.50.4.254
!
!
!
!
interface Loopback0
 ip address 150.50.8.8 255.255.255.0
!
interface Loopback1
 ip address 150.50.88.1 255.255.255.0
!
interface Ethernet0
 ip address 150.50.14.8 255.255.255.0
 ip access-group acc172 in
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 bandwidth 64
 ip address 150.50.25.8 255.255.255.0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 bridge-group 1
!
interface Serial1
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface BRI0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
router rip
 passive-interface Ethernet0
 passive-interface Loopback0
 network 150.50.0.0
!
ip classless
no ip http server
ip pim bidir-enable
!
!
ip access-list extended acc172
 permit tcp 172.24.24.0 0.0.1.255 150.50.40.0 0.0.0.255 eq ftp
 permit tcp 172.24.24.0 0.0.1.255 150.50.40.0 0.0.0.255 eq ftp-data
 permit tcp 172.24.24.0 0.0.1.255 150.50.88.0 0.0.0.255 eq ftp
 permit tcp 172.24.24.0 0.0.1.255 150.50.88.0 0.0.0.255 eq ftp-data
 permit udp 172.24.24.0 0.0.1.255 host 150.50.2.2 eq snmp
 permit udp 172.24.24.0 0.0.1.255 host 150.50.123.2 eq snmp
 permit udp 172.24.24.0 0.0.1.255 host 150.50.17.2 eq snmp
 permit udp 172.24.24.0 0.0.1.255 host 192.168.25.2 eq snmp
 permit icmp 172.24.24.0 0.0.1.255 host 150.50.7.7
 permit icmp 172.24.24.0 0.0.1.255 host 150.50.27.7
 permit icmp 172.24.24.0 0.0.1.255 host 150.50.25.7
 deny ip 172.24.24.0 0.0.1.255 any
 permit ip any any
!
bridge 1 protocol ieee
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
 transport input all
line vty 0 4
 password bp
 login
!
end

r8#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R 192.168.25.0/24 [120/1] via 150.50.25.7, 00:00:24, Serial0
R 192.168.56.0/24 [120/1] via 150.50.25.7, 00:00:24, Serial0
     150.50.0.0/16 is variably subnetted, 20 subnets, 2 masks
R 150.50.200.0/24 [120/1] via 150.50.25.7, 00:00:25, Serial0
R 150.50.40.0/24 [120/1] via 150.50.25.7, 00:00:25, Serial0
R 150.50.4.0/24 [120/1] via 150.50.25.7, 00:00:25, Serial0
R 150.50.5.0/24 [120/1] via 150.50.25.7, 00:00:25, Serial0
R 150.50.6.0/24 [120/1] via 150.50.25.7, 00:00:26, Serial0
R 150.50.7.0/24 [120/1] via 150.50.25.7, 00:00:26, Serial0
R 150.50.2.2/32 [120/1] via 150.50.25.7, 00:00:26, Serial0
R 150.50.1.0/24 [120/1] via 150.50.25.7, 00:00:26, Serial0
R 150.50.2.0/24 [120/1] via 150.50.25.7, 00:00:26, Serial0
C 150.50.14.0/24 is directly connected, Ethernet0
C 150.50.8.0/24 is directly connected, Loopback0
R 150.50.17.0/24 [120/1] via 150.50.25.7, 00:00:27, Serial0
C 150.50.25.7/32 is directly connected, Serial0
C 150.50.25.0/24 is directly connected, Serial0
R 150.50.123.6/32 [120/1] via 150.50.25.7, 00:00:27, Serial0
R 150.50.123.5/32 [120/1] via 150.50.25.7, 00:00:27, Serial0
R 150.50.123.4/32 [120/1] via 150.50.25.7, 00:00:27, Serial0
R 150.50.123.2/32 [120/1] via 150.50.25.7, 00:00:27, Serial0
R 150.50.123.0/24 [120/1] via 150.50.25.7, 00:00:27, Serial0
C 150.50.88.0/24 is directly connected, Loopback1
r8#



This archive was generated by hypermail 2.1.4 : Fri Jul 04 2003 - 11:10:52 GMT-3