Re: PPP callback

From: Richard Kleimon (richk@knowledgenet.com)
Date: Mon May 05 2003 - 02:48:50 GMT-3


Thanks for the reply. I do have the username and password lower case on
both router. All the debugs show the ppp authentication is working properly.
Here is the full config from both routers.

r4#wr t
Building configuration...

Current configuration : 3043 bytes
!
! Last configuration change at 00:34:00 UTC Sat May 3 2003
! NVRAM config last updated at 21:34:23 UTC Thu May 1 2003
!
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r4
!
logging buffered 4096 debugging
!
username r5 password 0 cisco
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
interface Loopback0
 ip address 150.50.44.44 255.255.255.0
!
interface Loopback1
 ip address 144.144.144.144 255.255.255.0
!
interface Loopback200
 ip address 200.200.44.44 255.255.255.0
!
interface FastEthernet0/0
 ip address 151.51.112.4 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 150.50.54.4 255.255.255.240
 encapsulation frame-relay
 ip ospf network point-to-point
 frame-relay map ip 150.50.54.4 145 broadcast
 frame-relay map ip 150.50.54.5 145 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
!
interface BRI0/0
  ip address 150.50.45.4 255.255.255.248
  encapsulation ppp
  ip ospf demand-circuit
  dialer idle-timeout 10
  dialer map ip 150.50.45.5 name r5 broadcast 8358662
  dialer map ip 150.50.45.5 name r5 broadcast 8358664
  dialer-group 1
  isdn switch-type basic-ni
  isdn spid1 0835866101 8358661
  isdn spid2 0835866301 8358663
  no peer neighbor-route
  ppp callback request
  ppp authentication chap
  ppp multilink

interface Serial0/1
 no ip address
 shutdown
!
router eigrp 112
 redistribute ospf 1 metric 10000 1000 255 1 1500 route-map ospf-eigrp
 network 151.51.112.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 150.50.44.44
 log-adjacency-changes
 redistribute eigrp 112 metric 10000 subnets tag 490 route-map eigrp-ospf
 passive-interface BRI0/0
 network 150.50.44.0 0.0.0.255 area 2456
 network 150.50.45.0 0.0.0.7 area 2456
 network 150.50.54.0 0.0.0.15 area 2456
 distribute-list 5 in
!
router bgp 46
 no synchronization
 bgp router-id 150.50.44.44
 bgp cluster-id 3368561708
 bgp log-neighbor-changes
 network 144.144.144.0 mask 255.255.255.0
 neighbor 150.50.66.66 remote-as 46
 neighbor 150.50.66.66 update-source Loopback0
 neighbor 151.51.112.112 remote-as 1212
 no auto-summary
!
ip classless
no ip http server
!
logging facility local6
logging source-interface Loopback0
logging 150.50.111.100
access-list 5 deny 10.10.6.0 0.0.0.255
access-list 5 permit any
access-list 10 permit 151.51.112.0 0.0.0.255
queue-list 1 default 4
queue-list 1 queue 1 limit 25
queue-list 1 queue 2 limit 10
queue-list 1 queue 3 limit 15
dialer-list 1 protocol ip permit
route-map STATIC permit 10
 match ip address 10
 match interface FastEthernet0/0
!
route-map STATIC permit 20
!
route-map ospf-eigrp permit 10
 match route-type internal
!
route-map ospf-eigrp permit 20
 match tag 1120 190
!
route-map eigrp-ospf permit 10
 match route-type internal
!
!
!
alias configure itn int
alias configure ro router
alias exec bgpr sh run | be router bgp
alias exec * clear ip ro *
alias exec ** clear ip bgp *
alias exec co conf t
alias exec itn int
alias exec int sh ip int brie
alias exec bgp sh ip bgp sum
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end

version 12.1
no service single-slot-reload-enable
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname r5
!
logging buffered 10000 debugging
!
username r4 password 0 cisco
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
dial-peer voice 5 pots
 destination-pattern 14084960801
 port 1/0/0
!
dial-peer voice 10 pots
 destination-pattern 14084960802
 port 1/0/1
!
dial-peer voice 20 vofr
 destination-pattern 15107956815
 session target Serial0/0 152
!
!
dlsw local-peer peer-id 150.50.55.55 group 1 promiscuous
dlsw peer-on-demand-defaults tcp-queue-max 25
dlsw bridge-group 1
!
interface Loopback0
 ip address 150.50.55.55 255.255.255.0
!
interface Loopback1
 ip address 155.155.155.155 255.255.255.0
!
interface Loopback200
 ip address 200.200.55.55 255.255.255.0
!
interface FastEthernet0/0
 ip address 150.50.25.5 255.255.255.0
 no ip redirects
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 duplex auto
 speed auto
 standby 25 ip 150.50.25.100
 standby 25 priority 110
 standby 25 preempt
 standby 25 track Serial0/0
 bridge-group 1
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
 no frame-relay inverse-arp
!
interface Serial0/0.54 point-to-point
 ip address 150.50.54.5 255.255.255.240
 frame-relay interface-dlci 154
!
interface Serial0/0.526 multipoint
 ip address 150.50.26.5 255.255.255.224
 frame-relay map ip 150.50.26.2 152 broadcast
 frame-relay map ip 150.50.26.5 152 broadcast
 frame-relay map ip 150.50.26.6 156 broadcast
 frame-relay interface-dlci 152
  class VOICE
  vofr cisco
!
interface BRI0/0
  ip address 150.50.45.5 255.255.255.248
  encapsulation ppp
 ip ospf demand-circuit
  dialer callback-secure
  dialer fast-idle 5
  dialer enable-timeout 2
 dialer map ip 150.50.45.4 name r4 class DIALBACK broadcast 8358661
  dialer map ip 150.50.45.4 name r4 class DAILBACK broadcast 8358663
  dialer load-threshold 128 outbound
  dialer-group 1
  isdn switch-type basic-ni
  isdn spid1 0835866201 8358662
  isdn spid2 0835866401 8358664
  no peer neighbor-route
  ppp callback accept
  ppp authentication chap
  ppp multilink
!
interface Serial0/1
 no ip address
 shutdown
!
router ospf 1
 router-id 150.50.55.55
 log-adjacency-changes
 area 0 authentication message-digest
 area 0 range 140.40.0.0 255.255.252.0
 area 2456 virtual-link 150.50.66.66
 passive-interface BRI0/0
 network 150.50.25.0 0.0.0.255 area 0
 network 150.50.26.0 0.0.0.31 area 2456
 network 150.50.45.0 0.0.0.7 area 2456
 network 150.50.54.0 0.0.0.15 area 2456
 network 150.50.55.0 0.0.0.255 area 0
 neighbor 150.50.26.2 priority 1
 neighbor 150.50.26.6 priority 1
 distribute-list 5 in
!
router bgp 25
 no synchronization
 bgp router-id 150.50.55.55
 bgp cluster-id 3368564535
 bgp log-neighbor-changes
 network 155.155.155.0 mask 255.255.255.0
 neighbor 150.50.22.22 remote-as 25
 neighbor 150.50.22.22 update-source Loopback0
 no auto-summary
!
ip classless
no ip http server
!
!
map-class dialer DIALBACK
 dialer callback-server username
!
map-class frame-relay VOICE
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay mincir 24000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay voice bandwidth 24000
 frame-relay fragment 53
logging facility local6
logging source-interface Loopback0
logging 150.50.111.100
access-list 5 deny 10.10.6.0 0.0.0.255
access-list 5 permit any
dialer-list 1 protocol ip permit
!
bridge 1 protocol ieee
!
alias configure itn int
alias configure ro router
alias exec bgpr sh run | be router bgp
alias exec * clear ip ro *
alias exec ** clear ip bgp *
alias exec co conf t
alias exec itn int
alias exec int sh ip int brie
alias exec bgp sh ip bgp sum
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
!
end
----- Original Message -----
From: "Tony Schaffran" <tschaffran@cconlinelabs.com>
To: "'Richard Kleimon'" <richard_kleimon@qwest.net>;
<ccielab@groupstudy.com>
Sent: Sunday, May 04, 2003 8:10 PM
Subject: RE: PPP callback

> Do you have your username's configured on each of the routers?
>
>
> Tony Schaffran
> Network Analyst
> CCIE #11071
> CCNP, CCNA, CCDA,
> NNCDS, NNCSS, CNE, MCSE
>
> www.cconlinelabs.com
> Your #1 choice for online Cisco rack rentals.
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Richard Kleimon
> Sent: Sunday, May 04, 2003 6:59 PM
> To: ccielab@groupstudy.com
> Subject: PPP callback
>
> Can anyone tell me if they see anything wrong with my configs? I have
> checked them against CCO and they look right. If I strip the interfaces
> down to just the maps they work, but as soon as I put the callback stuff
> in it stops. I have debugged everything I can think of but it just doest
> want to work.
>
> Thanks,
>
> -Rich
>
>
> R4
> interface BRI0/0
> ip address 150.50.45.4 255.255.255.248
> encapsulation ppp
> ip ospf demand-circuit
> dialer idle-timeout 10
> dialer map ip 150.50.45.5 name r5 broadcast 8358662
> dialer map ip 150.50.45.5 name r5 broadcast 8358664
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 0835866101 8358661
> isdn spid2 0835866301 8358663
> no peer neighbor-route
> ppp callback request
> ppp authentication chap
> ppp multilink
>
> R5
> interface BRI0/0
> ip address 150.50.45.5 255.255.255.248
> encapsulation ppp
> ip ospf demand-circuit
> dialer callback-secure
> dialer fast-idle 5
> dialer enable-timeout 2
> dialer map ip 150.50.45.4 name r4 class DIALBACK broadcast 8358661
> dialer map ip 150.50.45.4 name r4 class DAILBACK broadcast 8358663
> dialer load-threshold 128 outbound
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 0835866201 8358662
> isdn spid2 0835866401 8358664
> no peer neighbor-route
> ppp callback accept
> ppp authentication chap
> ppp multilink
>
> map-class dialer DIALBACK
> dialer callback-server username



This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:37 GMT-3