From: Carlos (cchorao@xtra.co.nz)
Date: Sun May 04 2003 - 08:08:56 GMT-3
Robert,
It is disabled on an interface basis. Most times this is sufficient
however in your case you used the frame-relay interface-dlci rather than
the frame-relay map on the multipoint subint , which still results in a
inarp request from the sub int ( see scenario 1 below). If you use the
frame-relay map command then inarp request is not generated (see
scenario 2). If you disable inverse arp on the sub int inarp request is
not generated (scenario 3).
Notice that in scenario 1 and 3 that if inverse arp request is received
and static map is not used then even if inarp is disabled since the
inarp packet contains the protocol address on the other side of the PVC
, the dynamic mapping is completed anyway. This behavior is consistent
with RFC 1293.moral of the story; disable inverse arp on both sides
HTH ,Carlos
#11351
Scenario 1 ************************************
interface Serial1/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial1/0.1 multipoint
ip address 10.0.0.2 255.255.255.0
frame-relay interface-dlci 401
%SYS-5-CONFIG_I: Configured from console by console
2w5d: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
2w5d: Serial1/0.1(o): dlci 401(0x6411), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
2w5d: FR: Sending INARP Request on interface Serial1/0.1 dlci 401 for
link 7(IP) <---------------------------------- request sent
2w5d: broadcast dequeue
2w5d: Serial1/0.1(o):Pkt sent on dlci 401(0x6411), pkt encaps 0x300
0x8000 0x0 0x806 (ARP), data
gramsize 34
r2#
2w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed
state to up
r2#
2w5d: Serial1/0(i): dlci 401(0x6411), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
2w5d: Serial1/0.1: frame relay INARP received <----- req received ,
inarp not disabled on the other side.
2w5d: FR: Sending INARP Reply on interface Serial1/0.1 dlci 401 for link
7(IP)
r2#
2w5d: Serial1/0(i): dlci 401(0x6411), pkt type 0x800, datagramsize 96
2#sh frame-relay map
Serial1/0.1 (up): ip 10.0.0.3 dlci 401(0x191,0x6410), dynamic,
broadcast,, status defined, active
Scenario
2********************************************************************
nterface Serial1/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial1/0.1 multipoint
ip address 10.0.0.2 255.255.255.0
frame-relay map ip 10.0.0.3 401 broadcast <-------------------- static
mapping
%SYS-5-CONFIG_I: Configured from console by console
r2#
2w5d: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
2w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed
state to up
r2#
2w5d: Serial1/0(i): dlci 401(0x6411), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
2w5d: Serial1/0.1: frame relay INARP received <----- inarp received ,
none sent.
2w5d: FR: Sending INARP Reply on interface Serial1/0.1 dlci 401 for link
7(IP)
r2#sh fram
r2#sh frame-relay map
Serial1/0.1 (up): ip 10.0.0.3 dlci 401(0x191,0x6410), static,
broadcast,
CISCO, status defined, active
Scenario 3 *****************************************************
interface Serial1/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial1/0.1 multipoint
ip address 10.0.0.2 255.255.255.0
frame-relay interface-dlci 401
no frame-relay inverse-arp
%SYS-5-CONFIG_I: Configured from console by console
r2#
2w5d: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
2w5d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed
state to up
r2#
2w5d: Serial1/0(i): dlci 401(0x6411), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
2w5d: Serial1/0.1: frame relay INARP received < ------- req received ,
none sent
2w5d: FR: Sending INARP Reply on interface Serial1/0.1 dlci 401 for link
7(IP)
r2#
2w5d: Serial1/0(i): dlci 401(0x6411), pkt type 0x800, datagramsize 96
r2#sh fram
r2#sh frame-relay map
Serial1/0.1 (up): ip 10.0.0.3 dlci 401(0x191,0x6410), dynamic,
broadcast,, status defined, active <------ notice that the
result is still a dynamic mapping
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Robert Yee
Sent: 04 May 2003 18:29
To: ccielab@groupstudy.com
Subject: Does disabling inverse arp on physical interface, disable it on
subinterface?
Hi,
I was working on a FRTS question that I had, but it is leading me to an
Inverse ARP problem.
I was under the impresssion that if I disable inverse arp on the
physical interface, that the subinterfaces would also have inverse arp
disabled.
To test my orginal understanding, I dis the following:
1. Shut down serial interface
2. Configure 'encap frame'
3. Configure 'no frame-relay inverse arp'
4. Configure int s0.24 with 'frame-relay interface-dlci...'
5. Configure int s0.256 with 'frame-relay interface-dlci...'
6. Enabled serial interface.
I expected that no dynamic maps would appear...I was wrong. here is the
output:
r2(config)#int s0
r2(config-if)#shut
r2(config-if)#encap frame
00:02:45: %LINK-5-CHANGED: Interface Serial0, changed state to
administratively down
00:02:46: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,
changed state to down
r2(config-if)#encap frame
r2(config-if)#no frame inver
r2(config-if)#int s0.24 multi
r2(config-subif)#ip add 150.50.24.2 255.255.255.0
r2(config-subif)#frame interface-dlci 104
r2(config-fr-dlci)#int s0.256
r2(config)#int s0.256 multi
r2(config-subif)#ip add 150.50.100.2 255.255.255.224
r2(config-subif)#int s0.256
r2(config-subif)#frame interface-dlci 105
r2(config-fr-dlci)#frame interface-dlci 106
r2(config-fr-dlci)#exit
r2(config)#int s0
r2(config-if)#no shut
r2#sh run
r2#debug frame packet
Frame Relay packet debugging is on
r2#sh frame map
00:07:01: Serial0.24(o): dlci 104(0x1881), pkt encaps 0x0300 0x8000
0x0000 0x806 (ARP), datagramsize 34
00:07:01: FR: Sending INARP Request on interface Serial0.24 dlci 104 for
link 7(IP)
00:07:01: Serial0.256(o): dlci 106(0x18A1), pkt encaps 0x0300 0x8000
0x0000 0x806 (ARP), datagramsize 34
00:07:01: FR: Sending INARP Request on interface Serial0.256 dlci 106
for link 7(IP)
00:07:01: Serial0.256(o): dlci 105(0x1891), pkt encaps 0x0300 0x8000
0x0000 0x806 (ARP), datagramsize 34
00:07:01: FR: Sending INARP Request on interface Serial0.256 dlci 105
for link 7(IP)
00:07:01: broadcast dequeue
00:07:01: Serial0.24(o):Pkt sent on dlci 104(0x1881), pkt encaps 0x300
0x8000 0x0 0x806 (ARP), datagramsize 34
00:07:01: broadcast dequeue
00:07:01: Serial0.256(o):Pkt sent on dlci 106(0x18A1), pkt encaps 0x300
0x8000 0x0 0x806 (ARP), datagramsize 34
00:07:01: broadcast dequeue
00:07:01: Serial0.256(o):Pkt sent on dlci 105(0x1891), pkt encaps 0x300
0x8000 0x0 0x806 (ARP), dat
agramsize 34
00:07:01: Serial0(i): dlci 104(0x1881), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
00:07:01: Serial0(i): dlci 106(0x18A1), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
00:07:01: Serial0(i): dlci 105(0x1891), pkt encaps 0x0300 0x8000 0x0000
0x806 (ARP), datagramsize 34
00:07:01: Serial0.24: frame relay INARP received
00:07:01: Serial0.256: frame relay INARP received
00:07:01: Serial0.256: frame relay INARP received
r2#sh frame map
Serial0.24 (up): ip 150.50.24.4 dlci 104(0x68,0x1880), dynamic,
broadcast,, status defined, active
Serial0.256 (up): ip 150.50.100.5 dlci 105(0x69,0x1890), dynamic,
broadcast,, status defined, active
Serial0.256 (up): ip 150.50.100.6 dlci 106(0x6A,0x18A0), dynamic,
broadcast,, status defined, active
r2#
Any ideas where I went wrong?
This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:36 GMT-3