From: Robert Yee (robert@bluespud.com)
Date: Sun May 04 2003 - 00:07:06 GMT-3
Hi,
I'm working though some FRTs stuff and the more I look into it the more confused I get.
I have some general observations that I want to run by the group.
The scenario:
- Serial interface with 2 multipoint subinterfaces.
- The CIR (AR) of s0.24 is 56k
- The CIR (AR) of s0.256 is 512k split among 2 DLCIs of 256k each
Observation 1.
If I enable 'frame-relay traffic-shaping' on the the physical interface and add nothing else, all subinterfaces get a CIR of 56k by default
Observation 2.
If I enable 'frame-relay traffic-shaping' on the the physical interface and add map-class to the physical interface and nothing else, all subinterfaces inherit the map-class properties
Obseration 3.
If I enable 'frame-relay traffic-shaping' on the the physical interface and add map-class(1) to the physical interface and add map-class(2) to one of the subinterface, then that subinterface will have the properties of 2, while the other will still inherit the properties of 1.
*** OK, this is where I get confused ****
What about a multipoint subinterface with multiple DLCIs? I've tied 2 different confguration methods and both seem to work fine. Which is the correct method?
These are the map class I used for both mothods:
map-class frame-relay frts_dlci_105
frame-relay cir 256000
frame-relay bc 32000
frame-relay be 128000
frame-relay mincir 128000
no frame-relay adaptive-shaping
!
map-class frame-relay frts_dlci_106
frame-relay cir 256000
frame-relay bc 32000
frame-relay be 128000
frame-relay mincir 128000
no frame-relay adaptive-shaping
****************************************************************
Method 1.
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
no frame-relay inverse-arp
!
interface Serial0.24 multipoint
ip address 150.50.24.2 255.255.255.0
frame-relay map ip 150.50.24.2 104 broadcast
frame-relay map ip 150.50.24.4 104 broadcast
!
interface Serial0.256 multipoint
ip address 150.50.100.2 255.255.255.224
frame-relay interface-dlci 105
class frts_dlci_105
frame-relay interface-dlci 106
class frts_dlci_106
r2#sh traffic-shape
Interface Se0.24
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
104 56000 875 7000 0 125 875 -
Interface Se0.256
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
106 256000 20000 32000 128000 125 4000 -
105 256000 20000 32000 128000 125 4000 -
*****************************************************************************
Method 2.
interface Serial0
no ip address
encapsulation frame-relay
no fair-queue
frame-relay traffic-shaping
no frame-relay inverse-arp
!
interface Serial0.24 multipoint
ip address 150.50.24.2 255.255.255.0
frame-relay map ip 150.50.24.2 104 broadcast
frame-relay map ip 150.50.24.4 104 broadcast
!
interface Serial0.256 multipoint
ip address 150.50.100.2 255.255.255.224
ip ospf priority 255
frame-relay map ip 150.50.100.2 105 broadcast
frame-relay map ip 150.50.100.5 105 broadcast
frame-relay map ip 150.50.100.6 106 broadcast
frame-relay interface-dlci 105
class frts_dlci_105
frame-relay interface-dlci 106
class frts_dlci_106
r2#sh traffic-shape
Interface Se0.24
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
104 56000 875 7000 0 125 875 -
Interface Se0.256
Access Target Byte Sustain Excess Interval Increment Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes) Active
106 256000 20000 32000 128000 125 4000 -
105 256000 20000 32000 128000 125 4000 -
*****************************************************************************
This also leads me to my next question, I alsways believed that if inverse arp was turned off, you shouldn't rely on 'frame-relay interface-dlci...' to map your connections?
I thought that if inverse arp was disabled, you should use the map command?
Thanks,
Robert
This archive was generated by hypermail 2.1.4 : Mon Jun 02 2003 - 15:13:36 GMT-3