From: Daemons (liqunhui@LANGCHAO.COM.CN)
Date: Tue Apr 29 2003 - 05:23:59 GMT-3
hi darvin
may be this can help you!
daemons
wr t
Building configuration...
Current configuration : 1135 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1a
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
ip cef
frame-relay switching
cns event-service server
!
!
!
interface Tunnel0
no ip address
no ip route-cache cef
tunnel source Async1
tunnel destination 10.0.0.2
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay IETF
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 100 interface Tunnel0 100
!
interface Serial1
no ip address
encapsulation frame-relay IETF
shutdown
clockrate 64000
frame-relay intf-type dce
frame-relay route 200 interface Tunnel0 200
!
interface Async1
ip address 10.0.0.1 255.255.255.0
encapsulation ppp
async dynamic routing
async mode dedicated
!
ip kerberos source-interface any
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
modem InOut
transport input all
speed 38400
line vty 0 4
login
!
end
r1a#sh fram rou
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0 100 Tunnel0 100 active
Serial1 200 Tunnel0 200 inactive
Tunnel0 100 Serial0 100 active
Tunnel0 200 Serial1 200 inactive
r1a#
Term-Svr#2
[Resuming connection 2 to r1b ... ]
[OK]
r1b#wr t
Building configuration...
Current configuration : 1010 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1b
!
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
ip cef
frame-relay switching
cns event-service server
!
!
!
!
interface Tunnel0
no ip address
no ip route-cache cef
tunnel source Async1
tunnel destination 10.0.0.1
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
encapsulation frame-relay IETF
no fair-queue
clockrate 64000
frame-relay intf-type dce
frame-relay route 100 interface Tunnel0 100
!
interface Serial1
no ip address
encapsulation frame-relay IETF
clockrate 64000
frame-relay intf-type dce
frame-relay route 200 interface Tunnel0 200
!
interface Async1
ip address 10.0.0.2 255.255.255.0
encapsulation ppp
async dynamic routing
async mode dedicated
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
modem InOut
transport input all
speed 38400
line vty 0 4
login
!
end
r1b#sh fram rou
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0 100 Tunnel0 100 active
Serial1 200 Tunnel0 200 inactive
Tunnel0 100 Serial0 100 active
Tunnel0 200 Serial1 200 inactive
r1b#
Term-Svr#4
[Resuming connection 4 to r2 ... ]
r2#sh fram map
Serial0 (up): ip 20.0.0.2 dlci 100(0x64,0x1840), dynamic,
broadcast,
IETF, status defined, active
r2#
Term-Svr#5
[Resuming connection 5 to r3 ... ]
r3#sh fram map
Serial0 (up): ip 20.0.0.1 dlci 100(0x64,0x1840), dynamic,
broadcast,
IETF, status defined, active
r3#ping 20.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 152/152/156 ms
r3#sh fram pvc
PVC Statistics for interface Serial0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
input pkts 16 output pkts 25 in bytes 1356
out bytes 1888 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 10 out bcast bytes 328
pvc create time 00:04:21, last time pvc status changed 00:02:05
r3#
Term-Svr#4
[Resuming connection 4 to r2 ... ]
r2#ping 20.0.0.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 156/156/156 ms
r2#sh fram pvc
PVC Statistics for interface Serial0 (Frame Relay DTE)
Active Inactive Deleted Static
Local 1 0 0 0
Switched 0 0 0 0
Unused 0 0 0 0
DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0
input pkts 32 output pkts 22 in bytes 2474
out bytes 1906 dropped pkts 0 in FECN pkts 0
in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
in DE pkts 0 out DE pkts 0
out bcast pkts 7 out bcast bytes 346
pvc create time 00:05:40, last time pvc status changed 00:02:03
r2#
r2#
r2#
r2#
r2#
r2#
----- Original Message -----
From: "Dennis Dumont" <dfdumont@yahoo.com>
To: "Darvin" <darvin@blueyonder.co.uk>; <ccielab@groupstudy.com>
Sent: Monday, April 28, 2003 2:55 AM
Subject: Re: aux to aux connection
> > i want connect both these routers togther as 1 big
> > frame realy switch.
>
> Can't be done. Each frame switch operates PVC's to
> its local ports only. But... You can connect them as
> two frame switches that have an NNI interface between
> them as follows:
> R1:
> int ser x/x
> encap frame
> frame-relay intf-type nni
> frame route 101 int ser x/x+1 201
> (Presents DLCI 201 to the client attached to port
> x/x+1)
>
> R2:
> int ser y/y
> encap frame
> frame-relay intf-type nni
> frame route 101 int ser y/y+1 301
> (Presents DLCI 301 to the client attached to port
> y/y+1)
>
> This adds some interseting capabilities you don't
> normally have, like mismatched CIR's, disparate
> traffic shapping/policing, and different LMI
> end-to-end. You can begin to simulate what is
> actually in the real world.
>
> > problem i cant tunnel as 1 ethernet port and 1 a
> > token ring.
> >
> > i do beleive u can connect the router together using
> > the auxillary port then
> > tunnel the aux .
>
> ??? I'm lost with this. What are you thinking?
> encapsulating frame in a Tunnel interface? or just
> getting the two frame switches to speak BGP or an IGP
> to each other? If you need layer three routing
> between the switches, then use the AUX trick. Its
> VERY documented in the archives of Groupstudy - just
> be aware that you're limited to a 38,400 bps link and
> its ASYNC so nothing really taxing.
>
> Otherwise keep in mind that Frame-relay is a layer two
> (2) protocol and as such has no knowledge of IP or its
> routing. Just get the two switches to speak LMI to
> each other across the NNI interface above and they can
> each switch PVC traffic from the NNI interface to
> another serial port.
>
> __________________________________
> Do you Yahoo!?
> The New Yahoo! Search - Faster. Easier. Bingo.
> http://search.yahoo.com
liqunhui
ShanDong Cheeloosoft Corporation Ltd.
ShanDa Road 224,JiNan ShanDong province
Tel:86-531-8932888
----- Original Message -----
From: "Dennis Dumont" <dfdumont@yahoo.com>
To: "Darvin" <darvin@blueyonder.co.uk>; <ccielab@groupstudy.com>
Sent: Monday, April 28, 2003 2:55 AM
Subject: Re: aux to aux connection
> > i want connect both these routers togther as 1 big
> > frame realy switch.
>
> Can't be done. Each frame switch operates PVC's to
> its local ports only. But... You can connect them as
> two frame switches that have an NNI interface between
> them as follows:
> R1:
> int ser x/x
> encap frame
> frame-relay intf-type nni
> frame route 101 int ser x/x+1 201
> (Presents DLCI 201 to the client attached to port
> x/x+1)
>
> R2:
> int ser y/y
> encap frame
> frame-relay intf-type nni
> frame route 101 int ser y/y+1 301
> (Presents DLCI 301 to the client attached to port
> y/y+1)
>
> This adds some interseting capabilities you don't
> normally have, like mismatched CIR's, disparate
> traffic shapping/policing, and different LMI
> end-to-end. You can begin to simulate what is
> actually in the real world.
>
> > problem i cant tunnel as 1 ethernet port and 1 a
> > token ring.
> >
> > i do beleive u can connect the router together using
> > the auxillary port then
> > tunnel the aux .
>
> ??? I'm lost with this. What are you thinking?
> encapsulating frame in a Tunnel interface? or just
> getting the two frame switches to speak BGP or an IGP
> to each other? If you need layer three routing
> between the switches, then use the AUX trick. Its
> VERY documented in the archives of Groupstudy - just
> be aware that you're limited to a 38,400 bps link and
> its ASYNC so nothing really taxing.
>
> Otherwise keep in mind that Frame-relay is a layer two
> (2) protocol and as such has no knowledge of IP or its
> routing. Just get the two switches to speak LMI to
> each other across the NNI interface above and they can
> each switch PVC traffic from the NNI interface to
> another serial port.
>
> __________________________________
> Do you Yahoo!?
> The New Yahoo! Search - Faster. Easier. Bingo.
> http://search.yahoo.com
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:36:09 GMT-3