nat on multihomed

From: Ali Fahmi (afahmi@plasa.com)
Date: Thu Apr 24 2003 - 03:48:08 GMT-3


hi All,

I have a router as internet gateway connected to 2
different ISPs, second ISP is as backup
I use private Addres on Ethernet and Public IP on serial.

I implemented policy routing like this on Ethernet 0

access-list 1 permit 192.168.1.0 0.0.0.255

route-map traffic permit 10
    match ip address 1
    set interface serial 0 serial 1

TRAFFIC FLOW EXPECTED :,
IF Packet forwarded to ISP1 Private IP will be translated
to Public IP of ISP1, (i.e 202.155.23.0/28) , if link is
down packets will be forwarded to ISP2 (i.e 203.15.1.0/28)

so, I created NAt based route-map like this

route-map ISP1-map permit 10
  match ip address 1
  match interface serial 0

route-map ISP2-map permit 10
  match ip address 1
  match interface serial 1

ip nat inside source route-map ISP1-map pool ISP1-ip
ip nat inside source route-map ISP2-map pool ISP2-ip

ip nat pool ISP1-ip netmask 255.255.255.240
  address 202.155.23.1 202.155.23.14

ip nat pool ISP2-ip netmask 255.255.255.240
  address 203.15.1.1 203.15.1.14

Ip nat translation timeout 3

PROBLEM :
- When I ping from PC on LAN to the Internet and I unplug
cable on serial 0
   ping always request-time out
   when I debug nat, I saw private Ip Address still be
translated to Public of ISP1 but
   packet have been forwarded to ISP2 (serial 1),
   IF I clear NAT Cache, ping to the internet via iSP2 can
get reply packet
   
   I expect, IF serial 0 down, NAT automatically change
from Ip of ISP1 to ISP2,

- I have already change nat timeout from default to 3
seconds, but this problem still exist,

Question :
Is there any additional config mas bu put in order NAT can
change the global ip from ISP1 to ISP2 automatically
without clearing NAT cache ??????

Thanks,

----

Ali

=========================================================================================== "Sudahkah Anda mencoba PlasaMessenger, aplikasi chat yg bisa digunakan untuk bertukar file, download di http://im.plasa.com" "Malas antri buat mendapatkan print-out tagihan telepon ? Klik aja http://billinfo2.plasa.com" ===========================================================================================



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:36:04 GMT-3