Re: How to convert Custom-Q to CBWFQ -- Process White Paper?

From: cannonr (cannonr@attbi.com)
Date: Mon Apr 21 2003 - 19:53:08 GMT-3


Is there a reason why this list uses multiplies by .75 instead of just using
max-reserved-bw in CBWFQ?
----- Original Message -----
From: "Carlson, James" <james.m.carlson@mci.com>
To: <ccielab@groupstudy.com>
Sent: Monday, April 21, 2003 2:25 PM
Subject: RE: How to convert Custom-Q to CBWFQ -- Process White Paper?

> Hello,
> Is there a white paper or tech tip on CCO to do the various queuing
> conversions?
> Thanks!
> Jamie
>
>
>
> -----Original Message-----
> From: Scott M. Livingston [mailto:scottl@sprinthosting.net]
> Sent: Sunday, April 20, 2003 12:18 AM
> To: 'Jeongwoo Park'; 'Jake Reynolds'; ccielab@groupstudy.com
> Subject: RE: How to convert Custom-Q to CBWFQ
>
> >> queue-list 1 protocol telnet 0
> >> queue-list 1 protocol ftp 1
> >> queue-list 1 default 2
> >> queue-list 1 queue 0 byte-count 1000 limit 100
> >> queue-list 1 queue 1 byte-count 1000 limit 100
> >> queue-list 1 queue 2 byte-count 2000 limit 100
>
> Based off the above this is how I would do it.....
> #############################
> To Find BW
> -------------
> BW = 128 * (byte of queue / total byte count of queues) * .75
>
>
> To Find BW %
> ------------
> BW % = (byte of queue / total byte count of queues) * .75
>
> ###############################
>
> Telnet Queue:
> -------------
> BW = 128 * (1000 / 4000) * .75
> BW = 24
>
> FTP Queue:
> ----------
> BW = 128 * (1000 / 4000) * .75
> BW = 24
>
> Default Queue:
> --------------
> BW = 128 * (2000 / 4000) * .75
> BW = 48
>
> !
> class-map match-all TELNET
> match access-group 100
> class-map match-all FTP
> match access-group 101
> !
> policy-map TCP-STUFF
> class TELNET
> bandwidth 24
> queue-limit 100
> class FTP
> bandwidth 24
> queue-limit 100
> class class-default
> bandwidth 48
> queue-limit 100
> !
> !
> interface Serial0/0
> band 128
> service-policy output TCP-STUFF
> !
> !
> access-list 100 permit tcp any any eq telnet
> access-list 101 permit tcp any any eq ftp
> access-list 101 permit tcp any any eq ftp-data
> !
>
> Let me know if you feel like I have something jacked! Fabrice and I
> shared some dialog on this a few weeks ago - I ended up seeing it his
> way. :)
>
> Thanks!
> scott
>
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Jeongwoo Park
> Sent: Saturday, April 19, 2003 8:10 PM
> To: 'Jake Reynolds'; 'ccielab@groupstudy.com'
> Subject: RE: How to convert Custom-Q to CBWFQ
>
> Jake,
>
> Where did you get the 30% from?
>
> JP
>
> -----Original Message-----
> From: Jake Reynolds [mailto:JREYNOLDS@uscentral.org]
> Sent: Wednesday, April 02, 2003 8:10 AM
> To: Ciscolab
> Cc: ccielab@groupstudy.com
> Subject: RE: How to convert Custom-Q to CBWFQ
>
>
> Well it depends on the bandwidth of your interface. If your interface is
> 128kbps then my math using the previous scenario would be:
>
> >> queue-list 1 protocol telnet 0
> >> queue-list 1 protocol ftp 1
> >> queue-list 1 default 2
> >> queue-list 1 queue 0 byte-count 1000 limit 100
> >> queue-list 1 queue 1 byte-count 1000 limit 100
> >> queue-list 1 queue 2 byte-count 2000 limit 100
>
> Add the byte counts together to get a total byte count.
>
> 1000 + 1000 + 2000 = 4000 bytes
>
> Multiply each queue by 30% (or .30) and divide by the total byte count.
>
> Queue 0: (.30 * 1000) / 4000 = .075 or 7.5%
> Queue 1: (.30 * 1000) / 4000 = .075 or 7.5%
> Queue 2: (.30 * 2000) / 4000 = .15 or 15%
>
> Check to make sure your percentages = 30 %
> 7.5% + 7.5% + 15% = 30%
>
> Multiply each percentage by the interface bandwidth.
>
> .....075 * 128 kpps = 9.6kbps
> .....075 * 128 kbps = 9.6kbps
> .....15 * 128 kpbs = 19.2kbps
>
> Check things again by adding up the bandwidths and dividing by the total
> interface bandwidth if you're a freak.
>
> 9.6kbps + 9.6 kbps + 19.2 kbps = 38.4kbps
> 38.4kbps / 128kbps = .3 (30%)
>
> And there you have it.
>
> Telnet get's 9.6kbps
> FTP gets 9.6kpbs
> Class-Default gets 19.2kbps
>
> And don't forget to add queue depths of 100 to each class in the
> policy-map
>
>
>
> Jake Reynolds
> Systems Engineer - Information Systems
> CCIE #11224, MCSE NT4 & W2K, CCNA, CCNP, A+
>
> US Central Credit Union
> 9701 Renner Blvd.
> Lenexa, KS 66219
>
> Office- 913.227.6122
> Cell- 816.305.6785
>
> jreynolds@uscentral.org
>
>
> -----Original Message-----
> From: Ciscolab [mailto:ciscolab@vip.sina.com]
> Sent: Wednesday, April 02, 2003 9:41 AM
> To: Jake Reynolds
> Cc: ccielab@groupstudy.com
> Subject: Re: How to convert Custom-Q to CBWFQ
>
>
> Jake Reynolds,
>
> If I use the command "Bandwidth percent 30", How much bandwidth will be
> use
> for the class in CBWFQ,
>
> A. 30% * 75% * X
> B. 305 * X
>
>
>
> ======= 2003-04-02 08:57:00 DzTZ@4PEVPP45@#:=======
>
> >I would assume that since you want to convert from CQ to CBWFQ as
> >accurately as possible, consider the following:
> >
> >1. CQ assumes 100 of the bandwidth. It doesn't matter whether you
> have
> >1 queue or 10 queues it's always moving from queue to queue (even
> >though it only takes effect during times of congestion.)
> >
> >2. By default an interface won't let you reserve more than 75 of its
> >bandwidth with CBWFQ.
> >
> >Since you want to be accurate use the max-reserve-bandwidth 100
> >command. This way you are actually distributing bandwidth like the CQ
>
> >specifies, not 75 of what the CQ specifies.
> >
> >Jake Reynolds
> >Systems Engineer - Information Systems
> >CCIE #11224, MCSE NT4 & W2K, CCNA, CCNP, A+
> >
> >US Central Credit Union
> >9701 Renner Blvd.
> >Lenexa, KS 66219
> >
> >Office- 913.227.6122
> >Cell- 816.305.6785
> >
> >jreynolds@uscentral.org
> >
> >
> >-----Original Message-----
> >From: ciscolab@vip.sina.com [mailto:ciscolab@vip.sina.com]
> >Sent: Tuesday, April 01, 2003 7:38 PM
> >To: Jake Reynolds
> >Cc: ccielab@groupstudy.com
> >Subject: RE: How to convert Custom-Q to CBWFQ
> >
> >
> >Do we need to consider the default bandwidth for CQ and CBWFQ
> >----- Original Message -----
> >From:"Jake Reynolds" <JREYNOLDS@uscentral.org>
> >To:<ccielab@groupstudy.com>
> >Subject:RE: How to convert Custom-Q to CBWFQ
> >Date:Tue, 1 Apr 2003 22:54:41 +0800
> >> Just add the byte counts together and divide each value by the
> >total.
> >> This gives you bandwidth percentages for each protocol. Then make
> >> class-maps matching each protocol. Create a policy-map and enter
> the
> >
> >> classes with the appropriate bandwidth percentages. Also don't
> >forget
> >> the queue depth of 100 packets. Then of course apply the policy-map
> >to
> >> an interface with the service-policy [input | output] command.
> >>
> >> Jake Reynolds
> >> Systems Engineer - Information Systems
> >> CCIE #11224, MCSE NT4 & W2K, CCNA, CCNP, A+
> >>
> >> US Central Credit Union
> >> 9701 Renner Blvd.
> >> Lenexa, KS 66219
> >>
> >> Office- 913.227.6122
> >> Cell- 816.305.6785
> >>
> >> jreynolds@uscentral.org
> >>
> >>
> >> -----Original Message-----
> >> From: Scot Peter [mailto:scotsman@rediffmail.com]
> >> Sent: Tuesday, April 01, 2003 7:48 AM
> >> To: ccielab@groupstudy.com
> >> Subject: How to convert Custom-Q to CBWFQ
> >>
> >>
> >> Hello Group,
> >>
> >> I have already posted a question on this topic, but no answers
> yet...
> >> so posting again... I want to convert the below Custom Queue to
> >> CBWFQ. How can I do it. Please put your suggestions.
> >>
> >> queue-list 1 protocol telnet 0
> >> queue-list 1 protocol ftp 1
> >> queue-list 1 default 2
> >> queue-list 1 queue 0 byte-count 1000 limit 100
> >> queue-list 1 queue 1 byte-count 1000 limit 100
> >> queue-list 1 queue 2 byte-count 2000 limit 100
> >>
> >> int s0
> >> custom-queue-list 1
> >>
> >> Warm regards
> >> Scot
> >>
> >>
> >_____________________________________________________________________
> _
> >> _
> >> Odomos - the only mosquito protection outside 4 walls - Click here
> >to
> >> know more!
> >>
> >http://r.rediff.com/r?http://clients.rediff.com/odomos/Odomos.htm&&od
> o
> >> mos&&wn
> >>
> >>
> >
> >______________________________________
> >
> >===================================================================
>
> = = = = = = = = = = = = = = = = = = = =
>
>
> !!!!!!!!!!!!!!!!VB
> @q#!
>
>
> !!!!!!!!!!!!!!!!Ciscolab
> !!!!!!!!!!!!!!!!ciscolab@vip.sina.com
> !!!!!!!!!!!!!!!!!!!!2003-04-02



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:36:00 GMT-3