From: badger (badger@pongo.org)
Date: Thu Apr 10 2003 - 19:52:14 GMT-3
Hello Jeff,
Thursday, April 10, 2003, 8:56:31 AM, you wrote:
JS> Thank you for everyone's help.
JS> I have just upgrade the IOS, but same problem resulted.
JS> I try to debug the ping and found something interesting. When the ping
JS> unsuccessful, it shows "encapsulation failed",
JS> could someone explain the meaning?
JS> Thank you.
JS> Switch#ping 172.16.56.6
JS> Type escape sequence to abort.
JS> Sending 5, 100-byte ICMP Echos to 172.16.56.6, timeout is 2 seconds:
JS> !!!!!
JS> Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
JS> Switch#
JS> 06:33:15: datagramsize=100, IP 35: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending
JS> 06:33:15: datagramsize=114, IP 35: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending full packet
JS> 06:33:15: datagramsize=118, IP 35: s=172.16.56.6 (Vlan123), d=172.16.56.123,
JS> totlen 100, fragment 0, fo 0, rcvd 1
JS> 06:33:15: datagramsize=100, IP 36: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending
JS> 06:33:15: datagramsize=114, IP 36: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending full packet
JS> 06:33:15: datagramsize=118, IP 36: s=172.16.56.6 (Vlan123), d=172.16.56.123,
JS> totlen 100, fragment 0, fo 0, rcvd 1
JS> 06:33:15: datagramsize=100, IP 37: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending
JS> 06:33:15: datagramsize=114, IP 37: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending full packet
JS> 06:33:15: datagramsize=118, IP 37: s=172.16.56.6 (Vlan123), d=172.16.56.123,
JS> totlen 100, fragment 0, fo 0, rcvd 1
JS> 06:33:15: datagramsize=100, IP 38: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending
JS> 06:33:15: datagramsize=114, IP 38: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending full packet
JS> 06:33:15: datagramsize=118, IP 38: s=172.16.56.6 (Vlan123), d=172.16.56.123,
JS> totlen 100, fragment 0, fo 0, rcvd 1
JS> 06:33:15: datagramsize=100, IP 39: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending
JS> 06:33:15: datagramsize=114, IP 39: s=172.16.56.123 (local), d=172.16.56.6
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending full packet
JS> 06:33:15: datagramsize=118, IP 39: s=172.16.56.6 (Vlan123), d=172.16.56.123,
JS> totlen 100, fragment 0, fo 0, rcvd 1
JS> Switch#
JS> Switch#ping 172.16.56.5
JS> Type escape sequence to abort.
JS> Sending 5, 100-byte ICMP Echos to 172.16.56.5, timeout is 2 seconds:
JS> 06:33:25: datagramsize=100, IP 40: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending.
JS> 06:33:28: datagramsize=100, IP 40: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, encapsulation failed
JS> 06:33:28: datagramsize=100, IP 41: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending.
JS> 06:33:31: datagramsize=100, IP 41: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, encapsulation failed
JS> 06:33:31: datagramsize=100, IP 42: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending.
JS> 06:33:34: datagramsize=100, IP 42: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, encapsulation failed
JS> 06:33:34: datagramsize=100, IP 43: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending.
JS> 06:33:37: datagramsize=100, IP 43: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, encapsulation failed
JS> 06:33:37: datagramsize=100, IP 44: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, sending.
JS> Success rate is 0 percent (0/5)
JS> Switch#
JS> 06:33:40: datagramsize=100, IP 44: s=172.16.56.123 (local), d=172.16.56.5
JS> (Vlan123), totlen 100, fragment 0, fo 0, encapsulation failed
JS> ----- Original Message -----
JS> From: "Jung, Jin" <jin.jung@lmco.com>
JS> To: "'Szeto Jeff'" <jytszeto@hotmail.com>; <ccielab@groupstudy.com>
JS> Sent: Thursday, April 10, 2003 9:51 PM
JS> Subject: RE: bvi help please
>>
>> It looks like all your IP addresses are in same subnet,
>> Other config looks okay,
>>
>> You may want to make VLAN 2 or Vlan 123 different subnet,
>>
>> Remember that, if des ip add is in same subnet, it will not be routed,
JS> local
>> ping, and since ports are in different Vlan of switch, ping will fail,
>>
>> When u want to route the packets using BVI interface, you need to make the
>> subnets different.
>>
>> Jin jung...
>>
>> -----Original Message-----
>> From: Szeto Jeff [mailto:jytszeto@hotmail.com]
>> Sent: Tuesday, April 08, 2003 11:02 PM
>> To: ccielab@groupstudy.com
>> Subject: bvi help please
>>
>>
>> Hi,
>>
>> I am following the example in
>> http://www.groupstudy.com/archives/ccielab/200207/msg01615.html
>> but need help.
>>
>> Router6-f0/0----------f0/24-Cat3550-f0/12-------Router5
>> Router1-e0------------f0/4-
>>
>> Router 6 and 3550 form an isl trunk, Router 5 is in vlan 2 Router 1 is in
>> vlan 123.
>>
>> The routers can ping each other with no problem but the switch cannot ping
>> Router 5 if I put the ip address in vlan 123 of the switch.
>> If the ip address is in vlan 2, it can ping Router 5.
>>
>> Config of the routers and switch.
>>
>> Switch
>>
>> interface FastEthernet0/4
>> switchport access vlan 123
>>
>> interface FastEthernet0/12
>> switchport access vlan 2
>>
>> interface FastEthernet0/24
>> switchport trunk encapsulation isl
>> switchport mode trunk
>>
>> interface Vlan1
>> no ip address
>>
>> interface Vlan2
>> no ip address
>>
>> interface Vlan123
>> ip address 172.16.56.123 255.255.255.0
>>
>> ip default-gateway 172.16.56.6
>>
>>
>> Router 6
>>
>> bridge irb
>> interface FastEthernet0/0.1
>> encapsulation isl 1
>> no ip redirects
>> bridge-group 2
>> !
>> interface FastEthernet0/0.2
>> description connecting to Router 5
>> encapsulation isl 2
>> no ip redirects
>> bridge-group 2
>> !
>> interface FastEthernet0/0.3
>> description for switch and Router 1
>> encapsulation isl 123
>> no ip redirects
>> bridge-group 2
>>
>> interface BVI2
>> ip address 172.16.56.6 255.255.255.0
>>
>> bridge 1 protocol ieee
>> bridge 1 route ip
>> bridge 2 protocol ieee
>> bridge 2 route ip
>>
>> Router 5 f0/0: ip add 172.16.56.5/24
>> Router 1 e0: ip add 172.16.56.200/24
>>
>> Thank you very much.
>>
>> Jeff
>>
>>
>>
>>
>>
>> _________________________________________________________________
>> No masks required! Use MSN Messenger to chat with friends and family.
>> http://go.msnserver.com/HK/25382.asp
This will not work on the 3550
-- Best regards, badger mailto:badger@pongo.org
This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:50 GMT-3