RE: VoIP UDP ports

From: Joe Martin (joe@martinsweb.org)
Date: Thu Apr 10 2003 - 18:04:59 GMT-3


VoIP Ports
----------
TCP 1720 H.323 H.225
TCP 1718-1719 H.323 RAS
TCP 11000-11999 H.323 H.245
TCP 5060 SIP
UDP 2427 MGCP
UDP 2428 MGCP backhaul
TCP 2000 Cisco Skinny Phone
TCP 2001 Cisco Skinny Analog Trunk (obsolete)
TCP 2002 Cisco Skinny Digital Trunk (obsolete)
UDP 16384-32787 RTP (even numbers are rtp and odd numbers are rtcp)
If router has 4 ports of voice then only need 16384 to 16390 in ACL.

LLQ

---
class-map match-all VoIP-Control
  match access-group 100
class-map match-all VoIP-RTP
  match access-group 101
!
policy-map VoIP-Policy
  class VoIP-RTP
    priority 507
  class VoIP-Control
   bandwidth 16
  class class-default
   fair-queue
!
Interface s0/0
  service-policy output VoIP-Policy
!
access-list 100 permit tcp any eq 1720 any
access-list 100 permit tcp any eq 2000 any
access-list 100 permit tcp any eq 2001 any
access-list 100 permit tcp any eq 2002 any
access-list 100 permit udp any range 2427 2428 any
access-list 100 permit tcp any eq 5060 any
access-list 100 permit tcp any range 1718 1719 any
access-list 100 permit tcp any range 11000 11999 any
access-list 100 permit tcp any any eq 1720
access-list 100 permit tcp any any eq 2000
access-list 100 permit tcp any any eq 2001
access-list 100 permit tcp any any eq 2002
access-list 100 permit udp any any range 2427 2428
access-list 100 permit tcp any any eq 5060
access-list 100 permit tcp any any range 1718 1719
access-list 100 permit tcp any any range 11000 11999
!
access-list 101 permit udp any any range 16384 32768
access-list 101 permit udp any range 16384 32768 any

Joe CCIE #5917

-----Original Message----- From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of Niksa Tomulic Sent: Thursday, April 10, 2003 3:23 AM To: 'Ccielab' Subject: VoIP UDP ports

Hi, Reading trough QOS for VoIP, and using ACLs to identify VoIP traffic, I can't find definite reference about which ports VoIP traffic use. There are different examples by Cisco what I've seen so far:

For sure there is TCP port 1720 which is used for H.323 signaling traffic, but: for VoIP itself I've seen different examples, and they all state "common UDP ports used by VoIP":

EX 1 access-list 100 permit udp any any range 16384 32767

EX 2 access-list 100 permit udp any any range 16384 32000

And with this command, again different:

ip rtp priority 16384 16383 40

Any thoughts?

Thanks, niksa



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:50 GMT-3