[RE]Re: WRED, it's so confusing

From: midaskim (janggulove@hanmail.net)
Date: Tue Apr 08 2003 - 02:27:58 GMT-3


Policy routing can't be applied inbound direction??

I didn't know that...

If it is right, this config is possible??

Which command is processes first?

and

How can I test (precedence or WRED)??

Any debug command?

<Another Config>

class-map match-all telnet
match protocol telnet
class-map match-all ftp
match protocol ftp
!
!
policy-map kms
class telnet
set ip precedence 1
bandwidth percent 40
random-detect
random-detect precedence 1 10 30 20
class ftp
set ip precedence 2
bandwidth percent 40
random-detect
random-detect precedence 2 10 25 20
class class-default
set ip precedence 0
bandwidth percent 20
random-detect
random-detect precedence 0 30 60 20

interface Serial0/0 -----> Engress traffic interface
  service-policy output kms

  ---------[ 9^@: 8^@O 3;?k ]----------
  A&8q : Re: WRED, it's so confusing
  3/B% : Mon, 07 Apr 2003 21:51:00 -0500
  :83=@L : "Zachary Hinz" <z_hinz@hotmail.com>
  9^4B@L : ng-hlong@hn.vnn.vn, janggulove@hanmail.net,
  ccielab@groupstudy.com

  Policy routing is applied in an outbound (egress) direction. Packets
  coming
  into your Ethernet interface will not have there precedence changed.

>From: "Nguyen Hoang Long"
>Reply-To: "Nguyen Hoang Long"
>To: "midaskim" ,
>Subject: Re: WRED, it's so confusing Date: Tue, 8 Apr 2003 08:52:09
  +0700
>
>1. yes, it's for Ingress
>2. I beleive it's possible
>
>ip cef
><<<>>>
>class telnet
> match protocol telnet
>class ftp
> match protocol ftp
>
>policy-map kms
> class telnet
> set ip precedence 1
> class ftp
> set ip precedence 2
> class class-default
> set ip precedence 0
>
>
><<>>
>the same as yours
>
>3.I think in your route-map kms permit 30
>you should have : set ip precedence 0
>
>although if IP precedence is not set by any network equipment, it's
>default=0, but who guarantees that some network device in the middle
  (from
>your router up to the source) does not do IP precedence setting
  also. So,..
>just reset it.
>
>Any idea ?
>
>----- Original Message -----
>From: "midaskim"
>To:
>Sent: Monday, April 07, 2003 4:04 PM
>Subject: WRED, it's so confusing
>
>
> > Hi, all
> >
> > I'm configuring WRED.
> >
> > But There are some confusing issues.
> >
> > 1) Telnet randomly dropped if queue is over 10 and completely
  dropped if
> > over 30
> > 2) FTP randomly dropped if queue is over 10 and completely
  dropped if
> > over 25
> > 3) Rest of the traffic randomly dropped if queue is over 30 and
> > completely
> > dropped if over 60
> > 4) Drop probability is 1 in 20 packet
> >
> >
> >
> > access-list 101 permit tcp any any eq telnet
> > access-list 102 permit tcp any any eq ftp-data
> > access-list 102 permit tcp any any eq ftp
> >
> > route-map kms permit 10
> > match ip address 101
> > set ip precedence priority
> > !
> > route-map kms permit 20
> > match ip address 102
> > set ip precedence immediate
> > !
> >
> > route-map kms permit 30
> > !
> >
> > interface Ethernet0 ----------> ingress traffic interface
> > ip policy route-map kms
> > !
> > interface Serial0
> > random-detect
> > random-detect precedence 0 30 60 20
> > random-detect precedence 1 10 30 20
> > random-detect precedence 2 10 25 20
> > !
> > !
> >
> > ------------------------------------------------------
> >
> > My config is right ??
> >
> >
> >
> > 1. Is that right that "route-map" is used in Ehternet0 (ingress
> > interface) ?
> >
> > Engress is right? I guess "Ingress" is right...
> >
> > 2. Is it possible to use "policy-map" instead of "route-map"???
> >
> > If it is possible, plz give me examples...
> >
> > 3. "precedence 0 30 60 20" means any traffic is......30 60 20..
> >
> > By default, All of traffic are "precedence is 0". Right??
> >
> > thanks..
> >

[IMAGE]

[IMAGE]

[IMAGE]

midaskim

[IMAGE]

[IMAGE]

"?l8. @NEM3], Daum" http://www.daum.net !:Fr;}>24B 9+7a GQ8^@O3]!;

[IMAGE]

GA8.9L>v 8^@O =a:8<L>n?d?
60!Av =:E2+?k7.H.@e+%a 3*88@G 8BCc 8^@O!

[IMAGE]

[IMAGE]

Daum>nGP?x
C<0h@{@N ?5>n@|9.DZ=:

[IMAGE]



This archive was generated by hypermail 2.1.4 : Thu May 01 2003 - 13:35:48 GMT-3