From: Hunt Lee (ciscoforme3@yahoo.com.au)
Date: Thu Mar 20 2003 - 10:16:32 GMT-3
Hi group,
I'm confused on the following eg.
<--- Area 2 ----->
Trunk VLAN30
11.1.1.1---R1 --- Cat 3550 ---- R2---200.200.200.1
(Area 11) |
|
|
other OSPF routers (OSPF Area 0)
R2 is advertising a default route out to OSPF
by: ip route 0.0.0.0 0.0.0.0 137.20.20.2
Both 11.1.1.1 & 200.200.200.1 are Loopback interface by R1 and R2 respectively
I scratched my head as to how can R2 establish a virtual-link to R1 with IP
11.1.1.1, where 11.1.1.1 is in Area 11, since I was expecting that R2 won't be able
to know about 11.1.1.1 until the Virtual-Link is formed...
At R2:-
interface Loopback0
ip address 200.200.200.1 255.255.255.0
interface Ethernet0
ip address 137.20.20.1 255.255.255.0
ip ospf priority 200
router ospf 1
router-id 200.200.200.1
log-adjacency-changes
area 2 virtual-link 11.1.1.1 <---- How can R2 see 11.1.1.1
network 137.20.20.1 0.0.0.0 area 2
network 150.100.32.2 0.0.0.0 area 0
default-information originate metric 100 metric-type 1
At R1:-
interface Loopback0
ip address 11.1.1.1 255.255.255.0
interface FastEthernet0/0.1
encapsulation dot1Q 10
ip address 192.168.1.11 255.255.255.224
!
interface FastEthernet0/0.2
encapsulation dot1Q 20
ip address 10.90.1.11 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 30
ip address 137.20.20.11 255.255.255.0
!
router ospf 1
router-id 11.1.1.1
log-adjacency-changes
area 2 virtual-link 200.200.200.1
summary-address 192.168.1.0 255.255.255.0
network 11.1.1.1 0.0.0.0 area 11
network 137.20.20.11 0.0.0.0 area 2
And at 3550:-
interface FastEthernet0/2
description R2
switchport access vlan 30
switchport mode access
no ip address
interface FastEthernet0/14
description R1's Trunk port
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-39,184-4094
switchport mode trunk
no ip address
duplex full
speed 100
Regards,
Lee
http://mobile.yahoo.com.au - Yahoo! Mobile
- Check & compose your email via SMS on your Telstra or Vodafone mobile.
This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:42 GMT-3