From: Brian Dennis (brian@labforge.com)
Date: Thu Mar 13 2003 - 20:25:46 GMT-3
It would not change anything to use a physical interface or a multipoint
subinterface. The issue is that AS1, AS2 and AS3 are all on the same IP
subnet. Let's say this was Ethernet and we had the same peering
arrangement and IP addresses, AS1 <-> AS2, AS1 <-> AS3 but no peering of
AS2 to AS3. If AS1 advertised a route learned from AS2 onto AS3, why
would AS3 need to send packets to AS1 that are destined for AS2 when
they could have been sent directly to AS2 in the first place? If AS3
sends the packets to AS1, AS1 would have to turn right around and resend
them on the same segment onto AS2. This is why AS1 does not alter the
next hop.
This of course is not a problem with most multi-access media (Ethernet,
Token-ring, FDDI, etc) because each router can talk directly with all
other routers on the segment. But in a Frame-relay or ATM environment it
is possible (technically Ethernet also) that a router can not reach
other routers that are on the same segment (IP subnet) and this in turn
is where the problem comes in. So lets see why this could have been a
problem with the original Frame-relay design (hub and spoke). If the
spokes are all on the same IP subnet each spoke needs to be able to
reach the other spokes if the hub is not altering the next hop address.
If the spokes can't reach the other spokes (i.e. physical or multipoint
without mappings) the network is broken.
Brian Dennis, CCIE #2210 (R&S/ISP Dial/Security) CCSI# 98640
brian@labforge.com
-----Original Message-----
From: Pita40 [mailto:pita40@hotmail.com]
Sent: Thursday, March 13, 2003 11:55 AM
To: Brian Dennis; 'CCIE FUN'
Cc: ccielab@groupstudy.com
Subject: Re: BGP and Multipoint interface
Dennis,
What id int s0 on r1 was a just a physical int and not a multipoint int?
----- Original Message -----
From: "Brian Dennis" <brian@labforge.com>
To: "'CCIE FUN'" <ccieexam2002@yahoo.com>
Cc: <ccielab@groupstudy.com>
Sent: Thursday, March 13, 2003 11:47 AM
Subject: RE: BGP and Multipoint interface
> This doesn't mean AS1 will be the next hop for AS3 to get to AS2. This
> is a multi-access network so AS1 will not alter the next hop by
default.
> If AS2 and AS3 were on separate IP subnets then AS1 will alter the
next
> hop. Here is an example:
>
> AS3#sho run
> <snip>
> hostname AS3
> !
> interface Loopback3
> ip address 3.3.3.3 255.255.255.255
> !
> interface Serial1/0
> ip address 10.1.1.3 255.255.255.0
> encapsulation frame-relay
> no arp frame-relay
> frame-relay map ip 10.1.1.1 301 broadcast
> no frame-relay inverse-arp
> !
> router bgp 3
> network 3.0.0.0
> neighbor 10.1.1.1 remote-as 1
> !
> <snip>
>
> AS3#sho ip bgp
> BGP table version is 2, local router ID is 3.3.3.3
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 3.0.0.0 0.0.0.0 0 32768 i
> AS3#
>
>
> AS1#sho run
> <snip>
> !
> hostname AS1
> !
> interface Serial0/0.1 multipoint
> ip address 10.1.1.1 255.255.255.0
> no arp frame-relay
> frame-relay map ip 10.1.1.2 102 broadcast
> frame-relay map ip 10.1.1.3 103 broadcast
> no frame-relay inverse-arp
> !
> router bgp 1
> bgp log-neighbor-changes
> neighbor 10.1.1.2 remote-as 2
> neighbor 10.1.1.3 remote-as 3
> <snip>
>
> AS1#sho ip bgp
> BGP table version is 2, local router ID is 10.1.1.1
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 3.0.0.0 10.1.1.3 0 0 3 i
> AS1#
>
>
> AS2#sho run
> <snip>
> hostname AS2
> !
> interface Serial0/0
> ip address 10.1.1.2 255.255.255.0
> encapsulation frame-relay
> no arp frame-relay
> frame-relay map ip 10.1.1.1 201 broadcast
> no frame-relay inverse-arp
> !
> router bgp 2
> bgp log-neighbor-changes
> neighbor 10.1.1.1 remote-as 1
> !
> <snip>
> AS2#sho ip bgp
> BGP table version is 2, local router ID is 10.1.1.2
> Status codes: s suppressed, d damped, h history, * valid, > best, i -
> internal
> Origin codes: i - IGP, e - EGP, ? - incomplete
>
> Network Next Hop Metric LocPrf Weight Path
> *> 3.0.0.0 10.1.1.3 0 1 3 i
> AS2#
>
>
> Brian Dennis, CCIE #2210 (R&S/ISP Dial/Security) CCSI# 98640
> brian@labforge.com
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> CCIE FUN
> Sent: Thursday, March 13, 2003 7:36 AM
> To: Sanfilippo, Ted; 'ccielab@groupstudy.com'
> Subject: Re: BGP and Multipoint interface
>
> I don't think you would need to use next hop self on
> any router.
> since you are running EBGP. your next hop for any AS
> would be its neighbor( specified in the neighbor
> statement)
>
> this means AS1 is next hop for AS3 to get to AS2( it
> at all you are allowing AS1 to be a transit AS to get
> to AS2.
>
>
> --- "Sanfilippo, Ted" <Ted.Sanfilippo@PaeTec.com>
> wrote:
> > Does anyone know of issues with the following set-up
> > fro BGP on a Frame
> > Network:
> >
> >
> >
> > AS2
> > /
> > /
> > AS1 --------
> > \
> > \
> > AS3
> >
> > All sites are on a frame relay network and AS1 is
> > Multipoint and AS2 and AS3
> > are point-point to AS1.
> >
> > Do I need to use Next-hop self on AS1?AS2?AS3?
> >
> >
> > Ted Sanfilippo
> > Manager of Backbone Network Engineering
> >
> > PaeTec Communications
> > One PaeTec Plaza
> > 600 Willowbrook Office Park
> > Fairport, NY 14450
> >
> > Tel: 585-340-2722
> > Fax: 585-340-2786
> > Email: ted.sanfilippo@paetec.com
>
>
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Web Hosting - establish your business online
> http://webhosting.yahoo.com
This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:39 GMT-3