From: Wojciech.Gebka@ssk.com.pl
Date: Sun Mar 02 2003 - 14:37:08 GMT-3
You are using classfull protocol, so:
Router R2 send updates via primary s0 to R1 about its secondary s0 and
loopback like a class boundary network 128.10.0.0:
on R1:
RIP: received v1 update from 128.20.10.1 on Serial0/0
128.10.0.0 in 1 hops
R1 is doing likewise:
3d09h: RIP: sending v1 update to 255.255.255.255 via Serial0/0
(128.20.10.2)
3d09h: RIP: build update entries
3d09h: network 128.10.0.0 metric 1
Please look, that network 128.10.0.0 is advertising to interface Loopback
with metric 2:
3d09h: RIP: sending v1 update to 255.255.255.255 via Loopback10
(128.10.128.5)
3d09h: RIP: build update entries
3d09h: subnet 128.10.0.0 metric 2
3d09h: subnet 128.10.128.12 metric 2
3d09h: subnet 128.10.128.128 metric 1
3d09h: network 128.20.0.0 metric 1
The summary route is instaled in routing table with mask /30 because of
existing interface with address on subnet of that network (s0 secondary).
Regards
Wojtek
"Vadim Mikhailov" <vm@lukoil.ru>
Sent by: nobody@groupstudy.com
2003-03-02 15:41
Please respond to "Vadim Mikhailov"
To: <ccielab@groupstudy.com>
cc:
Subject: RIP and secondary
Hi group
i'm slightly confused with following RIP behaviour -
it installs prefix received over secondary address with wrong mask, and ,
as i understand, it should do this in such way. Is it correct?
R1-------------R2
R1:
router rip
network 128.10.0.0
network 128.20.0.0
interface Serial0/1
ip address 128.10.128.129 255.255.255.252 secondary
ip address 128.20.10.2 255.255.255.252
interface Loopback0
ip address 128.10.128.5 255.255.255.252
R2:
router rip
network 128.10.0.0
network 128.20.0.0
interface Loopback0
ip address 128.10.128.13 255.255.255.252
no ip directed-broadcast
interface Serial0
ip address 128.10.128.130 255.255.255.252 secondary
ip address 128.20.10.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
R1: sh ip route
128.10.0.0/30 is subnetted, 6 subnets
R 128.10.128.12 [120/1] via 128.10.128.130, 00:00:16, Serial0/1
C 128.10.128.4 is directly connected, Loopback0
R 128.10.0.0 [120/1] via 128.20.10.1, 00:00:16, Serial0/1
<---------------
C 128.10.128.128 is directly connected, Serial0/1
C 128.10.101.0 is directly connected, Serial0/0
128.20.0.0/30 is subnetted, 1 subnets
C 128.20.10.0 is directly connected, Serial0/1
R2: sh ip route
128.10.0.0/30 is subnetted, 6 subnets
C 128.10.128.12 is directly connected, Loopback0
R 128.10.128.4 [120/1] via 128.10.128.129, 00:00:18, Serial0
R 128.10.0.0 [120/1] via 128.20.10.2, 00:00:18, Serial0
<---------------
C 128.10.128.128 is directly connected, Serial0
C 128.10.10.12 is directly connected, Serial1
128.20.0.0/30 is subnetted, 1 subnets
C 128.20.10.0 is directly connected, Serial0
This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:30 GMT-3