From: Gery Pang (pang_gery@yahoo.com.hk)
Date: Sun Mar 02 2003 - 07:09:38 GMT-3
At last, I swap the calling and the called side, it works fine. The problem
may due to ios bug but I can't find it.
By the way, I found a bug said there will be problem if using dialer
watch-group 1.
My last config for the calling side follows:
interface BRI1/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 5101 5100
isdn spid2 5102 5100
no peer neighbor-route
no cdp enable
ppp authentication chap
interface Dialer0
ip address 172.16.224.6 255.255.255.0
encapsulation ppp
dialer pool 1
dialer remote-name R5-2621
dialer idle-timeout 30
dialer string 5200
dialer load-threshold 1 either
dialer watch-group 3
dialer-group 5
no fair-queue
ppp multilink
dialer watch-list 3 ip 172.16.5.0 255.255.255.0
The idle-timeout on the called side is set to 0.
Thank you.
Gery
----- Original Message -----
From: "Ouellette, Tim" <tim.ouellette@eds.com>
To: "'Gery Pang'" <pang_gery@yahoo.com.hk>
Sent: Sunday, March 02, 2003 1:23 PM
Subject: RE: dialer watch and dialer profile
> With physical Interfaces, you have to "map" the network that you are
> watching. But with dialer profiles, as they are point-to-point networks,
> there is no need to map them and just the dialer-watch will suffice.
> AFAIK..
>
> Tim
>
>
> -----Original Message-----
> From: Gery Pang [mailto:pang_gery@yahoo.com.hk]
> Sent: Saturday, March 01, 2003 10:56 PM
> To: OhioHondo
> Cc: ccielab
> Subject: Re: dialer watch and dialer profile
>
>
> Hondo,
>
> Thank you for your document. I am studying it and hope to produce a
working
> config.
>
> I have tried to use dialer map as you suggest, but cannot make it.
>
> R5-2621#ct
> Enter configuration commands, one per line. End with CNTL/Z.
> R5-2621(config)#int bri 0/0
> R5-2621(config-if)#dialer map ip 172.16.6.0 ?
> WORD Dialer string
> broadcast Broadcasts should be forwarded to this address
> class dialer map class
> modem-script Specify regular expression to select modem dialing script
> name Map to a host
> spc Semi Permanent Connections
> speed Set dialer speed
> system-script Specify regular expression to select system dialing
script
>
> R5-2621(config-if)#dialer map ip 172.16.6.0 broad ?
> WORD Dialer string
> broadcast Broadcasts should be forwarded to this address
> class dialer map class
> modem-script Specify regular expression to select modem dialing script
> name Map to a host
> spc Semi Permanent Connections
> speed Set dialer speed
> system-script Specify regular expression to select system dialing
script
> <cr>
>
> R5-2621(config-if)#dialer map ip 172.16.6.0 broad
> %Remove Dialer Profile Configuration first
> R5-2621(config-if)#exit
> R5-2621(config)#
>
> R5-2621(config)#
> R5-2621(config)#int dialer 0
> R5-2621(config-if)#dialer ?
> callback-secure Enable callback security
> called Specify called telephone number to be screened
> caller Specify calling telephone number to be screened
> enable-timeout Set length of time an interface stays down before
> it
> is available for dialing
> fast-idle Set idle time before disconnecting line with an
> unusually high level of contention
> hold-queue Configure output hold queue
> idle-timeout Specify idle timeout before disconnecting line
> in-band Set v.25bis dialing for interface
> load-threshold Specify threshold for placing additional calls
> max-call Specify maximum number of calls
> pool Specify dialer pool to be used
> redial Configure redial for this interface
> remote-name Configure a remote name
> rotor Set outbound rotor order
> snapshot Enable snapshot address for dialer profile
> string Specify telephone number to be passed to DCE
device
> vpdn Enable vpdn dial
> wait-for-carrier-time How long the router will wait for carrier
> watch-disable Time to wait before bringing down watched route
> link
> watch-group Assign interface to dialer-watch-list
>
> R5-2621(config-if)#dialer map ip 172.16.6.0 broad
> ^
> % Invalid input detected at '^' marker.
>
> R5-2621(config-if)#
>
>
> Gery
> ----- Original Message -----
> From: "OhioHondo" <ohiohondo@columbus.rr.com>
> To: "Gery Pang" <pang_gery@yahoo.com.hk>
> Sent: Sunday, March 02, 2003 11:21 AM
> Subject: RE: dialer watch and dialer profile
>
>
> > Gery
> >
> > It's possible in the dialer interface that you don't need to define
> "name",
> > dialer string", etc. in the dialer map statement because there are
> separate
> > commands for that. Try it out and let me know how it works.
> >
> > -----Original Message-----
> > From: Gery Pang [mailto:pang_gery@yahoo.com.hk]
> > Sent: Saturday, March 01, 2003 8:17 PM
> > To: OhioHondo
> > Subject: Re: dialer watch and dialer profile
> >
> >
> >
> > Thank you Hondo.
> >
> > I have tried to make the dialer map statement both in the dialer
interface
> > and the physical interface in the calling router, but not success.
> >
> > R5-2621#ct
> > Enter configuration commands, one per line. End with CNTL/Z.
> > R5-2621(config)#int bri 0/0
> > R5-2621(config-if)#dialer map ip 172.16.5.0 name R6-3640 broad 5100
> > %Remove Dialer Profile Configuration first
> > R5-2621(config-if)#int dialer 0
> > R5-2621(config-if)#dialer map ip 172.16.5.0 name R6-3640 broad 5100
> > ^
> > % Invalid input detected at '^' marker.
> >
> > R5-2621(config-if)#
> >
> > Am I doing something wrong?
> >
> > Thank you.
> >
> > Gery
> >
> >
> > ----- Original Message -----
> > From: "OhioHondo" <ohiohondo@columbus.rr.com>
> > To: "Gery Pang" <pang_gery@yahoo.com.hk>; <ccielab@groupstudy.com>
> > Sent: Sunday, March 02, 2003 12:50 AM
> > Subject: RE: dialer watch and dialer profile
> >
> >
> > > Gery
> > >
> > > Make the idle-timeout on the calling side something other than 0. This
> > sets
> > > the time for the check that the dialer does to see if the watched
routes
> > > returned. If the watched routes have returned the Dialer drops the
link.
> > If
> > > the watched routes have not returned, the idle timer resets and the
> routes
> > > are not checked again until it times out again.
> > >
> > > I believe that you need dialer map statements on the calling side.
These
> > map
> > > statements have to reference the "watched" routes otherwise the dialer
> > does
> > > not know what to check when the iidle timer times out.
> > >
> > > -----Original Message-----
> > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > > Gery Pang
> > > Sent: Saturday, March 01, 2003 9:50 AM
> > > To: ccielab@groupstudy.com
> > > Subject: dialer watch and dialer profile
> > >
> > >
> > > Hi Group,
> > >
> > > I have a question using dialer watch with dialer profile.
> > >
> > > Here is the config:
> > >
> > > The calling router:
> > >
> > > interface BRI0/0
> > > no ip address
> > > encapsulation ppp
> > > dialer pool-member 1
> > > isdn switch-type basic-ni
> > > isdn spid1 5201 5200
> > > isdn spid2 5202 5200
> > > ppp authentication chap
> > > ppp multilink
> > >
> > > interface Dialer0
> > > ip address 172.16.224.5 255.255.255.0
> > > encapsulation ppp
> > > ip ospf demand-circuit
> > > dialer pool 1
> > > dialer remote-name R6-3640
> > > dialer watch-disable 10
> > > dialer string 5100
> > > dialer watch-group 10
> > > pulse-time 0
> > >
> > >
> > > The called router:
> > >
> > >
> > > interface BRI1/0
> > > no ip address
> > > encapsulation ppp
> > > ip ospf demand-circuit
> > > dialer pool-member 1
> > > isdn switch-type basic-ni
> > > isdn spid1 5101 5100
> > > isdn spid2 5102 5100
> > > no peer neighbor-route
> > > no cdp enable
> > > ppp authentication chap
> > > ppp multilink
> > >
> > > interface Dialer0
> > > ip address 172.16.224.6 255.255.255.0
> > > encapsulation ppp
> > > dialer pool 1
> > > dialer remote-name R5-2621
> > > dialer idle-timeout 0
> > > dialer string 5200
> > > dialer load-threshold 1 either
> > >
> > > The idle-timer on called side is 0 to prevent it from dropping the
line.
> > But
> > > I
> > > found the calling side keep dropping the line when the idle timer pass
> and
> > > the
> > > line is up again because of dialer watch.
> > > If I set the idle timeout to 0, the line is not drop even the watched
> > route
> > > appear in the route table, even the watch-disable timer pass.
> > >
> > > The following is the sh dialer from the calling router, the routed
route
> > is
> > > in
> > > the route table.
> > >
> > > R5-2621#sh dialer
> > >
> > > BRI0/0 - dialer type = ISDN
> > >
> > > Dial String Successes Failures Last DNIS Last status
> > > 0 incoming call(s) have been screened.
> > > 0 incoming call(s) rejected for callback.
> > >
> > > BRI0/0:1 - dialer type = ISDN
> > > Idle timer (never), Fast idle timer (20 secs)
> > > Wait for carrier (30 secs), Re-enable (15 secs)
> > > Dialer state is multilink member
> > > Interface bound to profile Di0
> > > Current call connected 00:29:04
> > > Connected to 5100 (R6-3640)
> > >
> > > BRI0/0:2 - dialer type = ISDN
> > > Idle timer (never), Fast idle timer (20 secs)
> > > Wait for carrier (30 secs), Re-enable (15 secs)
> > > Dialer state is data link layer up
> > > Dial reason: Dialing on watched route loss
> > > Interface bound to profile Di0
> > > Current call connected 00:29:04
> > > Connected to 5100 (R6-3640)
> > >
> > > Di0 - dialer type = DIALER PROFILE
> > > Idle timer (never), Fast idle timer (20 secs)
> > > Wait for carrier (30 secs), Re-enable (15 secs)
> > > Dialer state is data link layer up
> > > Number of active calls = 2
> > >
> > > Dial String Successes Failures Last DNIS Last status
> > > 5100 15 0 00:29:12 successful
> > Default
> > >
> > > Thank you.
> > >
> > > Gery
> > >
> >
> > _________________________________________________________
> > 'Z*:E:6F(.e/*(`)!A%*>F%k(=('u'J6T)!A'A3L,u(Twins)...
> > 9L$d-:$b>w9aAn BIRing3#1o
> > http://ringtone.yahoo.com.hk
> >
> >
>
> _________________________________________________________
> 'Z*:E:6F(.e/*(`)!A%*>F%k(=('u'J6T)!A'A3L,u(Twins)...
> 9L$d-:$b>w9aAn BIRing3#1o
> http://ringtone.yahoo.com.hk
This archive was generated by hypermail 2.1.4 : Sat Apr 05 2003 - 08:51:30 GMT-3