Re: WRED

From: cannonr (cannonr@attbi.com)
Date: Sat Feb 22 2003 - 11:48:37 GMT-3


Try creating using a policy-map instead.

Create a class-map for each traffic type and match on ACL. Create a
policy-map that includes random-detect config for each class.
Service-policy output "X" on the interface.

ex.

class-map telnet
match ip address 100

class-map ftp
match ip address 101

class-map default-class
match any

access-list 100 permit any any eq telnet
access-list 101 permit any any eq 20
access-list 101 permit any any eq 21

policy-map class

class telnet
(wrr config here)
class ftp
(wrr config here)
class default-class
(wrr config here)

int s1
service-policy output class

Don't just cut and paste, this is off the top of my head.....

HTH
----- Original Message -----
From: "pita40" <pita40@hotmail.com>
To: <ccielab@groupstudy.com>
Sent: Saturday, February 22, 2003 7:48 AM
Subject: WRED

> I have a question.
> I am having difficulty matching WRED traffic based on Tcp port.
>
> Configure congestion aviodance on r5 s1 based on the following
information.
>
> 1) Telnet randomly dropped if queue is over 10 and completely dropped if
over
> 30
> 2) FTP randomly dropped if queue is over 10 and completely dropped if over
25
> 3) Rest of the traffic randomly dropped if queue is over 30 and
completely
> dropped if over 60
> 4) Drop probability is 1 in 20 packet
>
> I can configure the random-detect on the int. My problem is in traffic
> assignment.
>
>
>
>
> My config so far
>
> int s1
> random-detect
> random-detect precedence 0 10 30 20
> random-detect precedence 1 10 25 20
> random-detect precedence 2 30 60 20
>
> Pease help.
> THanks



This archive was generated by hypermail 2.1.4 : Sat Mar 01 2003 - 11:06:28 GMT-3