physical/sub-interface at hub. brodadcast/neighbor

From: Kumar, Senthil (senthil.kumar@intechnology.co.uk)
Date: Tue Feb 11 2003 - 04:19:13 GMT-3


i am running a frame-relay nbma non-broadcast mode.

should i use broadcast keyword in my frame-relay map statement
- i assume that you shouldn't use broadcast keyword for non-brodacast mode

do i need to define static neighbor at the hub. or in hub and spoke.

- i assume the hub needs static neighbor definition for both spokes.
and the spoke needs static neighbor definition for hub only...

h - spoke1
   --- spoke2

hub - physical (10.0.0.1)
spoke- sub-interface (10.0.0.2, 10.0.0.3)

hub:

conf t
interface serial 0/0
clock rate 64000
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
ip address 10.0.0.1 255.255.255.0
frame-relay map ip 10.0.0.2 102
frame-relay map ip 10.0.0.3 103
ip ospf network non-broadcast
!
router ospf 1
net 10.0.0.0 0.0.0.255 area 0
neig 10.0.0.2 (spoke1)
neig 10.0.0.3 (spoke2)
!

spoke:

conf t
interface serial0/0
clock rate 64000
encapsulation frame-relay
no arp frame-relay
no frame-relay inverse-arp
no ip address
!
int s0/0.1 point
ip add 10.0.0.2 255.255.255.0
frame-realy interface-dlci 201
ip ospf network non-broadcast
!
router ospf 1
net 10.0.0.0 0.0.0.255 area 0
nei 10.0.0.1 pri 10 (hub-only)
!

or the spoke can be configured with a multipoint sub interface

conf t

int s0/0
encap frame-relay
clock rate 64000
no arp frame-relay
no frame-relay inverse-arp
no ip address
int s0/0.1 multi
ip add 10.0.0.2 255.255.255.0
frame-relay map ip 10.0.0.1 201
frame-relay map ip 10.0.0.2 201
ip ospf network non-broadcast
!
router ospf 1
net 10.0.0.0 0.0.0.255 area 0
nei 10.0.0.1 (hub-only)
!

-- 

subinteface in hub, physical interface in spoke.

Hub:

Conf t ! Int serial 0/0 Clock rate 64000 Encap frame-relay No arp frame-relay No frame-relay inverse-arp No ip address ! Int serial 0/0.1 multipoint Ip add 10.0.0.1 255.255.255.0 Frame-relay map ip 10.0.0.2 102 Frame-relay map ip 10.0.0.3 103 Ip ospf network non-broadcast ! router ospf 1 net 10.0.0.1 0.0.0.255 area 0 nei 10.0.0.2 nei 10.0.0.3

spoke:

conf t ! int serial0/0 clockrate 64000 encap frame-relay no arp frame-relay no frame-relay inverse-arp ip add 10.0.0.2 255.255.255.0 frame-relay map ip 10.0.0.1 201 frame-relau map ip 10.0.0.3 201 ! -- steps configuring frame-relay

understand the physical topology

define clock-rate and encapsulation

configure interfaces accordingly (remember sub-interface type)

disable arp & inverse-arp if necessary

assign an ip address

remember not to use broadcast keyword for non-broadcast type remember not to use frame-relay

do frame-relay map (multipoint) or frame-relay interface-dlci (point2point)

define ospf network type

define static routing neighbors (if necessary)

enable the interface

test ip connectivity & test routing adjacency & updates.

-



This archive was generated by hypermail 2.1.4 : Sat Mar 01 2003 - 11:06:18 GMT-3