From: jim.phillipo@guardent.com
Date: Thu Jan 16 2003 - 22:16:17 GMT-3
I am doing lab 7 of NLI's bootcamp. I am attempting to use tagging instead
of the Admin distance used by the lab.
The Rip domain sees all the OSPF routes but OSPF sees none of the RIP
routes.
Am I missing a "gotcha" here ?
Here is one config:
!
hostname r3
!
!
!
!
!
!
ip subnet-zero
!
cns event-service server
!
!
!
interface Ethernet0
ip address 10.6.1.1 255.255.0.0
no sh
!
interface Ethernet1
no ip address
shutdown
!
interface Serial0
ip address 10.65.1.1 255.255.0.0
no fair-queue
no sh
!
interface Serial1
ip address 10.100.1.6 255.255.0.0
encapsulation frame-relay
ip ospf network point-to-point
clockrate 64000
frame-relay map ip 10.100.1.3 305 broadcast
frame-relay lmi-type ansi
no sh
!
router ospf 1
redistribute rip metric 50 subnets route-map rip_to_ospf
redistribute rip metric 50 subnets
network 10.6.1.1 0.0.0.0 area 6
network 10.100.1.6 0.0.0.0 area 0
!
router rip
version 2
timers basic 5 30 30 40
redistribute ospf 1 metric 2 match internal external 1 external 2 route-map
ospf_to_rip
passive-interface Ethernet0
passive-interface Serial1
network 10.0.0.0
!
ip classless
no ip http server
!
access-list 33 permit 10.51.0.0 0.0.255.255 RIP DOMAIN
access-list 33 permit 10.21.0.0 0.0.255.255
access-list 33 permit 10.65.0.0 0.0.255.255
access-list 34 permit 10.3.0.0 0.0.255.255 OSPF DOMAIN
access-list 34 permit 10.33.0.0 0.0.255.255
access-list 34 permit 10.101.0.0 0.0.255.255
access-list 34 permit 137.20.0.0 0.0.255.255
access-list 34 permit 10.6.0.0 0.0.255.255
access-list 34 permit 10.100.0.0 0.0.255.255
route-map rip_to_ospf deny 10
match tag 34
!
route-map rip_to_ospf permit 20
match ip address 33
set tag 33
!
route-map ospf_to_rip deny 10
match tag 33
!
route-map ospf_to_rip permit 20
match ip address 34
set tag 34
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
r3#
.
This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:51 GMT-3