BGP Synchronization Rule - changed in 12.0??

From: cebuano (cebu2ccie@cox.net)
Date: Wed Jan 15 2003 - 18:29:26 GMT-3


Hi group.
I'm trying to do this lab based on
http://www.cisco.com/univercd/cc/td/doc/cisintwk/ics/icsbgp4.htm#xtocid2
043946
This shows the need for the NEXT_HOP to be learned and advertised by
OSPF between RtrA and RtrB via RtrF.
RtrA and RtrB are iBGP peers, and in between is RtrF running only OSPF.
RtrA is advertising External BGP routes to RtrB, and to make the
preserved next-hop eBGP address reachable, we enable
OSPF to include the 128.213.0.0 network. This allows reachability of
this advertised next-hop from RtrB thus allowing
The BGP routes to be treated as "best".
 
The BGP synchronization behavior is described as.
Usually, a BGP speaker does not advertise a route to an external
neighbor unless that route is local or exists in the IGP. The no
synchronization command allows the Cisco IOS software to advertise a
network route without waiting for the IGP. This feature allows routers
and access servers within an autonomous system to have the route before
BGP makes it available to other autonomous systems.
For
reference.http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/product
s_command_reference_chapter09186a00800ca79e.html#1023361
 
My question is this.if synchronization is turned ON (default).even if
the BGP routes are learned via OSPF.BGP does not install them in its
routing table. Is this how synchronization affects iBGP peer
advertisements?
 
// with "synchronization" turned on...
 
MC3810b#sh ip bgp
BGP table version is 42, local router ID is 203.250.15.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network Next Hop Metric LocPrf Weight Path
* i128.213.0.0 128.213.63.2 0 100 0 200 i
* i192.208.10.0 128.213.63.2 100 0 200 400 500
300 i
* i195.211.10.0 128.213.63.2 100 0 200 400 500
i
* i200.200.10.0 128.213.63.2 100 0 200 400 i
* i203.250.13.0 203.250.13.41 0 100 0 i
* i203.250.14.0 203.250.13.41 0 100 0 i
*> 203.250.15.0 0.0.0.0 0 32768 i
 
MC3810b#ir
 
O E2 195.211.10.0/24 [210/2000] via 203.250.15.1, 00:00:41, Serial1
O E2 192.208.10.0/24 [210/2000] via 203.250.15.1, 00:00:41, Serial1
     203.250.15.0/30 is subnetted, 1 subnets
C 203.250.15.0 is directly connected, Serial1
     128.213.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2 128.213.0.0/16 [210/2000] via 203.250.15.1, 00:00:41, Serial1
O 128.213.63.0/30 [70/138] via 203.250.15.1, 00:06:34, Serial1
O 203.250.14.0/24 [70/74] via 203.250.15.1, 00:06:34, Serial1
     203.250.13.0/32 is subnetted, 1 subnets
O 203.250.13.41 [70/75] via 203.250.15.1, 00:06:35, Serial1
O E2 200.200.10.0/24 [210/2000] via 203.250.15.1, 00:00:42, Serial1
 
Synchronization must be turned OFF for this to work. I've adjusted the
E2 routes to Admin. Distance of 210 in order to see the BGP entry.
// with "synchronization" turned off...
 
MC3810b#sh ip bgp
BGP table version is 64, local router ID is 203.250.15.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network Next Hop Metric LocPrf Weight Path
*>i128.213.0.0 128.213.63.2 0 100 0 200 i
*>i192.208.10.0 128.213.63.2 100 0 200 400 500
300 i
*>i195.211.10.0 128.213.63.2 100 0 200 400 500
i
*>i200.200.10.0 128.213.63.2 100 0 200 400 i
*>i203.250.13.0 203.250.13.41 0 100 0 i
*>i203.250.14.0 203.250.13.41 0 100 0 i
*> 203.250.15.0 0.0.0.0 0 32768 i
 
MC3810b#ir
 
 
B 195.211.10.0/24 [200/0] via 128.213.63.2, 00:00:11
B 192.208.10.0/24 [200/0] via 128.213.63.2, 00:00:11
     203.250.15.0/30 is subnetted, 1 subnets
C 203.250.15.0 is directly connected, Serial1
     128.213.0.0/16 is variably subnetted, 2 subnets, 2 masks
B 128.213.0.0/16 [200/0] via 128.213.63.2, 00:00:11
O 128.213.63.0/30 [70/138] via 203.250.15.1, 00:08:23, Serial1
O 203.250.14.0/24 [70/74] via 203.250.15.1, 00:08:23, Serial1
     203.250.13.0/24 is variably subnetted, 2 subnets, 2 masks
O 203.250.13.41/32 [70/75] via 203.250.15.1, 00:08:25, Serial1
B 203.250.13.0/24 [200/0] via 203.250.13.41, 00:00:12
B 200.200.10.0/24 [200/0] via 128.213.63.2, 00:00:12
 
Below are the configurations.
 
RtrA
2511#s
!
interface Loopback10
 ip address 203.250.13.41 255.255.255.0
!
interface Ethernet0
 ip address 203.250.14.1 255.255.255.0
!
interface Serial0
 ip address 128.213.63.1 255.255.255.252
!
router ospf 10
 redistribute bgp 100 metric 2000 subnets
 passive-interface Serial0
 network 128.213.0.0 0.0.255.255 area 0
 network 203.250.0.0 0.0.255.255 area 0
!
router bgp 100
 network 203.250.13.0
 network 203.250.14.0
 neighbor 128.213.63.2 remote-as 200
 neighbor 203.250.15.2 remote-as 100
 neighbor 203.250.15.2 update-source Loopback0
!
 
RtrB
MC3810b#s
!
interface Ethernet0
 ip address 192.208.10.6 255.255.255.252
!
interface Serial1
 ip address 203.250.15.2 255.255.255.252
!
router ospf 10
 network 203.250.0.0 0.0.255.255 area 0
 distance ospf intra-area 70 inter-area 60 external 210
!
router bgp 100
 network 203.250.15.0
 neighbor 192.208.10.5 remote-as 300
 neighbor 203.250.13.41 remote-as 100
!
 
RtrF
MC3810a#s
!
interface Ethernet0
 ip address 203.250.14.2 255.255.255.0
!
interface Serial1
 ip address 203.250.15.1 255.255.255.252
!
router ospf 10
 network 203.250.0.0 0.0.255.255 area 0
!
 
Thanks.
Elmer
.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:50 GMT-3