isdn callback problem

From: frank.yu@japan.bnpparibas.com
Date: Wed Jan 15 2003 - 04:12:31 GMT-3


Group,

   I wonder any one had this problem before. two 2621 with version
12.1(17). R2 initialize the call, and R1 should callback. The following is
the config, which is not working. BUT if I turn on "debug dialer", it
works. Any ideas?
  Thanks in advance.

Frank

     Rack04R01#sh run
Building configuration...

Current configuration : 1404 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack04R01
!
!
username Rack04R02 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type ntt
!
!
!
interface Loopback0
 ip address 135.6.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 135.6.12.1 255.255.255.252
 duplex auto
 speed auto
!
interface BRI0/0
 ip address 135.6.21.1 255.255.255.0
 encapsulation ppp
 dialer callback-secure
 dialer idle-timeout 15
 dialer fast-idle 15
 dialer enable-timeout 5
 dialer map ip 135.6.21.2 name Rack04R02 class callback broadcast 0352051090
 dialer-group 1
 isdn switch-type ntt
 ppp callback accept
 ppp authentication chap
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip http server
!
map-class dialer callback
 dialer callback-server username
access-list 100 deny ospf any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
!
end

Rack04R01#

Rack04R02#sh run
Building configuration...

Current configuration : 1476 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Rack04R02
!
!
username Rack04R01 password 0 cisco
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type ntt
!
!
!
!
!
interface Loopback0
 ip address 135.6.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface FastEthernet0/0
 ip address 135.6.12.2 255.255.255.252
 duplex auto
 speed auto
!
interface BRI0/0
 ip address 135.6.21.2 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 15
 dialer fast-idle 15
 dialer wait-for-carrier-time 10
 dialer watch-disable 20
 dialer map ip 135.6.12.0 name Rack04R01 broadcast 0352050189
 dialer map ip 135.6.21.1 name Rack04R01 broadcast 0352051089
 dialer watch-group 1
 dialer-group 1
 isdn switch-type ntt
 ppp callback request
 ppp authentication chap
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
ip http server
!
access-list 100 deny ospf any any
access-list 100 permit ip any any
dialer watch-list 1 ip 135.6.12.0 255.255.255.252
dialer-list 1 protocol ip list 100
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 exec-timeout 0 0
 privilege level 15
 no login
!
end

Rack04R02#

Rack04R02#ping 135.6.21.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 135.6.21.1, timeout is 2 seconds:

01:55:36527483164: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:55:08: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 0352050189 Ra.
01:55:34359738372: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down....
Success rate is 0 percent (0/5)
Rack04R02#ping 135.6.21.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 135.6.21.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Rack04R02#deb dialer
Dial on demand events debugging is on
Rack04R02#ping 135.6.21.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 135.6.21.1, timeout is 2 seconds:

01:55:53: BR0/0 DDR: Dialing cause ip (s=135.6.21.2, d=135.6.21.1)
01:55:53: BR0/0 DDR: Attempting to dial 0352051089
01:55:229795347888: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:55:53: BR0/0:1 DDR: Callback negotiated - Disconnecting now
01:55:53: BR0/0:1 DDR: disconnecting call
01:55:53: DDR: Dialer Watch: watch-group = 1
01:55:53: DDR: network 135.6.12.0/255.255.255.252 UP,
01:55:53: DDR: primary UP
01:55:53: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 0352050189 Ra1
01:55:227633266692: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to down
01:55:227633266688: DDR: Callback client for Rack04R01 0352050189 created
01:55:227633266696: BR0/0:1 DDR: disconnecting call
01:55:227633266688: DDR: Dialer Watch: watch-group = 1
01:55:227633266688: DDR: network 135.6.12.0/255.255.255.252 UP,
01:55:227674170179: DDR: primary UP...
01:55:58: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state to up
01:55:59: BR0/0:1 DDR: Callback received from Rack04R01 0352050189
01:55:59: DDR: Freeing callback to Rack04R01 0352050189
01:55:59: BR0/0:1 DDR: dialer protocol up
01:56:00: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0/0:1, changed sta!
Success rate is 20 percent (1/5), round-trip min/avg/max = 40/40/40 ms
Rack04R02#ping 135.6.21.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 135.6.21.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/41/44 ms
Rack04R02#
01:56:02: %OSPF-5-ADJCHG: Process 110, Nbr 135.6.2.2 on BRI0/0 from LOADING to e
01:56:04: %ISDN-6-CONNECT: Interface BRI0/0:1 is now connected to 0352050189 Ra1

This message and any attachments (the "message") is
intended solely for the addressees and is confidential.
If you receive this message in error, please delete it and
immediately notify the sender. Any use not in accord with
its purpose, any dissemination or disclosure, either whole
or partial, is prohibited except formal approval. The internet
can not guarantee the integrity of this message.
BNP PARIBAS (and its subsidiaries) shall (will) not
therefore be liable for the message if modified.

                ---------------------------------------------

Ce message et toutes les pieces jointes (ci-apres le
"message") sont etablis a l'intention exclusive de ses
destinataires et sont confidentiels. Si vous recevez ce
message par erreur, merci de le detruire et d'en avertir
immediatement l'expediteur. Toute utilisation de ce
message non conforme a sa destination, toute diffusion
ou toute publication, totale ou partielle, est interdite, sauf
autorisation expresse. L'internet ne permettant pas
d'assurer l'integrite de ce message, BNP PARIBAS (et ses
filiales) decline(nt) toute responsabilite au titre de ce
message, dans l'hypothese ou il aurait ete modifie.
.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:49 GMT-3