From: Brian McGahan (brian@cyscoexpert.com)
Date: Sun Jan 12 2003 - 18:21:54 GMT-3
Solomon,
WRED uses IP precedence values to determine the drop probability
of particular traffic. By default, all IP traffic has an IP precedence
of 0. If you do not tag any of the traffic manually, WRED behaves as
RED, or just random early detect. The difference between WRED and RED
is that when using WRED, traffic with a higher IP precedence value is
less likely to be marked for drop. With RED, all traffic is just as
likely to be marked for drop.
There are multiple ways to set the IP precedence values in
traffic. Two common ways are through policy routing and committed
access rate. Traffic coloring with policy routing or CAR is used on the
ingress edge of your network, while WRED is used in the transit path to
manage the traffic. Take the following example
HostA--| ________
| ( )
|--R1--( IP Cloud )
(________)
HostA sits on R1's Ethernet segment, and is sending various
different types of traffic into the IP cloud. CAR and policy routing
will be used on R1's Ethernet interface to tag traffic being generated
by HostA. WRED will be used on the Serial interface connected to the IP
Cloud to manage the egress traffic into the cloud.
The following would be two different methods to mark all telnet
traffic with an IP precedence of "critical". Also, this critical
traffic will have a minimum queue size of 40, a maximum queue size of
60, and a mark probability of 1/20. All other traffic classes are left
as default.
!
! Setting IP Precedence via CAR
!
access-list 100 permit tcp any any eq telnet
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
rate-limit input access-group 100 8000 1500 3000 conform-action
set-prec-transmit 5 exceed-action set-prec-transmit 5
!
! Since the conform and exceed actions are the same,
! the bps, burst, and excess burst values are arbitrary
!
interface Serial0
ip address 1.0.0.1 255.255.255.252
random-detect
random-detect precedence 5 40 60 20
!
!
! Setting IP Precedence via policy routing
!
access-list 100 permit tcp any any eq telnet
!
route-map IP_PRECEDENCE permit 10
match ip address 100
set ip precedence critical
!
route-map IP_PRECEDENCE permit 20
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip policy route-map IP_PRECEDENCE
!
interface Serial0
ip address 1.0.0.1 255.255.255.252
random-detect
random-detect precedence 5 40 60 20
!
For more information:
"Classification Overview"
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configur
ation_guide_chapter09186a00800c60da.html
"Congestion Avoidance Overview"
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configur
ation_guide_chapter09186a00800c60d9.html
"Configuring Weighted Random Early Detection"
http://www.cisco.com/en/US/products/sw/iosswrel/ps1831/products_configur
ation_guide_chapter09186a00800c60c0.html
HTH
Brian McGahan, CCIE #8593
Director of Design and Implementation
brian@cyscoexpert.com
CyscoExpert Corporation
Internetwork Consulting & Training
Voice: 847.674.3392
Fax: 847.674.2625
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Solomon Ghebremariam
> Sent: Sunday, January 12, 2003 2:09 PM
> To: Scott Morris
> Cc: 'pita40'; ccielab@groupstudy.com
> Subject: RE: WRED
>
> Scott
> So this means using class to match the traffic of interest and
> applying the WRED parameters won't work?
>
> Ex.
> Class-map WRED_TELNET
>
> match ip address 142
>
> access-list 142 permit tcp any any eq telnet
>
> Policy-map DROP_TELNET
> class WRED_TELNET
> bandwidth 2048
> random-detect flow
>
> random-detect flow average-depth-factor 20
> random-detect flow count 40
>
> and applying service policy DROP_TELNET to the interface??? or I am
off
> base here?
> What is the best way of applying WRED to a specific traffic type?
>
> solomon
>
> At 11:15 AM 1/12/2003 -0500, Scott Morris wrote:
>
> There are a couple different ways to do it, but the bottom line is
> that
> you classify your traffic before deciding how to handle it.
>
> For example, set up a CBWFQ and one queue deals with telnet traffic.
> Within this queue you use random-detect with the parameters you have
> mentioned.
>
> Another way is to mark the traffic on ingress perhaps even with
> policy
> routing. Set a DSCP tag onto the traffic. Then use random-detect
> dscp
> with the values you have listed on the egress point.
>
> AFAIK, there isn't an ACL parameter on any of the random-detect
> command
> lines.
>
> Enjoy!
>
> Scott
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of
> pita40
> Sent: Sunday, January 12, 2003 10:11 AM
> To: ccielab@groupstudy.com
> Subject: WRED
>
> I am trying to configure WRED. I can configure WRED based on
> precedence
> but I am having difficulty finding in CCO how to configure based on
> different types of ip traffic.
>
> For example.
>
> Configure WRED so that telnet traffic will be randomly dropped if
> queue
> lenght is over 20 and completely droped if over 40
>
> I am having proble with specify telnet traffic in the configuration.
> Please help. .
> .
> .
.
This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:47 GMT-3