Re: Conditional Advertisement

From: John Underhill (stepnwlf@magma.ca)
Date: Sat Jan 11 2003 - 16:57:27 GMT-3


In EIGRP I think you could just use something like this..
Advertise default information and use access-list to match BGP network, then
if route is withdrawn, default should disapear from neighbors table..
Like so..

router eigrp 100
 redistribute bgp 200 metric 10000 1000 254 1 1500 route-map REDISBGP
 passive-interface default
 no passive-interface Serial0
 network 12.1.1.0 0.0.0.255
 default-information out 2 <-- not sure what acl is doing here, defining
route or neighbors?
 distance 171 0.0.0.1 255.255.255.0 1
 no auto-summary
 no eigrp log-neighbor-changes

router bgp 200
 no synchronization
 bgp log-neighbor-changes
 neighbor 150.50.17.1 remote-as 100
 distance 171 0.0.0.1 255.255.255.0 2
 no auto-summary

access-list 2 permit 10.1.1.0 0.0.0.255

route-map REDISBGP permit 10
 match ip address 2

Then redist the BGP route into EIGRP with the lower distance. When BGP route
is in EIGRP table, it gets advertised as via the access-list entry, if route
is absent, no default route. Haven't tested it yet, might work..

----- Original Message -----
From: "Cameron, John" <johcamer@cisco.com>
To: "'John Underhill'" <stepnwlf@magma.ca>; "'Sage Vadi'"
<sagevadi@yahoo.co.uk>; <ccielab@groupstudy.com>
Sent: Saturday, January 11, 2003 2:07 PM
Subject: RE: Conditional Advertisement

> This is the same train of thought that I had
> but he sent me an e-mail that said he wanted
> to use EIGRP as the IGP and I'm not sure their
> is something similar in eigrp.
>
> JDC
>
>
> -----Original Message-----
> From: John Underhill [mailto:stepnwlf@magma.ca]
> Sent: Saturday, January 11, 2003 1:59 PM
> To: Cameron, John; 'Sage Vadi'; ccielab@groupstudy.com
> Subject: Re: Conditional Advertisement
>
>
> Not sure if this is what you are looking for, but..
> Here's a config, I had to modify the distance of that route into the
> ospf/bgp router, redistribute the one route, then conditional default. Now
> when this route shows up in ospf table, default route is advertised to
ospf
> neighbors..
>
> router ospf 100
> log-adjacency-changes
> redistribute bgp 200 metric 3 subnets route-map REDISBGP
> network 12.1.1.0 0.0.0.255 area 0
> default-information originate route-map CONNECTED
> !
> router bgp 200
> no synchronization
> bgp log-neighbor-changes
> neighbor 150.50.17.1 remote-as 100
> distance 121 0.0.0.1 255.255.255.0 1
> no auto-summary
> !
> access-list 1 permit 10.1.1.0 0.0.0.255
> !
> route-map REDISBGP permit 10
> match ip address 1
> !
> route-map CONNECTED permit 10
> match ip address 1
>
> ----- Original Message -----
> From: "Cameron, John" <johcamer@cisco.com>
> To: "'Sage Vadi'" <sagevadi@yahoo.co.uk>; <ccielab@groupstudy.com>
> Sent: Saturday, January 11, 2003 11:44 AM
> Subject: RE: Conditional Advertisement
>
>
> > Sage,
> >
> > What IGP are you using?
> >
> > JDC
> >
> >
> > -----Original Message-----
> > From: Sage Vadi [mailto:sagevadi@yahoo.co.uk]
> > Sent: Saturday, January 11, 2003 6:50 AM
> > To: Ouellette, Tim; ccielab@groupstudy.com
> > Subject: RE: Conditional Advertisement
> >
> >
> > Tim,
> >
> > I believed you missed this line in my email -
> >
> > "NB: the ATM cloud is NOT running BGP."
> >
> > What I am trying to do is receive a route from a
> > neighbor and then activate a default-route into my ATM
> > network.
> >
> > To clarify, I will rephrase:
> >
> > BGP---R5----IGP(ATM)----R6
> >
> > R5 has a BGP route, when it has this route I want it
> > to send a default-route into the ATM network.
> >
> > Q) How can I achieve this?
> >
> > I'm not sure even if this is possible, but I believe
> > it is.
> >
> > Thanks anyway =)
> >
> > Cheers,
> > Sage
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Everything you'll ever need on one web page
> > from News and Sport to Email and Music Charts
> > http://uk.my.yahoo.com
> > .
> > .
.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:47 GMT-3