PAM question

From: Jeff Ryan (jryan@wamnet.com)
Date: Wed Jan 08 2003 - 14:52:42 GMT-3


Anyone experienced using PAM? I'm trying to help a buddy out. Basically
he wants to allow external users (from home) to come into his network
and NAT to one address using multiple ports and to be able to use the
VNC application. I don't have this IOS loaded and would appreciate any
pointers.

Thanks,
Jeff

Here's the existing config that works for two hosts right now. He would
like to keep his existing public addresses.

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Lindsay
!
boot system flash 1:aaa1313.bin
enable password 7 143B430508512B32
!
!
!
!
!
memory-size iomem 12
ip subnet-zero
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Loopback0
 ip address x.x.x.153 255.255.255.248
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 10.16.247.201 255.255.255.0
 ip helper-address 10.16.247.188
 no ip directed-broadcast
 ip nat inside
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no fair-queue
 service-module t1 timeslots 1-24
 frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ip nat outside
 frame-relay interface-dlci 500 IETF
!
ip nat pool Lindsay x.x.x.154 x.x.x.156 netmask 255.255.255.248
ip nat inside source list 10 pool Lindsay overload
ip nat inside source static 10.16.247.206 x.x.x.157
ip nat inside source static 10.16.247.188 x.x.x.158
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0.1
no ip http server
!
access-list 10 permit 10.16.247.0 0.0.0.255
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password 7 062A5E2F481B0800
 login
!
end

****************************************
Jeff Ryan CCNP, CCDP
Design & Engineering Group
WAM!NET Government Services
Office: 703-736-4083
Mobile: 301-675-7344
email: jryan@wamnet.com
****************************************
.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:45 GMT-3