From: kym blair (kymblair@hotmail.com)
Date: Sat Jan 04 2003 - 18:54:16 GMT-3
Jay,
Disable inverse-arp and include a map statement for your own IP (works with
physical interface or point-to-multipoint subinterface); it doesn't matter
which DLCI you select for yourself, but it must be an active DLCI for this
interface (i.e., used for one of your neighbors):
R6 (hub)
interface Serial1.2 multipoint
ip address 172.16.100.6 255.255.255.224
frame-relay map ip 172.16.100.3 106 broadcast
frame-relay map ip 172.16.100.5 105 broadcast
frame-relay map ip 172.16.100.6 106 broadcast
no frame-relay inverse-arp
R3 (spoke)
interface Serial0
ip address 172.16.100.3 255.255.255.224
encapsulation frame-relay
frame-relay map ip 172.16.100.3 601 broadcast
frame-relay map ip 172.16.100.5 601 broadcast
frame-relay map ip 172.16.100.6 601 broadcast
no frame-relay inverse-arp
R5 (spoke)
interface Serial0
ip address 172.16.100.5 255.255.255.224
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 172.16.100.3 501 broadcast
frame-relay map ip 172.16.100.5 501 broadcast
frame-relay map ip 172.16.100.6 501 broadcast
no frame-relay inverse-arp
-----------------------
For point-to-point subint, you must stay with inverse-arp (will be able to
ping self):
R6
interface Serial1.1 point-to-point
ip address 172.16.146.6 255.255.255.240
frame-relay interface-dlci 104
R14
interface Serial0/0
ip address 172.16.146.14 255.255.255.240
encapsulation frame-relay
frame-relay map ip 172.16.146.6 401 broadcast
frame-relay map ip 172.16.146.14 401 broadcast
no frame-relay inverse-arp
--------------------------------------------
Two important points:
(1) always include the "broadcast" keyword
(2) After you have your frame map statements installed and the interfaces
"no shut", make sure you haven't mapped any unwanted DLCIs: "show frame map"
If there are any "0.0.0.0" mappings, you should reboot your routers and let
them come up clean. Actually, you should reboot the routers anyway so
inverse-arp gets disabled. You want to find frame-relay problems early
before you layer all the IGP, BGP, IP Services, etc on top.
HTH, Kym
>From: Jay Greenberg <groupstudylist@execulink.com>
>Reply-To: Jay Greenberg <groupstudylist@execulink.com>
>To: ccielab@groupstudy.com
>Subject: A Frame Relay router cannot ping itself?
>Date: 04 Jan 2003 13:09:41 -0500
>
>Does anyone know how to allow a router with a frame-relay interface to
>be able to ping it's own FR interface? This would make my ping tests
>run a lot smoother.
>.
This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:41 GMT-3