FW: Snapshot and Dialer interface

From: Ouellette, Tim (tim.ouellette@eds.com)
Date: Thu Jan 02 2003 - 22:14:25 GMT-3


You know, I had a wierd problem like that. Is the problem that your spoke
site is not advertising any networks to your hub site? I tried debugging
the rip routes on the hub to see why the spoke wasn't hearing about network
3.0.0.0/8 from the hub. It was only when the spoke site actually advertised
something that the hub also advertised it's rip routes.

R2----DDR-----R3

r2 is the client and r3 is the server.

BTW, you don't just have to use physical interfaces, you can use dialer
profiles, you just don't use

Below is the debugging on r3(server). R3 was not sending anything across
the dialer (supressing null update) until the spoke site (r2) actually
advertised something (after I created a loopback and added it to r2's rip
table)

00:15:20: SNAPSHOT: Dialer1[1]: Avoiding active: in client post
active->active q
ueue (Dial connection set)

00:21:32: RIP: sending v1 flash update to 255.255.255.255 via Dialer1
(192.168.1
.3)
00:21:32: RIP: build flash update entries - suppressing null update
<-------------NOT WORKING!!
00:21:32: RIP: sending v1 flash update to 255.255.255.255 via Loopback0
(3.3.3.3
)
00:21:32: RIP: build flash update entries
00:21:32: network 2.0.0.0 metric 2 <-----r3
hears about 2.0.0.0 from r2
00:21:35: RIP: sending v1 update to 255.255.255.255 via Dialer1
(192.168.1.3)
00:21:35: RIP: build update entries
00:21:35: network 3.0.0.0 metric 1 <---- r3
then advertises the network to r2
00:21:35: RIP: sending v1 update to 255.255.255.255 via Loopback0 (3.3.3.3)
00:21:35: RIP: build update entries
00:21:35: network 2.0.0.0 metric 2
00:21:35: network 192.168.1.0 metric 1
00:21:36: RIP: received v1 update from 192.168.1.2 on Dialer1
00:21:36: 2.0.0.0 in 1 hops
r3#

Below is the working configs using dialer profiles (snipped to save space).
The key is that when you use physical interfaces, you use the "dialer map
snapshot" but with dialer profiles you have to use the "dialer snapshot"
command to tell it to do snapshot.

----------------R3 - server-----------------------------------
[Resuming connection 3 to r3 ... ]

<snip>
logging buffered 10000 debugging
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 0835868301 8358683
 isdn spid2 0835868401 8358684
!
interface Dialer1
 ip address 192.168.1.3 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name r2
 dialer string 8358681
 dialer snapshot
 dialer-group 1
 snapshot server 5 dialer
 no peer neighbor-route
!
router rip
 network 3.0.0.0
 network 192.168.1.0
!
dialer-list 1 protocol ip permit
!

---------------------------r2 snapshot client------------------------

hostname r2
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 0835868101 8358681
 isdn spid2 0835868201 8358682
!
interface Dialer1
 ip address 192.168.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name r3
 dialer string 8358683
 dialer snapshot
 dialer-group 1
 snapshot client 5 10 dialer
 no peer neighbor-route
!
router rip
 network 2.0.0.0
 network 192.168.1.0
!
ip classless
no ip http server
!
dialer-list 1 protocol ip permit
!

Lemme know if there is any issues.

Tim

-----Original Message-----
From: cebuano [mailto:cebu2ccie@cox.net]
Sent: Tuesday, December 31, 2002 11:09 PM
To: ccielab@groupstudy.com
Subject: Snapshot and Dialer interface

Hi all.
Does anyone have a link/info on why snapshot routing only works with
PHYSICAL interfaces? I tried it on DIALER interface and although the
link is brought up, no RIP networks get advertised. I know that you
don't have the "dialer map" capability under a DIALER interface, even
though the IOS allows you to configure a snapshot client/server under
this virtual interface.
My test config are as follows.
TIA.
 
2503#s
!
hostname 2503
!
username london password 0 cisco
!
isdn switch-type basic-ni
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 no ip mroute-cache
 no keepalive
!
interface BRI0
 no ip address
 encapsulation ppp
 no ip mroute-cache
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 0835866101 8358661
 isdn spid2 0835866301 8358663
 ppp authentication chap
 ppp chap hostname tokyo
 ppp multilink
!
interface Dialer0
 ip address 172.16.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer string 8358662
 dialer load-threshold 1 outbound
 dialer-group 1
 snapshot client 5 8 dialer
!
router rip
 network 10.0.0.0
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
 
 
2504#s
!
hostname 2504
!
username tokyo password 0 cisco
!
isdn switch-type basic-ni
!
interface TokenRing0
 ip address 20.20.20.1 255.255.255.0
 ring-speed 16
!
interface BRI0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 0835866201 8358662
 isdn spid2 0835866401 8358664
 ppp authentication chap
 ppp chap hostname london
 ppp multilink
!
interface Dialer0
 ip address 172.16.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer string 8358661
 dialer load-threshold 1 outbound
 dialer-group 1
 snapshot server 5 dialer
!
router rip
 network 20.0.0.0
 network 172.16.0.0
!
dialer-list 1 protocol ip permit
!
.
.



This archive was generated by hypermail 2.1.4 : Sat Feb 01 2003 - 07:33:39 GMT-3