RE: RIP neighbors

From: Jake Jake (spage@nc.rr.com)
Date: Sun Dec 22 2002 - 21:36:28 GMT-3


rip v1 is classful, it will only advertise networks that have same subnet
mask as the interface it is being advertised out, same for receiving routes.
You can either change to rip v2, or put a secondary address on the serial
interfaces that have /24 mask with in the same class b network.

Jake

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Jason Cash
Sent: Sunday, December 22, 2002 7:02 PM
To: ccielab@groupstudy.com
Subject: RIP neighbors

Thought this would be simple but apparently not! Just trying to set up
RIP b/w two routers and it just won't happen. How am I making this
difficult?

R5 (s1) --- R3 (s1)

R5
interface Loopback0
 ip address 153.1.105.1 255.255.255.0
!
interface Ethernet0
 ip address 162.1.1.1 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 shutdown
!
interface Serial0
 no ip address
 no ip route-cache
 no ip mroute-cache
 shutdown
!
interface Serial1
 ip address 153.1.53.68 255.255.255.224
 no ip route-cache
 no ip mroute-cache
 clockrate 500000
!
router rip
 network 153.1.0.0
!
ip classless
no ip http server
!
!
alias exec shi sh ip int brief
!
line con 0
 exec-timeout 60 0
line aux 0
 transport input all
line vty 0 4
 password cisco
 login
!
end

R3
interface Loopback0
 ip address 153.1.103.1 255.255.255.0
!
interface Ethernet0
 ip address 153.1.43.33 255.255.255.128
 no ip route-cache
 no ip mroute-cache
!
interface Serial0
 ip address 153.1.200.3 255.255.255.0
 encapsulation frame-relay
 no ip route-cache
 no ip mroute-cache
!
interface Serial1
 ip address 153.1.53.67 255.255.255.224
 no ip route-cache
 no ip mroute-cache
!
router rip
 network 153.1.0.0
!
ip kerberos source-interface any
ip classless
no ip http server

Here is the deb ip rip output from R5

r5#deb ip rip
RIP protocol debugging is on
r5#clear ip ro *
r5#
04:27:38: RIP: sending request on Serial1 to 255.255.255.255
04:27:38: RIP: sending request on Loopback0 to 255.255.255.255
04:27:39: RIP: sending v1 update to 255.255.255.255 via Loopback0
(153.1.105.1)
04:27:39: RIP: build update entries - suppressing null update
04:27:39: RIP: sending v1 update to 255.255.255.255 via Serial1
(153.1.53.68)
04:27:39: RIP: build update entries - suppressing null update
04:27:40: RIP: sending v1 flash update to 255.255.255.255 via Loopback0
(153.1.105.1)
04:27:40: RIP: build flash update entries - suppressing null update
04:27:40: RIP: sending v1 flash update to 255.255.255.255 via Serial1
(153.1.53.68)
04:27:40: RIP: build flash update entries - suppressing null update
.
.



This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:51 GMT-3