From: kym blair (kymblair@hotmail.com)
Date: Wed Dec 18 2002 - 06:05:41 GMT-3
John,
On R2, the client, set your enable-timeout to about 5 seconds, and on R5,
the server, add "dialer wait-for-carrier" of 10 or 11 seconds (at least
double the client's enable-timeout.
HTH, Kym
>From: "John Tafasi" <johntafasi@yahoo.com>
>Reply-To: "John Tafasi" <johntafasi@yahoo.com>
>To: "Cisco Group Study" <cisco@groupstudy.com>, "ccielab"
><ccielab@groupstudy.com>
>Subject: Isdn callback problem
>Date: Wed, 18 Dec 2002 00:54:27 -0700
>
>Hi group,
>
>I have r2 which is configured to request callback from r5. The problem is
>that r2 does not wait for r5 to callback and will repeat the calling r5 and
>request callback. However r5 will eventually succeed and callback r2. My
>question is how can you prevent r2 from repeating the call to r5? I have
>pasted below the configuration for both routers and the output of "debug
>isdn q931" and "debug ppp authentication" on r2.
>
>
>r2#show run
> !
>version 11.3
> !
>hostname r2
>!
> username r5 password 7 13061E010803
>ip subnet-zero
>no ip domain-lookup
>isdn switch-type basic-ni1
>!
> !
>interface BRI0
> no ip address
> no ip directed-broadcast
> encapsulation ppp
> dialer pool-member 1
> isdn spid1 0835866101
> isdn spid2 0835866301
> ppp callback request
>!
>interface Dialer1
> ip address 10.10.10.1 255.255.255.0
> no ip directed-broadcast
> encapsulation ppp
> dialer remote-name r5
> dialer enable-timeout 1000
> dialer string 8358662
> dialer hold-queue 100 timeout 30
> dialer pool 1
> dialer-group 1
> ntp broadcast
> pulse-time 0
> ppp authentication chap
>!
> !
>map-class dialer eng
>access-list 1 deny any
>access-list 100 permit tcp any any eq telnet
>access-list 100 permit icmp any any
>dialer-list 1 protocol ip list 100
>!
>line con 0
> exec-timeout 0 0
> logging synchronous
> transport input none
>line aux 0
>line vty 0 4
> exec-timeout 0 0
> password 7 06101B38
> login
> telnet break-on-ip
> telnet ip-on-break
>!
>ntp clock-period 17179853
>end
>
>r2#
>
>=================
>
>r5#show run
> version 12.2
>!
>hostname r5
> username r2 password 7 045802150C2E
> no ip domain-lookup
>!
> isdn switch-type basic-ni
>!
>!
>!
>!
> !
>interface BRI0
> ip address 10.10.10.2 255.255.255.0
> encapsulation ppp
> dialer callback-secure
> dialer map ip 10.10.10.1 name r2 class eng broadcast 8358661
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 0835866201
> isdn spid2 0835866401
> cdapi buffers regular 0
> cdapi buffers raw 0
> cdapi buffers large 0
> ppp callback accept
> ppp authentication chap
> ppp chap hostname r5
>!
> !
>map-class dialer eng
> dialer callback-server username
> access-list 100 permit tcp any any eq telnet
>access-list 100 permit icmp any any
>dialer-list 1 protocol ip list 100
>!
>!
>line con 0
> exec-timeout 0 0
> logging synchronous
> transport input none
>line aux 0
>line vty 0 4
> password 7 045802150C2E
> login
> autocommand access-enable host timeout 5
>!
>ntp clock-period 17179628
>ntp master 4
>ntp peer 10.10.110.16
>end
>
>r5#
>
>==============
>r2#show debug
>ISDN:
> ISDN Q931 packets debugging is on
>r2#debu ppp authen
>PPP authentication debugging is on
>r2#
>r2#ping 10.10.10.2
>
>Type escape sequence to abort.
>Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
>.....
>Success rate is 0 percent (0/5)
>r2#
>.Mar 2 11:01:03.477: ISDN BR0: TX -> SETUP pd = 8 callref = 0x04
>.Mar 2 11:01:03.481: Bearer Capability i = 0x8890
>.Mar 2 11:01:03.485: Channel ID i = 0x83
>.Mar 2 11:01:03.485: Keypad Facility i = '8358662'
>.Mar 2 11:01:03.529: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x84
>.Mar 2 11:01:03.529: Channel ID i = 0x89
>.Mar 2 11:01:03.681: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x84
>.Mar 2 11:01:03.693: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
>.Mar 2 11:01:03.721: %DIALER-6-BIND: Interface BRI0:1 bound to profile
>Dialer1
>.Mar 2 11:01:03.733: BR0:1 PPP: Treating connection as a callout
>.Mar 2 11:01:03.733: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x04
>.Mar 2 11:01:05.797: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
>.Mar 2 11:01:07.653: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
>.Mar 2 11:01:07.673: BR0:1 CHAP: I CHALLENGE id 195 len 23 from "r5"
>.Mar 2 11:01:07.681: BR0:1 CHAP: O RESPONSE id 195 len 23 from "r2"
>.Mar 2 11:01:07.705: BR0:1 CHAP: I SUCCESS id 195 len 4
>.Mar 2 11:01:07.769: %LINEPROTO-5-UPDOWN: Line protocol on Interface
>BRI0:1, changed state to up
>.Mar 2 11:01:07.777: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x84
>.Mar 2 11:01:07.777: Cause i = 0x8090 - Normal call clearing
>.Mar 2 11:01:07.797: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected
>from 8358662 , call lasted 4 seconds
>.Mar 2 11:01:07.801: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
>down
>.Mar 2 11:01:07.833: %DIALER-6-UNBIND: Interface BRI0:1 unbound from
>profile Dialer1
>.Mar 2 11:01:07.837: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x04
>.Mar 2 11:01:07.857: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x84
>.Mar 2 11:01:08.773: %LINEPROTO-5-UPDOWN: Line protocol on Interface
>BRI0:1, changed state to down
>.Mar 2 11:01:09.477: ISDN BR0: TX -> SETUP pd = 8 callref = 0x05
>.Mar 2 11:01:09.481: Bearer Capability i = 0x8890
>.Mar 2 11:01:09.481: Channel ID i = 0x83
>.Mar 2 11:01:09.485: Keypad Facility i = '8358662'
>.Mar 2 11:01:09.525: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x85
>.Mar 2 11:01:09.529: Channel ID i = 0x89
>.Mar 2 11:01:09.689: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x85
>.Mar 2 11:01:09.705: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
>.Mar 2 11:01:09.733: %DIALER-6-BIND: Interface BRI0:1 bound to profile
>Dialer1
>.Mar 2 11:01:09.741: BR0:1 PPP: Treating connection as a callout
>.Mar 2 11:01:09.745: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x05
>.Mar 2 11:01:11.809: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
>.Mar 2 11:01:13.657: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
>.Mar 2 11:01:13.681: BR0:1 CHAP: I CHALLENGE id 196 len 23 from "r5"
>.Mar 2 11:01:13.689: BR0:1 CHAP: O RESPONSE id 196 len 23 from "r2"
>.Mar 2 11:01:13.709: BR0:1 CHAP: I SUCCESS id 196 len 4
>.Mar 2 11:01:13.773: ISDN BR0: RX <- DISCONNECT pd = 8 callref = 0x85
>.Mar 2 11:01:13.777: Cause i = 0x8090 - Normal call clearing
>.Mar 2 11:01:13.793: %ISDN-6-DISCONNECT: Interface BRI0:1 disconnected
>from 8358662 , call lasted 4 seconds
>.Mar 2 11:01:13.797: %LINK-3-UPDOWN: Interface BRI0:1, changed state to
>down
>.Mar 2 11:01:13.829: %DIALER-6-UNBIND: Interface BRI0:1 unbound from
>profile Dialer1
>.Mar 2 11:01:13.837: ISDN BR0: TX -> RELEASE pd = 8 callref = 0x05
>.Mar 2 11:01:13.853: ISDN BR0: RX <- RELEASE_COMP pd = 8 callref = 0x85
>r2#
>.Mar 2 11:01:22.785: ISDN BR0: RX <- SETUP pd = 8 callref = 0x0E
>.Mar 2 11:01:22.785: Bearer Capability i = 0x8890
>.Mar 2 11:01:22.789: Channel ID i = 0x89
>.Mar 2 11:01:22.793: Calling Party Number i = 0x80, '8358662'
>.Mar 2 11:01:22.801: %DIALER-6-BIND: Interface BRI0:1 bound to profile
>Dialer1
>.Mar 2 11:01:22.805: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
>r2#
>.Mar 2 11:01:22.837: BR0:1 PPP: Treating connection as a callin
>.Mar 2 11:01:22.849: ISDN BR0: TX -> CONNECT pd = 8 callref = 0x8E
>.Mar 2 11:01:22.853: Channel ID i = 0x89
>.Mar 2 11:01:22.961: ISDN BR0: RX <- CONNECT_ACK pd = 8 callref = 0x0E
>r2#
>.Mar 2 11:01:26.889: BR0:1 PPP: Phase is AUTHENTICATING, by the peer
>.Mar 2 11:01:26.901: BR0:1 CHAP: I CHALLENGE id 197 len 23 from "r5"
>.Mar 2 11:01:26.909: BR0:1 CHAP: O RESPONSE id 197 len 23 from "r2"
>.Mar 2 11:01:26.933: BR0:1 CHAP: I SUCCESS id 197 len 4
>r2#
>.Mar 2 11:01:27.865: %LINEPROTO-5-UPDOWN: Line protocol on Interface
>BRI0:1, changed state to up
>r2#
>.Mar 2 11:01:28.837: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to
>8358662 8358662
>r2#
>.
This archive was generated by hypermail 2.1.4 : Fri Jan 17 2003 - 17:21:48 GMT-3